LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Help with Suse 10.0 wifi desperately needed (http://www.linuxquestions.org/questions/suse-novell-60/help-with-suse-10-0-wifi-desperately-needed-427259/)

crh112 03-22-2006 08:17 AM

Help with Suse 10.0 wifi desperately needed
 
Hello

I have a dell inspiron 6000 laptop with an intel 2200bg wifi adapter. There are loads of posts on this all over the place but i cant seem to find anything to help me.

Anyway im a complete noob so this is my problem. I have a fresh install of suse 10 and cant get my wifi to work. Yast recognises my wifi card but thats about it. The only network interface appears to be eth0 my 10/100 (which does work else i would be completly stuck without net access). I have downloaded the firmware from ipw2200.sourceforge.net and dropped them in /lib/firmware. I then ran modprobe ipw2200 but it doesnt appear to do anything.

Anyone got any ideas

Help would be much appreciated, let me know whatever extrat information you require.

Chris

emg 03-22-2006 09:48 AM

Quote:

Originally Posted by crh112
Hello

I have a dell inspiron 6000 laptop with an intel 2200bg wifi adapter. There are loads of posts on this all over the place but i cant seem to find anything to help me.

Anyway im a complete noob so this is my problem. I have a fresh install of suse 10 and cant get my wifi to work. Yast recognises my wifi card but thats about it. The only network interface appears to be eth0 my 10/100 (which does work else i would be completly stuck without net access). I have downloaded the firmware from ipw2200.sourceforge.net and dropped them in /lib/firmware. I then ran modprobe ipw2200 but it doesnt appear to do anything.

Anyone got any ideas

Help would be much appreciated, let me know whatever extrat information you require.

Chris

I'm not familiar with your wireless card but a couple of ideas, when you did the modprobe of the ipw2200 was there any errors? If not in a konsole type lsmod | grep ipw and see if the module is in fact loaded. Also if you run YOU I think there is an option to download the firmware for your card, I prefer to use the system tools. If the module is loaded then go into yast and setup your card there. If its your main access to your router/modem then set it to activate on boot. After that you can do ifdown eth0 ifup wlan0 (in konsole). Be sure to shutdown eth0 before you bring up wlan0.

Hope I've given you a couple of things to try, good luck!!

onjoo 03-22-2006 09:55 AM

The centrino wlan(ipw2100/2200/2195) thingy is "supported" , but due to a license problems they can't include the ipw-firmware.-package to make it operational.

Yes you can see the card in the network adapter list, but cannot use it or configurate it.

Solution :
Download package from here ftp://ftp.gwdg.de/pub/linux/suse/ftp...5-6.noarch.rpm
Install it with Yast or with "rpm -ivh package.rpm" (must be done by root)
Reboot
Log in and configure your card

crh112 03-22-2006 12:31 PM

Thanks. The rpm seems to do the trick. All works with no extra effort required.

Thanks for your help


All times are GMT -5. The time now is 07:28 AM.