LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 12-03-2004, 09:03 AM   #1
munkus.agb
LQ Newbie
 
Registered: Dec 2004
Posts: 4

Rep: Reputation: 0
Question Help - USB flash memory stick and hard drive


I am using SuSe 9.1 pro and Windows XP on the same computer

the first time I used my usb memory stick it worked fine, as did the external hard drive but they now won't work

There is a folder for each of them on the desk top but these are empty when opened and the devices do not respond

in the suse plugger thing, the memory stick is recognised but that is as far as it gets, aldo I cannot eject it - comes up with a message saying the device does not exist

I am new to linux so can't give you much more info

Please help

Last edited by munkus.agb; 12-03-2004 at 09:05 AM.
 
Old 12-03-2004, 11:00 AM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Have a look at the output of dmesg after you plugged-in the drives. It should show you in the last lines, if it has been recognized correctly.
 
Old 12-06-2004, 09:18 AM   #3
dkpw
Member
 
Registered: Sep 2003
Location: Scotland
Distribution: LinuxMint16 & Ubuntu 12.0.4 LTS
Posts: 218

Rep: Reputation: 30
Hi munkus.agb

Please check out all the details in this thread, where the USB problem in 9.1 is fully discussed and resolved.

http://www.linuxquestions.org/questi...readid=179440.


Or for the condensed version:
Follow the advice here:
http://portal.suse.com/sdb/en/2004/...from_subfs.html

I switched off HOTPLUG_USE_SUBFS as recommended in /etc/sysconfig/hotplug.

I added the following line to my /etc/fstab:

/dev/sda1 /media/gizmo auto noauto,users,rw 0 0

I then manually created the directory /media/gizmo. After a restart I created a new desktop device, pointed it to the /media/gizmo directory and plugged in the USB stick, right clicked the drive on the desktop and it mounted like a charm, first time and no moaning.

That should do it. BTW 9.2 does not have the problem!

Regards

dkpw
 
Old 12-15-2004, 06:51 AM   #4
munkus.agb
LQ Newbie
 
Registered: Dec 2004
Posts: 4

Original Poster
Rep: Reputation: 0
USB drives

Hi again

I have found out that my Iomega Zip100 drive is detected and will mount with no problem in suse 9.1 pro but my USB flash memory stick and USB hard drive still won't?????

Alex
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
removable usb storage drive (memory stick) christel Linux - Newbie 7 11-17-2006 04:18 AM
Missing memory in USB stick, flash memory, removable hd etc bamboo_spider Linux - Newbie 3 06-14-2006 06:39 PM
Can't mount USB memory stick/pen drive wellmt Slackware 11 06-25-2004 03:10 AM
How do I mount a USB flash memory stick? brian Linux - Newbie 3 02-07-2004 03:49 PM
USB 2.0 Flash Memory Drive Malakh Linux - Hardware 16 11-06-2003 06:07 AM


All times are GMT -5. The time now is 08:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration