LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 11-12-2004, 06:47 PM   #1
MisterESauce
Member
 
Registered: Nov 2004
Distribution: FC3 dualboot with XP on my main machine, Slackware 9 on my POS ;)
Posts: 30

Rep: Reputation: 15
Help installing GCC on SuSE 9.1


Hey guys, I'm a total linux and I'm having problems installing GCC. I've downloaded and untarred the package and I try to configure it with the ./configure command but I get this error:

./configure
creating cache ./config.cache
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking build system type... i686-pc-linux-gnu
checking for a BSD compatible install... /usr/bin/install -c
/gcc3/gcc-3.4.3/./configure: line 2332: cc: command not found
*** The command 'cc -o conftest -g conftest.c' failed.
*** You must set the environment variable CC to a working compiler.

How can I set the environment variable to a working compiler if I don't HAVE a working compiler (hence needing to install GCC)? I'm running a new install of SuSE 9.1 Personal.

Any help is good help! Thanks,
Elliott
 
Old 11-12-2004, 09:56 PM   #2
crabboy
Moderator
 
Registered: Feb 2001
Location: Atlanta, GA
Distribution: Slackware
Posts: 1,823

Rep: Reputation: 120Reputation: 120
Looks like you have downloaded the souce package for gcc. That requires that you compile it.

You will need to grab a binary version and install it. I'd suggest the ones off your SuSE CD. The 9.1 version I'm using now came with 3.3.3
 
Old 11-13-2004, 04:22 AM   #3
MisterESauce
Member
 
Registered: Nov 2004
Distribution: FC3 dualboot with XP on my main machine, Slackware 9 on my POS ;)
Posts: 30

Original Poster
Rep: Reputation: 15
Okay, so I'm gonna have to install it from binary then? Unfortunately I'm pretty sure those files aren't included on my install CD because I have the personal version... Some place on the web I could find them?
 
Old 11-15-2004, 11:55 PM   #4
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Several options...

Hi -

You're correct on both counts: a) you are going to need the binaries, and b) SusE Personal doesn't come with gcc.

You have many choices, however:

1. You should be able to go into Control Center, Yast2, Install/Remove software; point to SuSE's FTP site, and download automagically from there.

2. You can also do a "google" search for an Linux binary for gcc on the web.

A SuSE 9.1 binary would obviously be ideal, but, strictly speaking, *any* gcc binary for Linux might be
"good enough".

'Hope that helps .. PSM
 
Old 11-16-2004, 11:21 AM   #5
MisterESauce
Member
 
Registered: Nov 2004
Distribution: FC3 dualboot with XP on my main machine, Slackware 9 on my POS ;)
Posts: 30

Original Poster
Rep: Reputation: 15
Cool, thanks a lot guys!
 
Old 11-16-2004, 03:56 PM   #6
Napalm Llama
Member
 
Registered: Nov 2004
Location: Bristol, UK
Distribution: Gentoo 2005.0
Posts: 224

Rep: Reputation: 30
I'm in pretty much the same predicament as you - I can't find GCC on YOU, but I've found an excellent RPM archive:

rpmfind.net

Just enter GCC into the search box, scroll down until you find the yellow-hilighted files (the SuSE ones) and get the i586 version, not the src... (and get the first ones - the lower-down ones are for earlier SuSE versions!)

It's just over 1mb. My SuSE 9.1 (presumably yours is the same) has binutils pre-installed, but YaST doesn't list glibc-devel precicely - only plain old glibc. I'm downloading the devel version just to be on the safe side - it's about 6mb. (You need these packages to support GCC.)

I say 'excellent RPM archive' - I haven't installed the package yet. I'll keep you posted.

Sorry if this post seems a bit fragmented - I'm very tired...


EDIT: The RPMs seem to work, although I downloaded a different version of glibc-delev from the glibc I have - so I'm now downloading the compatable glibc (1.4mb)...
I'll let you know if they install OK once I've got it!



EDIT: Arrrrggghh! My Linux *really* doesn't like me trying to install the older version over the newer version, (92, count 'em, 92 conflicts!), so I'm now downloading this:
ftp://fr.rpmfind.net/linux/SuSE-Linu....3-97.i686.rpm
which is the new version of glibc-devel (which IS needed on top of ordinary glibc) and which isn't listed on the rpmfind.net search for some reason. I just Googled the exact file name. The page for it no longer exists on the server, but Google had a cached version, and for some reason the RPM is still there. 10.1mb

This post is turning into a blog...
I'm colour-coding my EDITs for ease of reading... and when I've finally got GCC up and working, I'll give a list of files that need downloadig, things that need doing - a general walkthrough to getting this thing installed on SuSE Personal 9.1.


EDIT: Aww... I have cpp-3.3.3-41... it wants 3.3.1-29... I'm going to leave it for the night. All this downloading is annoying over dialup, but it could be worse - I could have a broadband line with a download limit...

Last edited by Napalm Llama; 11-16-2004 at 06:09 PM.
 
Old 11-17-2004, 03:22 PM   #7
Napalm Llama
Member
 
Registered: Nov 2004
Location: Bristol, UK
Distribution: Gentoo 2005.0
Posts: 224

Rep: Reputation: 30
OK. I've installed GCC without any further hitches.

Turns out that for SuSE Personal 9.1, you need to download the following two packages:

glibc-devel-2.3.3-97
gcc-3.3.3-41

and install them in that order.

glibc-del-2.3.3-97 can be obtained from HERE

gcc-3.3.3-41 can be obtained from HERE

just open a terminal window in the directory you downloaded the files to (make sure there are no spaces in the path, or things will go wrong), and do the following:

Code:
su
<your_root_password>
rpm -i glibc-del-2.3.3-97.rpm
rpm -i gcc-3.3.3-41
exit
exit
And you're done!


[EDIT] ...You can now use the ./configure step of the install process, but chances are you won't be able to use make... please bear with me

[EDIT]OK, it looks like you can get make-3.80-184 from here:
http://www.mirrorservice.org/sites/f...0-184.i586.rpm

and for a pifflling 15kb more, you can have makedev-2.6-403 from here:
http://www.mirrorservice.org/sites/f...6-403.i586.rpm

I don't know whether you need it, but it may come in useful at some point...


[EDIT] It's now advising me to install automake and perl...
automake-1.8.3-23 can be obtained from:
http://www.mirrorservice.org/sites/f....3-23.i586.rpm

perl is already on the system.

I'm going to stop giving these web addresses, because they're all pretty much the same. If you go to the SuSE website, and find the FTP mirrors section (within Downloads), get the mirrow closest to where you are and navigate to your version of SuSE - everything is there in RPMs - it really couldn't be easier. I should also point out that the mirrorservice.org sites are a UK mirror - if you're from elsewhere, I suggest finding a different one.

I bet a load of the more experienced users are having a right old laugh about this thread - "A newbie's struggle to compile something - anything! - from source"

Last edited by Napalm Llama; 11-17-2004 at 04:15 PM.
 
Old 11-18-2004, 05:23 PM   #8
Napalm Llama
Member
 
Registered: Nov 2004
Location: Bristol, UK
Distribution: Gentoo 2005.0
Posts: 224

Rep: Reputation: 30
OK, I've got stuck.. I really need help here from more experienced users!

make seems to hate me. After a successful configure step, this was its output:

Code:
Making all in src
make[1]: Entering directory `/usr/local/supertux/src'
source='badguy.cpp' object='badguy.o' libtool=no \
depfile='.deps/badguy.Po' tmpdepfile='.deps/badguy.TPo' \
depmode=none /bin/sh ../depcomp \
g++ -DPACKAGE_NAME=\"SuperTux\" -DPACKAGE_TARNAME=\"supertux\" -DPACKAGE_VERSION=\"0.1.2\" -DPACKAGE_STRING=\"SuperTux\ 0.1.2\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"supertux\" -DVERSION=\"0.1.2\" -DHAVE_DIRENT_H=1 -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_UNISTD_H=1 -DHAVE_LIBSDL_MIXER=1 -DHAVE_LIBSDL_IMAGE=1 -DHAVE_PTHREAD=1 -DHAVE_LIBZ=1 -DHAVE_MKDIR=1 -DHAVE_STRDUP=1 -DHAVE_STRSTR=1  -I. -I.     -Wall -W -DDEBUG -O0 -g3 -I/usr/include/SDL -D_REENTRANT -DNOOPENGL -DDATA_PREFIX='"/usr/local/share/supertux"' -c -o badguy.o badguy.cpp
../depcomp: line 470: exec: g++: not found
make[1]: *** [badguy.o] Error 127
make[1]: Leaving directory `/usr/local/supertux/src'
make: *** [all-recursive] Error 1
I got a very similar error (Error 127 and something to do with g++) while trying to make tuxkart.

I have gcc-3.3.3-41, which I'm told includeds g++. What's going on, and how do I fix it? I'd be happy to provide more information if it's needed.

If people think I'd be better off re-posting this question in a new topic, by all means say.

Last edited by Napalm Llama; 11-18-2004 at 05:24 PM.
 
Old 11-18-2004, 10:06 PM   #9
winsnomore
Member
 
Registered: May 2004
Location: USA
Distribution: #1 PCLinuxOS -- for laughs -> Ubuntu, Suse, Mepis
Posts: 315

Rep: Reputation: 31
I don't klnow what you are REALLY trying to do.
I suggest you don't resort to Compiling gcc .. it's not necessary .. and could be a problem if you
kernel was compiled with a different version .. so you should use the source mirrors for it.

To install gcc on Personal 9.1 follow the following.

use YaST2

Select to change the source ..
- Select to Add a source
- Add the HTTP or FTP mirror (some how FTP never worked for me)
- in the Source enther the name of the mirror ... like xxx.yyy.zzz
in the folder .. enter the directory suse/whatever----/9.1 (don't point below this)

let it accept the source.

now go to add/remove software on the YAST.
when window opens on the left .. type gcc and let it find all the packages.
click on all the found packages and hit accept and it it will install it.

That's the only sane way .. other ways are way to involved with suse.

hope this helps
 
Old 11-19-2004, 03:02 PM   #10
Napalm Llama
Member
 
Registered: Nov 2004
Location: Bristol, UK
Distribution: Gentoo 2005.0
Posts: 224

Rep: Reputation: 30
Thanks for the reply, but I think I solved the GCC thing myself... but then again I might not have done. I grabbed the latest GCC rpm off the SuSE servers, and also all the extra packages it needed to install. I've not yet come across a configure script with errors that can't be solved by installing new packages... (I'm sure there are plenty out there! )... but it's when i run make that the errors appear. It can't find g++ (even though the configure script uses GCC to compile) and it returns an error 127.

It's the output of make that I quoted in my post just now.

I don't know how much relevance this now has to the original point of the thread, but I think it's worthwhile putting it here, because as far as I can tell this is a problem that anyone with this copy of SuSE is likely to come across, and if they perform a search, it'll be useful for them to have all the answers in one place.

Last edited by Napalm Llama; 11-19-2004 at 03:41 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't compile simple C++ programs on Suse 9.1 after installing gcc cyclebain Linux - Software 9 07-04-2007 08:04 AM
Installing gcc and g++ on suse 9.1 enigmatic Linux - Software 7 09-05-2005 08:05 PM
Installing GCC SUSE 9.1 jonwatson Suse/Novell 13 11-01-2004 05:38 PM
Installing GCC 3.4.2 w/ SUSE 9.1 personal justin0820 Linux - Newbie 1 10-05-2004 04:33 PM
Installing GCC on SuSE 9.1 Kiajin Linux - Newbie 4 07-13-2004 11:23 PM


All times are GMT -5. The time now is 01:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration