LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Help getting libusb 0.1.12 installed... (http://www.linuxquestions.org/questions/suse-novell-60/help-getting-libusb-0-1-12-installed-458315/)

003 06-26-2006 12:32 AM

Help getting libusb 0.1.12 installed...
 
I downloaded libusb 0.1.12 from here:
http://libusb.sourceforge.net/

When I do ./configure, I get this near the end:
Code:

checking for Doxygen tools... checking for dot... not found
checking for doxygen... not found
configure: WARNING: Documentation build components not installed. sgml docs will not be built

Looking in the readme, I see this:
Code:

One common problem is building the SGML documentation. On some systems,
like SuSE, you will need to set the SGML_CATALOG_FILES environment
variable to something similar to this (actual paths may vary):

export SGML_CATALOG_FILES="/usr/share/sgml/CATALOG.docbook_3:/usr/share/sgml/CATALOG.docbook-dsssl-stylesheets:/usr/share/sgml/openjade/catalog"

So I tried putting in that command and it seemed to work (didn't produce an error), but the ./configure still gave the same result. If I try to do a make, I get this:

Code:

make  all-recursive
make[1]: Entering directory `/home/alester/Downloads/libusb-0.1.12'
Making all in .
make[2]: Entering directory `/home/alester/Downloads/libusb-0.1.12'
if /bin/sh ./libtool --mode=compile /home/alester/Downloads/libusb-0.1.12/compile gcc -DHAVE_CONFIG_H  -I.  -Werror  -g -O2 -g -Wall -MT usb.lo -MD -MP -MF ".deps/usb.Tpo" -c -o usb.lo usb.c; \
then mv -f ".deps/usb.Tpo" ".deps/usb.Plo"; else rm -f ".deps/usb.Tpo"; exit 1; fi
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make[2]: *** [usb.lo] Error 1
make[2]: Leaving directory `/home/alester/Downloads/libusb-0.1.12'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/alester/Downloads/libusb-0.1.12'
make: *** [all] Error 2

How can I get libusb installed? I really need it. Please help me.

Bugrem 06-26-2006 05:19 PM

Are you sure that libusb isn't already installed (whereis libusb). I thought it was installed by default. I'd use Yast/Software Management to install from CD/DVD.

HTH
B.

pilotgi 06-26-2006 05:21 PM

Why don't you install the rpm from the SUSE disc?

To check if it's already installed, type rpm -qi libusb

003 06-26-2006 06:09 PM

Yes it's already installed but I need a newer version for RazerTool to work:
http://razertool.sourceforge.net/

Bugrem 06-26-2006 06:28 PM

You can get libusb-0.1.12-7.i586.rpm from:
http://ftp.opensuse.org/pub/opensuse...rce/suse/i586/

B.

003 06-26-2006 07:24 PM

Ok, thats really confusing. When I try installing that it says it's already installed. So why do I get this when I do a ./configure of RazerTool:

Code:

checking for libusb... configure: error: Package requirements (libusb >= 0.1.0) were not met:

No package 'libusb' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables libusb_CFLAGS
and libusb_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Can anybody please help me get it working? I really need it.

Bugrem 06-27-2006 02:31 PM

Suse probably hasn't put libusb where razor expects to find it.

If you don't mind being slightly behind bleeding-edge, v2.72-2 is available from Suse via Yast. It also satisfies the various perl dependencies.

Failing that, rpmfind.net reckon they have v2.12-4 which is odd..... But you'll have to satisfy your own dependencies.

Maybe install the Suse version, then update razor to v"2.12-4" from rpmfind with kpackage?

Yast/Installation Source to v2.72-2:

http source
Server:
ftp.opensuse.org
Directory:
pub/opensuse/distribution/SL-10.0-OSS/inst-source/

HTH
B.

elvanor 07-15-2006 03:45 PM

Hello. I managed to get razertool to compile.

I did not bother with the pkg-config stuff cause I don't know what this is.

But If you put the correct settings in the environment variables, as said, it will work.

What I did was: export libusb_CFLAGS="-llibusb" (this has in fact no effect, but it needs to be there for ./configure to work.

and

export libusb_LIBS="/usr/lib64/libusb.so"

In this last line you must provide the full path to YOUR libusb (where you installed libusb).

After that ./configure runs correctly, and make works. I have tested the program and it works.

I am on Gentoo AMD64.

Hope that helps,

Elvanor


All times are GMT -5. The time now is 03:38 AM.