LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-05-2007, 10:02 AM   #1
levi_s
LQ Newbie
 
Registered: Mar 2007
Location: Jerusalem, Israel
Distribution: CentOS 5.3
Posts: 13

Rep: Reputation: 0
Exclamation Help a Noob! VIA chipset driver help - video


Hello all. I am not only new to this group but new to linux in general. 20 years ago i used to have a DOS machine but unfortuanately i have forgotten most of what i ever knew about command line OS's. My problem is this. >> Having finally tired of the strangle-hold microsoft has on my computer in addition to the fact that i can't seem to go more than a couple months without having to re-install XP, i am trying to make the switch to linux. with that in mind i have done some research and settled upon openSuSE 10.2 as my platform of choice. My problem is this > for 3 days now, i have been reading and trying to find out how to get my onboard graphic chipset to work [chipset in question= VIA K8M800 on a gigabyte GA-K8VM800M (r.2) motherboard]... i have tried numerous howto's to no avail, in the last day i have finally managed to figure out how to get subversion working and i have installed every package that contains the word "xorg" onto my system. i have been trying to follow this tut <a href="http://wiki.openchrome.org/tikiwiki/tiki-index.php?page=Compiling+the+source+code">here</a> and it just refuses to comply. my latest and greates attempt ended like this:
----------------------------------------------
linux-ddi-me1:~ # cd openchrome
linux-ddi-me1:~/openchrome # svn co http://svn.openchrome.org/svn/trunk
A trunk/configure.ac
A trunk/l...
[edited for content]
...k/unichrome/via_ch7xxx.h
A trunk/autogen.sh
A trunk/man
A trunk/man/Makefile.am
Checked out revision 298.
linux-ddi-me1:~/openchrome # cd trunk
linux-ddi-me1:~/openchrome/trunk # ./autogen.sh
./autogen.sh: line 9: autoreconf: command not found
linux-ddi-me1:~/openchrome/trunk # dir
total 104
drwxr-xr-x 6 root root 4096 Mar 5 16:48 .svn
-rw-r--r-- 1 root root 49070 Mar 5 16:48 ChangeLog
-rw-r--r-- 1 root root 1181 Mar 5 16:48 Makefile.am
-rw-r--r-- 1 root root 3766 Mar 5 16:48 acinclude.m4
-rwxr-xr-x 1 root root 195 Mar 5 16:48 autogen.sh
-rw-r--r-- 1 root root 5263 Mar 5 16:48 configure.ac
drwxr-xr-x 3 root root 4096 Mar 5 16:48 libxvmc
drwxr-xr-x 3 root root 4096 Mar 5 16:48 man
-rwxr-xr-x 1 root root 18277 Mar 5 16:48 prepare-ChangeLogSVN.pl
drwxr-xr-x 3 root root 4096 Mar 5 16:48 unichrome
linux-ddi-me1:~/openchrome/trunk # /autogen.sh
bash: /autogen.sh: No such file or directory
linux-ddi-me1:~/openchrome/trunk # autogen.sh
bash: autogen.sh: command not found
linux-ddi-me1:~/openchrome/trunk # make
make: *** No targets specified and no makefile found. Stop.
linux-ddi-me1:~/openchrome/trunk # make install
make: *** No rule to make target `install'. Stop.
linux-ddi-me1:~/openchrome/trunk #
--------------------------------------------------------------

a number of problems after the install of the trunk as you can see. plus, i still do not have a /usr/lib/xorg/modules/drivers/ folder on my system... now, according to the tut, it should already be there?? or do i have to create a xorg folder in the usr/lib folder??

i am really begininning to get frustrated and without the new driver my computer display is reminiscent of the 286 i once used back 20 years ago.

any help would be greatfully appreciated.

Thanks,
Levi
 
Old 03-06-2007, 03:59 AM   #2
BruceCadieux
Member
 
Registered: Apr 2002
Location: Wales MA.
Distribution: openSuSE 11.1
Posts: 409

Rep: Reputation: 32
You only need to install one file, then edit your xorg.conf file.

The file and instructions are here http://www.logix.cz/michal/devel/suse-openchrome/
 
Old 03-06-2007, 10:51 AM   #3
levi_s
LQ Newbie
 
Registered: Mar 2007
Location: Jerusalem, Israel
Distribution: CentOS 5.3
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks... however,

Thanks for the link... it seems to have worked, however i can not figure out how to Start Xorg. I have an X server module in my applications folder... but it seems to be just a reference... it doesn't give you an option to start the service or edit any of the data.

I am going to try a reboot now and see if it starts automatically.

Thanks, and any further help would be great.
 
Old 03-06-2007, 10:58 AM   #4
levi_s
LQ Newbie
 
Registered: Mar 2007
Location: Jerusalem, Israel
Distribution: CentOS 5.3
Posts: 13

Original Poster
Rep: Reputation: 0
it's working!

So far so good... thank you . the reboot took care of it. firefox is now working like normal i can scroll and browse at normal speeds. the next thing i need to do ios see if the 3d is working... i'll keep you posted.

Thanks again,
Levi
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
910GML intel chipset and x-video cyberia_2ooo Linux - Laptop and Netbook 5 11-09-2005 06:50 AM
Best supported video card chipset? bendeco13 Linux - Hardware 3 10-10-2004 09:55 PM
Video Driver Poblems with Red Hat 8.0 (trident video driver) AstroJim Linux - Newbie 1 05-20-2004 03:25 PM
Chipset on Ultra60 video card kaplan71 Solaris / OpenSolaris 1 12-10-2003 02:24 AM
trying to start X with onboard video chipset starlight Linux - Software 3 11-27-2001 04:27 AM


All times are GMT -5. The time now is 07:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration