LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 08-11-2007, 11:17 AM   #1
jst4fun
LQ Newbie
 
Registered: Feb 2007
Posts: 18

Rep: Reputation: 0
Question Headphone problem on Acer 5583N running opensuse 10.2


Hi,
I recently installed opensuse 10.2 on Acer 5583 laptop. The issue is even if I have inserted the jack of my headphone to the laptop I can hear voice from both the laptop speakers and also the headphone which should not be happening. I am not facing any such issues when I tried it on Windows. Is there any workaround for this? Thanks
 
Old 08-11-2007, 07:06 PM   #2
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
There could be several possible issues here. Could you run http://bulletproof.servebeer.com/als...s/alsa-info.sh and post the resulting link for debugging?

It could be something simple, like an updated driver. it could also mean a driver hasn't been implemented yet. This will help me to review the driver code to see where you are support wise.
 
Old 08-12-2007, 11:40 AM   #3
jst4fun
LQ Newbie
 
Registered: Feb 2007
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks GrueMaster for your reply. I did the test and the result is now available at http://pastebin.ca/654612. Please go through it. Thanks once again
 
Old 08-12-2007, 12:08 PM   #4
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
After a very brief (~20 seconds) review of your information, I can tell you that you are supported, but you will need to upgrade your alsa installation. You are currently running 1.0.12rc1 (very old in alsa terms). Your system is supported in 1.0.14.

There are two ways that I know of that you can use to upgrade your alsa drivers (without installing a different distribution). The first is to download the latest drivers from http://alsa-project.org, the second is to download my build environment and use it to create rpm packages for openSuse (the distribution you are currently running). To use my build environment, you will need to install the kernel-source or kernel-devel packages, rpmbuild, and other basic kernel build tools. Yast should be able to figure out what all you need. Once you have the tools in place, just untar my build environment, and run make as root from inside it's top directory (./my-build). Then run audio-install to install the packages.

Tobin
 
Old 08-13-2007, 03:41 AM   #5
jst4fun
LQ Newbie
 
Registered: Feb 2007
Posts: 18

Original Poster
Rep: Reputation: 0
i tried what you asked me to do. I a getting following errors while running make
Code:
RPM build errors:
 user tobind does not exist - using root
    group tobind does not exist - using root
    user tobind does not exist - using root
    group tobind does not exist - using root
    Installed (but unpackaged) file(s) found:
   /usr/lib/alsa-lib/smixer/smixer-ac97.la
   /usr/lib/alsa-lib/smixer/smixer-ac97.so
   /usr/lib/alsa-lib/smixer/smixer-hda.la
   /usr/lib/alsa-lib/smixer/smixer-hda.so
   /usr/lib/alsa-lib/smixer/smixer-sbase.la
   /usr/lib/alsa-lib/smixer/smixer-sbase.so
   /usr/share/alsa/alsa.conf
   /usr/share/alsa/cards/AACI.conf
   /usr/share/alsa/cards/ATIIXP-MODEM.conf
   /usr/share/alsa/cards/ATIIXP-SPDMA.conf
   /usr/share/alsa/cards/ATIIXP.conf
   /usr/share/alsa/cards/AU8810.conf
   /usr/share/alsa/cards/AU8820.conf
   /usr/share/alsa/cards/AU8830.conf
   /usr/share/alsa/cards/Audigy.conf
   /usr/share/alsa/cards/Audigy2.conf
   /usr/share/alsa/cards/Aureon51.conf
   /usr/share/alsa/cards/Aureon71.conf
   /usr/share/alsa/cards/CA0106.conf
   /usr/share/alsa/cards/CMI8338-SWIEC.conf
   /usr/share/alsa/cards/CMI8338.conf
   /usr/share/alsa/cards/CMI8738-MC6.conf
   /usr/share/alsa/cards/CMI8738-MC8.conf
   /usr/share/alsa/cards/CS46xx.conf
   /usr/share/alsa/cards/EMU10K1.conf
   /usr/share/alsa/cards/EMU10K1X.conf
   /usr/share/alsa/cards/ENS1370.conf
   /usr/share/alsa/cards/ENS1371.conf
   /usr/share/alsa/cards/ES1968.conf
   /usr/share/alsa/cards/FM801.conf
   /usr/share/alsa/cards/GUS.conf
   /usr/share/alsa/cards/HDA-Intel.conf
   /usr/share/alsa/cards/ICE1712.conf
   /usr/share/alsa/cards/ICE1724.conf
   /usr/share/alsa/cards/ICH-MODEM.conf
   /usr/share/alsa/cards/ICH.conf
   /usr/share/alsa/cards/ICH4.conf
   /usr/share/alsa/cards/Maestro3.conf
   /usr/share/alsa/cards/NFORCE.conf
   /usr/share/alsa/cards/PC-Speaker.conf
   /usr/share/alsa/cards/PMac.conf
   /usr/share/alsa/cards/PMacToonie.conf
   /usr/share/alsa/cards/RME9636.conf
   /usr/share/alsa/cards/RME9652.conf
   /usr/share/alsa/cards/SI7018.conf
   /usr/share/alsa/cards/SI7018/sndoc-mixer.alisp
   /usr/share/alsa/cards/SI7018/sndop-mixer.alisp
   /usr/share/alsa/cards/TRID4DWAVENX.conf
   /usr/share/alsa/cards/USB-Audio.conf
   /usr/share/alsa/cards/VIA686A.conf
   /usr/share/alsa/cards/VIA8233.conf
   /usr/share/alsa/cards/VIA8233A.conf
   /usr/share/alsa/cards/VIA8237.conf
   /usr/share/alsa/cards/VX222.conf
   /usr/share/alsa/cards/VXPocket.conf
   /usr/share/alsa/cards/VXPocket440.conf
   /usr/share/alsa/cards/YMF744.conf
   /usr/share/alsa/cards/aliases.alisp
   /usr/share/alsa/cards/aliases.conf
   /usr/share/alsa/pcm/center_lfe.conf
   /usr/share/alsa/pcm/default.conf
   /usr/share/alsa/pcm/dmix.conf
   /usr/share/alsa/pcm/dpl.conf
   /usr/share/alsa/pcm/dsnoop.conf
   /usr/share/alsa/pcm/front.conf
   /usr/share/alsa/pcm/iec958.conf
   /usr/share/alsa/pcm/modem.conf
   /usr/share/alsa/pcm/rear.conf
   /usr/share/alsa/pcm/side.conf
   /usr/share/alsa/pcm/surround40.conf
   /usr/share/alsa/pcm/surround41.conf
   /usr/share/alsa/pcm/surround50.conf
   /usr/share/alsa/pcm/surround51.conf
   /usr/share/alsa/pcm/surround71.conf
   /usr/share/alsa/smixer.conf
   /usr/share/alsa/sndo-mixer.alisp
make: *** [alsa-lib-1.0.14-nld.i386.rpm] Error
Did i miss any packages that need to be installed or should I remove the old alsa installation? Thanks
 
Old 08-13-2007, 08:58 AM   #6
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
Oops. My bad. I had forgotten to update alsa-lib to 1.0.14a. There was a bug with alsa-lib-1.0.14. I did a build test and it should work now. Re-download my build environment and try again.
 
Old 08-14-2007, 01:19 PM   #7
jst4fun
LQ Newbie
 
Registered: Feb 2007
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks for your reply. I downloaded the latest build and tried compiling it. I am getting a new error now.
Code:
error: cannot open common_source_rpms/alsa-lib-1.0.14-1.src.rpm: No such file or directory
make: *** [alsa-lib-1.0.14a-nld.i386.rpm] Error 1
I hope you would be able to figure out where I went wrong. Thanks.
 
Old 08-14-2007, 01:34 PM   #8
jst4fun
LQ Newbie
 
Registered: Feb 2007
Posts: 18

Original Poster
Rep: Reputation: 0
I think I figured out the issue. It was a missing 'a' in the makefile at lines 72,73,77 after "alsa-lib-1.0.14".I am not getting the reported error once it was rectified, but I am getting another error
Code:
RPM build errors:
    user tobind does not exist - using root
    group tobind does not exist - using root
    user tobind does not exist - using root
    group tobind does not exist - using root
    Installed (but unpackaged) file(s) found:
   /usr/lib/alsa-lib/smixer/smixer-ac97.la
   /usr/lib/alsa-lib/smixer/smixer-ac97.so
   /usr/lib/alsa-lib/smixer/smixer-hda.la
   /usr/lib/alsa-lib/smixer/smixer-hda.so
   /usr/lib/alsa-lib/smixer/smixer-sbase.la
   /usr/lib/alsa-lib/smixer/smixer-sbase.so
   /usr/share/alsa/alsa.conf
   /usr/share/alsa/cards/AACI.conf
   /usr/share/alsa/cards/ATIIXP-MODEM.conf
   /usr/share/alsa/cards/ATIIXP-SPDMA.conf
   /usr/share/alsa/cards/ATIIXP.conf
   /usr/share/alsa/cards/AU8810.conf
   /usr/share/alsa/cards/AU8820.conf
   /usr/share/alsa/cards/AU8830.conf
   /usr/share/alsa/cards/Audigy.conf
   /usr/share/alsa/cards/Audigy2.conf
   /usr/share/alsa/cards/Aureon51.conf
   /usr/share/alsa/cards/Aureon71.conf
   /usr/share/alsa/cards/CA0106.conf
   /usr/share/alsa/cards/CMI8338-SWIEC.conf
   /usr/share/alsa/cards/CMI8338.conf
   /usr/share/alsa/cards/CMI8738-MC6.conf
   /usr/share/alsa/cards/CMI8738-MC8.conf
   /usr/share/alsa/cards/CS46xx.conf
   /usr/share/alsa/cards/EMU10K1.conf
   /usr/share/alsa/cards/EMU10K1X.conf
   /usr/share/alsa/cards/ENS1370.conf
   /usr/share/alsa/cards/ENS1371.conf
   /usr/share/alsa/cards/ES1968.conf
   /usr/share/alsa/cards/FM801.conf
   /usr/share/alsa/cards/GUS.conf
   /usr/share/alsa/cards/HDA-Intel.conf
   /usr/share/alsa/cards/ICE1712.conf
   /usr/share/alsa/cards/ICE1724.conf
   /usr/share/alsa/cards/ICH-MODEM.conf
   /usr/share/alsa/cards/ICH.conf
   /usr/share/alsa/cards/ICH4.conf
   /usr/share/alsa/cards/Maestro3.conf
   /usr/share/alsa/cards/NFORCE.conf
   /usr/share/alsa/cards/PC-Speaker.conf
   /usr/share/alsa/cards/PMac.conf
   /usr/share/alsa/cards/PMacToonie.conf
   /usr/share/alsa/cards/RME9636.conf
   /usr/share/alsa/cards/RME9652.conf
   /usr/share/alsa/cards/SI7018.conf
   /usr/share/alsa/cards/SI7018/sndoc-mixer.alisp
   /usr/share/alsa/cards/SI7018/sndop-mixer.alisp
   /usr/share/alsa/cards/TRID4DWAVENX.conf
   /usr/share/alsa/cards/USB-Audio.conf
   /usr/share/alsa/cards/VIA686A.conf
   /usr/share/alsa/cards/VIA8233.conf
   /usr/share/alsa/cards/VIA8233A.conf
   /usr/share/alsa/cards/VIA8237.conf
   /usr/share/alsa/cards/VX222.conf
   /usr/share/alsa/cards/VXPocket.conf
   /usr/share/alsa/cards/VXPocket440.conf
   /usr/share/alsa/cards/YMF744.conf
   /usr/share/alsa/cards/aliases.alisp
   /usr/share/alsa/cards/aliases.conf
   /usr/share/alsa/pcm/center_lfe.conf
   /usr/share/alsa/pcm/default.conf
   /usr/share/alsa/pcm/dmix.conf
   /usr/share/alsa/pcm/dpl.conf
   /usr/share/alsa/pcm/dsnoop.conf
   /usr/share/alsa/pcm/front.conf
   /usr/share/alsa/pcm/iec958.conf
   /usr/share/alsa/pcm/modem.conf
   /usr/share/alsa/pcm/rear.conf
   /usr/share/alsa/pcm/side.conf
   /usr/share/alsa/pcm/surround40.conf
   /usr/share/alsa/pcm/surround41.conf
   /usr/share/alsa/pcm/surround50.conf
   /usr/share/alsa/pcm/surround51.conf
   /usr/share/alsa/pcm/surround71.conf
   /usr/share/alsa/smixer.conf
   /usr/share/alsa/sndo-mixer.alisp
make: *** [alsa-lib-1.0.14a-nld.i386.rpm] Error 1
Did I do something stupid by changing the makefile?
 
Old 08-15-2007, 01:54 AM   #9
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
No, I did something stupid by not changing the Makefile. Thanks for spotting that. One of these days I'll get around to rewriting the Makefile so I only have to edit 3 lines.

The other error you are getting is due to a quirk in your distro that I haven't been able to figure out. There are a couple of lines in the alsa-lib.spec file that are commented out to make it work on mine, but you need them uncommented for your distro. They are near the bottom of the file (lines 89 & 100). To rebuild this package manually, do the following:

Quote:
cd rpmTop
rpm --define "_topdir $pwd" -i ../common_source_rpms/alsa-lib* ../common_source_rpms/alsa-utils*
(edit SPECS/alsa-lib.spec and fix the above lines)
rpmbuild --define "_topdir $PWD" -ba SPECS/alsa-lib.spec
rpmbuild --define "_topdir $PWD" -ba SPECS/alsa-utils.spec
cp RPMS/`uname -m`/* ../
cd ..
audio_install
And that should do it. I'll try to edit the build environment for other distributions later. let me know if ou still have issues.
 
  


Reply

Tags
acer, headphone, laptop, opensuse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help ACER Aspire 9810 Laptop sound only works thru shared spdif/headphone jack califalcon Linux - Laptop and Netbook 3 08-30-2007 12:38 PM
Atheros card not working in opensuse 10.2 Acer Aspire 5570Z chief_officer Linux - Laptop and Netbook 16 07-20-2007 10:20 AM
opensuse 10 on acer laptop Screener Suse/Novell 1 03-18-2006 10:42 AM
OpenSuse 10.0 on Acer Ferrari 4000 subcubes Suse/Novell 3 09-27-2005 11:30 AM
headphone problem on suse 9.1 pro cheyrek Linux - Laptop and Netbook 2 07-16-2004 04:24 AM


All times are GMT -5. The time now is 11:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration