LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Guile rpm file won't install from command line or yast2 (http://www.linuxquestions.org/questions/suse-novell-60/guile-rpm-file-wont-install-from-command-line-or-yast2-261143/)

TdlSnare 11-30-2004 09:37 PM

Guile rpm file won't install from command line or yast2
 
when installing an rpm file using yast2 I was told that i needed libguile.so.10, libltdl.so.3,and libqthreads.so.0.
I searched rmpfind.com for these files and found that they are included in guile-1.4.1-48. I downloaded this rpm and attempted to install it from yast2 and the command line. Yast2 did nothing and the command line said "Warning: only v3 signatures can be verified, skipping v4 signature."
on the command line I used the standard "rpm -i" command and got this warning. What can I do to fix this? Is there another way to get the files that i origianlly needed?

sigsegv 11-30-2004 10:55 PM

If you *really* know that you have the right RPMs, you can rpm -i --force --nodeps. If the RPMs are "wrong", this *will* cause you grief.

As for where to get the RPMs you need -- are they not on the install media?

TdlSnare 11-30-2004 11:00 PM

it is RIDICULOUSSSSSS!... when you download Suse 9.1 from the FTP, there is next to nothing in the way of compilers and other things. i had to install the <make> command... im reaaaaaaaaaly getting irritated with it

sigsegv 11-30-2004 11:18 PM

Ick ... That sucks.

This is why Debian's apt and *BSD's ports system and cousins (emerge, etc) are great and plain old RPM, well ... blows.

TdlSnare 11-30-2004 11:37 PM

i just tried the command you gave me... i got the exact same message... what else can i do?

sigsegv 12-01-2004 07:36 AM

try ading a -v to your command line. That will give you more verbose output. Also try rpm -qa | grep -i guile. If the signature warning was just a warning, the packages may be installed (though I doubt it).

Failing all that, I'd say you'll have to find packages built for your distro.


All times are GMT -5. The time now is 11:31 AM.