LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Grub boot problem with Suse 9.2 Pro (http://www.linuxquestions.org/questions/suse-novell-60/grub-boot-problem-with-suse-9-2-pro-255876/)

Steerpike 11-17-2004 03:23 AM

Grub boot problem with Suse 9.2 Pro
 
Background: Purchased and installed boxed SuSE 9.2 pro on a brand-new hard-drive on my dell laptop. Works fine - boots into GUI with no problems.

Then tried to install into VMWare running in winxp (VMWare is a virtual OS 'host' that supports linux; I need to use VMWare for various reasons). Got a clean install, and again, booted into the GUI (KDE) with no problems.

As an aside, did same with an FTP install of SuSE 9.1 Free - got it running as a guest OS in VMWare.

The problem: now when I boot my virtual OS in VMWare, I only get as far as the 'GRUB' prompt. I can get the OS to boot, just fine, if I type in the detailed 'kernel' and 'initrd' commands, then 'boot' - works like a charm. But it won't boot automatically.

I experimented ... once fully booted, I can go to a shell and type 'grub', then type (eg) find /boot/message - (finds it); find /boot/vmlinuz - (finds it); and find /boot/initrd - (finds it). I can also type (this is significant) 'find /boot/grub/menu.lst' and find it.

BUT - if I reboot the machine, which dumps me at the 'grub' prompt by default, the first three 'finds' above work, but NOT the find on /boot/grub/menu.lst. So there's something about the 'grub' directory it would seem that is problematic on a reboot.

Also, after fully booting, I can go to a shell and type 'grub' and then 'configfile (hd0,1)/boot/grub/menu.lst, and a text version of the menu shows up as expected. BUT, if I try this same command on a real boot of the machine, I get 'error 10: Selected cylinder exceeds maximum supported by BIOS'.

But, as I said, if I type in the two (rather lengthy!) commands from the menu.lst file (as observed once booted), I can boot fine. The commands are,

--------------------------
kernel (hd0,1)/boot/vmlinuz root=/dev/sda2 selinux=0 splash=silent resume=/dev/sda1 desktop elevator=as showopts
initrd (hd0,1)/boot/initrd
---------------------------
followed by 'boot' of course.

I have - of course - a plain vanilla, clean install of SuSE 9.2 - no kernel mods, etc.

So in summary,
1) Booting the OS lands me at the 'grub' prompt
2) manually entering the kernel and initrd commands, verbatim from menu.lst, allow me to boot as expected.
3) doing a 'find' on .../menu.lst, at the boot grub prompt, fails, and doing a 'configfile' on the menu.lst file, at the boot grub prompt, gives a 'cylinder...' error
4) doing the 'find' and the 'cofigfile' commands in a shell, once booted, behave as expected.

My hunch is there is something about the 'grub' directory that is making it somehow 'hidden' at the time of bootup. Why I can't imagine!

Thanks for your help!

Steerpike 11-18-2004 11:19 AM

Since no one responded, should I be posting this elsewhere - newbie forum, or whatever? I don't want to be rude or abuse the forum rules. Re-reading my post, I see that in my attempt to povide background, I may have 'buried' what the actual problem is ... so in a nutshell,

When I boot my 9.2 Pro install in a vmware environment, I don't get past the 'grub' prompt. If I manually type in the 'kernel' and 'initrd' commands, then 'boot', I boot fine, and once booted, I can look in the /boot/... folders and everything is there, including a proper 'menu.lst' in the 'grub' folder. Also, once booted, I can launch a shell and type 'grub', and type 'configfile (hd0,1)/dev/sda2/menu.lst', and get a menu. But typing this latter command at the grub promp after booting gives the errors mentioned below.

I've done several 9.1Free (FTP) suse installs into vmware and they boot just fine.

Any help, pointers, etc gladly received, and my apologies if this constitutes a 'bump'!

jschiwal 11-18-2004 12:46 PM

First of all you need to be a bit more patient waiting for a response.

Here are the permissions for the /boot/grub directory:
> ls -l /boot/grub/ -d
drwxr-xr-x 2 root root 4096 2004-10-24 03:23 /boot/grub/

I doubt that yours will be different.
The command to install grub on your device is called 'grub-install'

However I'm not familiar with VMware, and I don't know if this will replace the VMware bootloader. Also, don't you need to install Windows and Linux while running VMware?

There is a boot loader installer in YaST. Have you tried using it?

Good Luck!

ssaksa 11-19-2004 01:55 PM

Type of install
 
I had a problem with GRUB configuration and then complaints about disk geometry when I customized the installed packages. I did a new install and went with the defaualts and about 10 more screens of the installer came up. When it finished my machine booted okay, and now I am working on the vmware-tools and video issues.

Steerpike 11-19-2004 02:29 PM

Thanks for the help. I've checked permissions, and they are as you indicate. I've also tried repairing and re-installing the boot loader; the process completes but no change to the behavior.

See this post, over on the vmware forums ... - looks like a common problem. The posted solution does not solve the problem for me (boots me, one-time, but subsequent re-boots get same issue).

Everything was working fine until I tried to install vmware tools into the OS. There are several issues, it seems, between vmware and SUSE 9.2. VMWare tries to set up a shared folder between the host and guest os's, using a module 'vmhgfs', but there's something about how SUSE is handling security that vmware won't support - but this should simply mean that the shared folder feature won't work, which is no big deal. The other thing is, when you try to build the module using VMWare's script, the build process fails and again, vmware blame this on some non-standard locations used by SuSE. But none of these issues should render the OS non-bootable ... ;)

Anyway, I'll keep looking and report back what I find. Thanks!

Allen T 11-19-2004 03:19 PM

Current support of SuSE 9.2 on VMWare
 
I think I can share my experiences about running Suse 9.1 and 9.2 on VMware.

The problem apprears that VMware's support of each version of linux depends heavily on linux kernel version. Which means that if you install the latest version of kernel, due to the lagging support provided by VMware, the new Suse might not be able to run properly. And how severe the problem will depends on how much changes the new kernel has compared to the supported kernel. I used to install Suse 9.1 pro in VMware and everything work perfectly. However, I encounter something similiar to what you have now when I use the Suse's online update to update my kernel to the latest version. And I am able to confirm that problem as after I reinstall it and update the system after SPECIFYING DON'T UPDATE KERNEL, things work great again. As for 9.2, I installed it in VMware and due to the new kernel problem, things start to behave strangely. And I don't find a good solution to this problem while waiting VMware to issue an update for its software. After all, there is no support in term of VMware tool for Suse 9.2 yet. So, I ended up installing 9.2 on the computer natively and using 9.1 within VMware if I have to run both Windows and Suse at the same time.

Hope the above info can be useful to you.

AT

Steerpike 11-23-2004 10:57 AM

Thanks for the info.

It seems, so far, that you can run Suse 9.2 inside vmware without loading vmtools at all. I'm able to go to full screen mode, at 1024x768. Obviously, without vmtools, you can't move the mouse seamlessly from inside the client window to the native OS, and you have to use 'ctrl-alt' to 'release' the cursor to get 'out' of the window, once inside. But I'm getting used to this now. Also, of course, you can't use the shared folder feature, but you can get around that using ftp.

So until such time as they get vmtools figured out for suse, I may just ignore it ... and possibly move to another distribution.

Thanks.

Steerpike 12-16-2004 01:05 AM

Well here I am, a month later ... I abandoned the 9.2 VMWare environment above, and loaded 9.2 natively on a new hard drive.

But this week, I installed a new 9.1 Free environment into VMWare, and updated it online to kernel version 2.6.5.7.111, and all was fine - was busilly installing Oracle products, etc with no problems. Rebooted several times. But all of a sudden, tonight, I tried to restart the environment, and ... stuck at the grub boot prompt for no good reason. And this time, I can't get it to boot no matter what I try - typing in the 'kernel' string results in 'Error 18: Selected cylinder exceeds maximum supported by BIOS'.

The only thing that comes to mind is this ... I'm using unallocated disk space (this is an optional technique in VMWare to only allocate disk space as needed), and I'd just copied about 1.2 Gig's worth of files into the VM (via FTP). Could there be some problem with linux and VMWare's unallocated disk space technique? My strategy with VMWare has always been to assign a large virtual disk (64 Gig), but then leave it unallocated, so that only as much as needed gets allocated. Could the boot process be messed up by this?

minrich 12-16-2004 11:30 AM

Steerpike

Could you give a little more info on your dell laptop? HDD, CPU, RAM, VideoCard, VRAM, etc. So that I can compare with my inspiron 8000, 866MHz, 384MB RAM, 30GB HDD, ATI Mobility M4 (32MB Ram).

I have loaded Suse9.2pro (boxed) with VMware tools on my Tablet and it runs fine.

How much RAM did you allocate to your Suse9.2 and/or Suse9.1Free VMs?

Why do you use 'unallocated' disks? I have never had a problem with 4GB (in 2GB segments)?

Have you checked your VM BIOS settings? (NB. These are not, nor do they have to be, exactly the same as your laptop BIOS - for example, you can set the order of peripherals on boot differently - I for instance have no floppy on my Tablet so I have disabled it in my VM Bios - nevertheless Suse9.2 does see a virtual floppy when I attach my 512MB USB Flash drive which has a 1.44MB floppy partition on it). My question here is that maybe the VM BIOS is unable to access the full 60GB as currently set on your machine - remeber that the BIOS in a VM is povided by VMware.

Incidentally what version of VMware are you using? I recently upgraded to 4.5.2 since the RAM leakage seems to have been fixed.

With a little more info. I should be able to steer you right

Cheers

TonyRic 12-17-2004 10:09 AM

I run 3 separate 9.2 sessions on VMWare and ran into this problem and the fix I have used is to use LiLO instead of Grub. All of these problems went away.

Steerpike 12-17-2004 08:29 PM

Quote:

Originally posted by minrich
[B]Steerpike

Could you give a little more info on your dell laptop? HDD, CPU, RAM, VideoCard, VRAM, etc. So that I can compare with my inspiron 8000, 866MHz, 384MB RAM, 30GB HDD, ATI Mobility M4 (32MB Ram).
My laptop is a latitude D600, 1.6 GHz, 1 Gig Ram, 40 Gig HD, plenty of free disk space, ATI Mobility.

However, i've reproduced the same problem now on my desktop - a Dell dimension 4600, 1 Gig RAM, 80 Gig HD, etc.

Quote:

How much RAM did you allocate to your Suse9.2 and/or Suse9.1Free VMs?
I initially allocated 256 Meg, with a view to increasing it later if needed. In the latest test, though, on my desktop, I increased it from 256 to 512Meg. After the change, I rebooted several times with no issues. I then loaded a complete Oracle product (10g AS), shut down the machine, copied the entire folder (so I'd have a backup), and ... could no longer boot.

Quote:

Why do you use 'unallocated' disks? I have never had a problem with 4GB (in 2GB segments)?
This is a very useful appraoch I developed working with windows guests. When I first started working with VMWare, I used to create (eg) 8 gig hard drives and fully allocate the 8 gig. But then, if I wanted to copy the virtual machine, I'd have to copy the full 8 gig, which prevented me from using DVDs (unless I compresssed using winzip, which takes time). So I hit on the idea of creating 'very large' disks (eg, 64 Gig) but not allocating the space. When you first load the OS, only about 2 Gig is used. So I load the OS, apply all the necessary service packs, etc, then copy the VM folder to DVD so I have a 'ready to run' Virtual Machine, loaded and patched - just copy back from the DVD to the hard drive, and point to the folder.

With my Linux virtual machines, I first create the machine and load the base OS (eg, 9.1 Free). Then copy the folder to DVD as a 'base load of OS' template. Then apply Yast Online Update, get to latest kernel version, and again copy virtual machine folder to DVD. Then, in my case, do all the preparations for loading Oracle (a tedious set of tasks) and again copy to DVD - so now I have three DVDs, one for a base load of Suse, one fully patched, and one ready to load Oracle. Finally, I load Oracle, and make a fourth copy.

If I want to run a linux machine that is un-patched, I copy my first dvd to the hard drive and run it in VMWare. If I want to run Oracle, I copy the Oracle DVD to the hard drive and run it with VMWare. Basically, I have a 'library' of different machines all ready to run just by copying from DVD. I'm guessing it's this copying of virtual machines that's causing - or at least contributing - to my problems, but for me, that's part of the power of VMWare!

I could, of course, create a 4 Gig Hard Drive, and fully allocate it, but then, you can never go beyond this size - a limitation of VMWare.

Quote:

Have you checked your VM BIOS settings? (NB. These are not, nor do they have to be, exactly the same as your laptop BIOS - for example, you can set the order of peripherals on boot differently - I for instance have no floppy on my Tablet so I have disabled it in my VM Bios - nevertheless Suse9.2 does see a virtual floppy when I attach my 512MB USB Flash drive which has a 1.44MB floppy partition on it). My question here is that maybe the VM BIOS is unable to access the full 60GB as currently set on your machine - remeber that the BIOS in a VM is povided by VMware.
How do I check the BIOS in the vm? Is this just a simple matter of looking at the VM settings - that is, in VMWare, menu VM/Settings...? Or do you mean press F2 on boot and access the BIOS configuration screen? In the BIOS, I can't see a way to change the order of peripherals (for example).

Quote:

Incidentally what version of VMware are you using? I recently upgraded to 4.5.2 since the RAM leakage seems to have been fixed.

With a little more info. I should be able to steer you right

Cheers
I'm using 4.5.2. Thanks for your help.

minrich 12-17-2004 09:24 PM

Hi

Although I have a dvd writer built into my Tablet, I just save my (upto 4GB) VM's to my HDD and like you I have multiple versions of each distro. I tend to save unsuspended vdisks since then I can move the VM to another machine and/or upgrade as new versions of VMware are released. I have a 200GB one-touch Maxtor Firewire/USB2 external drive on which I keep my backup (of everything). Usually one text install with development tools and kernel source ( I need these to set up my printer (a Konica-Minolta magicolor 2300DL color laser printer using IP access, because this requires loading a special driver, ghostscript, and an ICM), then I struggle a bit to install VMware Tools which requires making some changes to an untar'ed copy of vmware-config-tools.pl to adjust it from XFree86 3.4.0 to Xorg so that it builds something called vmhgfs, which I believe is used for mouse/cursor release from the guest to the host and vice-versa. Installing vmware tools allow use of the vm SVGA driver ratehr than the VESA setting @ 1024x768 that I use until the tools are installed.

On most of my VM's I only allocate 256MB- 272MB of my 512MB so that I can avoid using a swap file - the only problem with the 60GB drive on the Tablet PC is that it is very very slow even compared to my inspiron 8000 that was purchased 4 years ago today.

Yes you have to access the VM BIOS settings using F2 before booting your guest. Really it is only a matter of ensuring that your host has the expected drives - as I stated my Tablet has no floppy drive and I hate waiting for it not being found. I am still using Large Disk Access Mode: [DOS] (under the Advanced tab) although it suggests that I should use 'Other' for UNIX, Novell NetWare or other operating systems. I have my 'Boot tab' devices set to +Hard Drive | CD-ROM Device | +Removable Devices. Works for me but then I am not using Oracle.

I use bridged networking (sometimes NAT when diagnosing others' LQ problems) and I have set up Samba so that I can transfer to/from my host machine - have you tried this approach with your Oracle Data?

Incidentally did you try TonyRic's suggestion of Lilo rather than GRUB?

Also I would like to know how large your VM becomes after loading Oraccle and Oracle Data, specially if it is over 4GB.

have you checked out your problem on the VMware community site?

http://www.vmware.com/community/index.jspa

and this thread in particular;

http://www.vmware.com/community/thre...ID=84154#84154

Steerpike 12-19-2004 09:00 PM

Switching to LiLo seems to be the trick. Since doing so Friday, I have copied, renamed, and generally messed around with my installations and can't get them to fail to boot.

The Oracle product I've been loading is the application server product, not the database, so there is no data involved. The total image size is about 3 gig so far. But ultimately, I anticipate needing to grow the image beyond 4 gig when I start to load configuration data into the environment.

Will take a look at the posts you mention. Thanks.


All times are GMT -5. The time now is 10:22 PM.