LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-02-2008, 03:26 PM   #1
fishstick
LQ Newbie
 
Registered: Oct 2006
Location: Chicago, IL
Distribution: SUSE 10.1
Posts: 14

Rep: Reputation: 0
Gnome and KDE fail to start under user. root access ok.


HI,

here's the issue. i was setup for auto login. When i booted to SUSE 10.1, i got to the login screen. Gnome wont start, it looks like it is starting but in 40 sec it goes back to the login screen. I can get in as rootm but not as the user. KDE is a different story. It gives me error " No write access to /home/michal/.ICEauthority/ KDE is unable to start. "
any help will be appreciated.

Thanks
 
Old 04-02-2008, 05:27 PM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 3 / CrunchBang Linux 10 Statler / Easy Peasy
Posts: 4,293

Rep: Reputation: 205Reputation: 205Reputation: 205
Seems to be an ownership issue. You could try changing the ownership as root to michal recursively i.e. chown -R michal:michal /home/michal this will change the ownership of all files in /home/michal to that user (as they should be).

If you are confident that it's only the .ICEauthority file that's the problem then simply use the chown command as root on that file. i.e. chown michal:michal /home/michal/.ICEauthority
 
Old 04-02-2008, 06:03 PM   #3
fishstick
LQ Newbie
 
Registered: Oct 2006
Location: Chicago, IL
Distribution: SUSE 10.1
Posts: 14

Original Poster
Rep: Reputation: 0
thanks for the reply. I ran chown -R michal:michal /home/michal , but that failed and said michal:michal invalid group. I have not made any changes to my system.???
 
Old 04-02-2008, 06:07 PM   #4
fishstick
LQ Newbie
 
Registered: Oct 2006
Location: Chicago, IL
Distribution: SUSE 10.1
Posts: 14

Original Poster
Rep: Reputation: 0
ok, i fixed it. I ran chown -R michal:users /home/michal and that reselved the issue. Thanks for your help, if i am ever in the UK.. i owe u a beer...
 
Old 04-02-2008, 06:09 PM   #5
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 3 / CrunchBang Linux 10 Statler / Easy Peasy
Posts: 4,293

Rep: Reputation: 205Reputation: 205Reputation: 205
Glad to have helped. Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SUSE 9.1: KDE or GNOME start only as root blish_blash Linux - General 4 09-18-2004 09:35 AM
Fail to start Gnome satimis Fedora 1 07-30-2004 10:30 AM
Fail to start KDE as USER satimis Red Hat 3 07-03-2004 10:00 PM
Normal user cannot start KDE - root can tagit Linux - Newbie 3 12-26-2003 08:12 PM
Normal user cannot start KDE - root can tagit Debian 1 12-26-2003 03:14 PM


All times are GMT -5. The time now is 03:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration