LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 11-30-2004, 05:40 PM   #1
m3s3lf
Member
 
Registered: Oct 2004
Distribution: SuSe 9.1
Posts: 41

Rep: Reputation: 15
freezes loading name server cache daemon


Distro is Suse 9.1 - everything was working fine (for weeks)... booted into win2k and it worked as well as windows ever does, then I restarted to boot back into Suse and it freezes loading "Name Server Cache Daemon". Tried restarting, tried booting into "Failsafe" and it still freezes. What could be causing this and is there a workaround/fix?
Thanks a lot!
Billy
 
Old 11-30-2004, 05:50 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
personally i'd say kill that service... it's just a crippled version of bind which might speed u pyour dns hits by .25 seconds sometimes... as for the problem... maybe a lockfile or somethign like that, but also it might be a netowrknig thing. have you tried leaving it to timeout for a length of time? either way i'd suggest just cutting it out for now, by deleting /etc/rc5.d/S80dnscache or whatever it's going to be called on suse. this is only a symlink to the real service, so totally replacable at any point you want to. (and rc5.d is assuming you boot to X, if you use a console login, change the 5 to a 3.) if you're having a hard time getting in at all, try booting to single user mode, add a "1" or "single" to your boot prompts (lilo or grub) and go from there.
 
Old 11-30-2004, 05:55 PM   #3
m3s3lf
Member
 
Registered: Oct 2004
Distribution: SuSe 9.1
Posts: 41

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by acid_kewpie
personally i'd say kill that service... it's just a crippled version of bind which might speed u pyour dns hits by .25 seconds sometimes... as for the problem... maybe a lockfile or somethign like that, but also it might be a netowrknig thing. have you tried leaving it to timeout for a length of time? either way i'd suggest just cutting it out for now, by deleting /etc/rc5.d/S80dnscache or whatever it's going to be called on suse. this is only a symlink to the real service, so totally replacable at any point you want to. (and rc5.d is assuming you boot to X, if you use a console login, change the 5 to a 3.) if you're having a hard time getting in at all, try booting to single user mode, add a "1" or "single" to your boot prompts (lilo or grub) and go from there.
Well, I'm glad you're telling me that the service is pretty much worthless, but everthing else is greek I didn't make a bootdisk or anything so I don't even know where to start to kill the service. Thanks for the help!
Billy

EDIT: Oh yeah, I did give it plenty of time to timeout.

Last edited by m3s3lf; 11-30-2004 at 05:59 PM.
 
Old 11-30-2004, 06:04 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
ok. at lilo or boot prompt hit e (grub) or... ctrl-x maybe in lilo (???) and add "1" or "single" to the options, and then boot. this will log you in as root and not load any services at all.

then use "rm /etc/rc5.d/<linktocacheservicewithhopefullyobviousname>" to remove it from boot. i'm not familiar with suse's /etc/ structure, might be /etc/rc.d/rc5.d, might be /etc/init.d/rc5.d.. just poke around using "ls" once deleted, reboot.

as a disclaimer, i tend to describe things in as low level way as possible, as it's more generic across platfom. maybe (like redhat / fedora) you can press "I" during a normal boot to confirm ecah service as they load? that's much nicer way if possible....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Knoppix freezes when loading cardmgr ajc275 Linux - Newbie 2 03-01-2005 12:07 PM
KDE 3.2 and 3.3 freezes while loading rumester Linux - Newbie 2 09-30-2004 07:40 AM
Red Hat 9 install freezes after PCI cache line problem bensmail69 Linux - Newbie 4 06-29-2004 07:49 PM
laptop freezes after loading mandrake 10 fitzy85 Linux - Laptop and Netbook 1 04-04-2004 02:12 PM
kde freezes when loading C++freak Slackware 2 02-26-2003 02:05 PM


All times are GMT -5. The time now is 01:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration