LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 04-16-2008, 03:24 PM   #1
The GNUinator
Member
 
Registered: Oct 2006
Location: Fort Collins, CO
Distribution: Slackware 14.0, 14.1
Posts: 71

Rep: Reputation: 15
Firefox always starts in offline mode. Konqueror cannot access Internet at all


Hello All,

Upgraded from OpenSUSE 10.2 to 10.3 ... the new version
is much faster, but very different ... in 10.2 dhcp client
would start automatically, my wireless card was a 'required'
device and I was on the Internet automatically at the coffee
shop.

10.3 requires that I start dhcp client manually. That's
ok though I wonder why this has changed after being the
same from SuSE 9.0, 9.3, OpenSUSE 10.2 and now all of a
sudden it has changed. Firefox starts in offline mode
no matter what I do. I even created a new profile and
that doesn't help. Konqueror will not connect to
the Internet at all even when I'm connected. The error
message is: "offline mode active" ... I've read
Konqueror handbook and searched documentation - can't
find any reference. Any ideas?

tia,

The GNUinator
 
Old 04-16-2008, 05:45 PM   #2
The GNUinator
Member
 
Registered: Oct 2006
Location: Fort Collins, CO
Distribution: Slackware 14.0, 14.1
Posts: 71

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by The GNUinator View Post
Hello All,

Upgraded from OpenSUSE 10.2 to 10.3 ... the new version
is much faster, but very different ... in 10.2 dhcp client
would start automatically, my wireless card was a 'required'
device and I was on the Internet automatically at the coffee
shop.

10.3 requires that I start dhcp client manually. That's
ok though I wonder why this has changed after being the
same from SuSE 9.0, 9.3, OpenSUSE 10.2 and now all of a
sudden it has changed. Firefox starts in offline mode
no matter what I do. I even created a new profile and
that doesn't help. Konqueror will not connect to
the Internet at all even when I'm connected. The error
message is: "offline mode active" ... I've read
Konqueror handbook and searched documentation - can't
find any reference. Any ideas?

tia,

The GNUinator
Fixed it myself! The fix is to turn off NetworkManager
and go back to the traditional ifup and ifdown scripts
that I'm familiar with from pervious versions. Installation
is on a ThinkPad T30 with a 10/100 ethernet card on the planar
(that's IBMspeak for the motherboard) and a minipci Orinoco
gold 802.11b wireless card as eth1. I put eth1 as a required
device at boot --- now sure enough dhclient starts right up
on boot the way it did in previous versions. Now, if there
is a wireless connection Firefox starts in online mode and
Konqueror is able to connect to the Internet.

I'm posting this in case it helps someone else.

The GNUinator
Sacramento / Fort Collins
 
Old 06-25-2008, 06:20 PM   #3
netsurf
Member
 
Registered: Nov 2004
Location: UK
Distribution: ubuntu 10.04+ distro hopping
Posts: 181

Rep: Reputation: 31
in the unlikely event that you are using Fedora 8 with eth0 onboot and network manager running this also happens if you used remi's repo to install the newly released firefox 3
many thanks for the quickfix
 
Old 07-13-2008, 01:13 AM   #4
tweiers
LQ Newbie
 
Registered: Jul 2008
Posts: 2

Rep: Reputation: 0
also gave up on Network Manager and changed to wpa_supplicant. Wpa_supplicant and wpa_supplicant_gui are available as packages on the SuSE 10.3 DVD, Network Manager has to be disabled for the purpose (go yast -> network devices -> network card -> global options, change from Network Manager to ifup/ifdown).
I installed these and configured my network as follows: Contrary to most tutorials the wpa_supplicant configuration goes to /etc/wpa_supplicant.conf instead of /etc/wpa_supplicant/wpa_supplicant.conf on my SuSE 10.3 machine.
My /etc/wpa_supplicant.conf works and looks like this:

ctrl_interface=/var/run/wpa_supplicant
ap_scan=1

network={
ssid="dlink"
key_mgmt=NONE
}
network={
ssid="MyWirelessHomeLAN"
key_mgmt=WPA-PSK
psk="MySooperSecretPassPhrase"
}
network={
ssid="MyFriendsWirelessLAN"
key_mgmt=NONE
wep_key0="HerPasswd"
wep_tx_keyidx=0
}
network={
scan_ssid=1
key_mgmt=NONE
}

Also, the system needs to be told to use wpa_supplicant by changing /etc/sysconfig/network/ifcfg-eth1 (or similar) as follows:

BOOTPROTO='dhcp'
BROADCAST=''
PREFER_WPA_SUPPLICANT='yes'
ETHTOOL_OPTIONS=''
IPADDR=''
MTU='1500'
NAME='Intel PRO/Wireless 3945ABG Network Connection'
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
WIRELESS_AP=''
WIRELESS_AUTH_MODE='open'
WIRELESS_BITRATE='auto'
WIRELESS_CA_CERT=''
WIRELESS_CHANNEL=''
WIRELESS_CLIENT_CERT=''
WIRELESS_CLIENT_KEY=''
WIRELESS_CLIENT_KEY_PASSWORD=''
WIRELESS_DEFAULT_KEY='0'
WIRELESS_EAP_AUTH=''
WIRELESS_EAP_MODE=''
WIRELESS_ESSID='dlink'
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_KEY_0=''
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_PEAP_VERSION=''
WIRELESS_POWER='yes'
WIRELESS_WPA_ANONID=''
WIRELESS_WPA_IDENTITY=''
WIRELESS_WPA_PASSWORD=''
WIRELESS_WPA_PSK='' .

Eventually, I had to modify the way SuSE 10.3 configures a network during startup. To do so I changed every line that reads "ifup $INTERFACE -o dhcp" to "ifup $INTERFACE -o dhcpd" in /etc/sysconfig/network/scripts/dhcpcd-hook (please note the "d" at the end).

After having rebooted my computer it came up with the right configuration straight away.

tweiers

Quote:
Originally Posted by The GNUinator View Post
Fixed it myself! The fix is to turn off NetworkManager
and go back to the traditional ifup and ifdown scripts
that I'm familiar with from pervious versions. Installation
is on a ThinkPad T30 with a 10/100 ethernet card on the planar
(that's IBMspeak for the motherboard) and a minipci Orinoco
gold 802.11b wireless card as eth1. I put eth1 as a required
device at boot --- now sure enough dhclient starts right up
on boot the way it did in previous versions. Now, if there
is a wireless connection Firefox starts in online mode and
Konqueror is able to connect to the Internet.

I'm posting this in case it helps someone else.

The GNUinator
Sacramento / Fort Collins
 
Old 07-13-2008, 02:33 AM   #5
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
I didn't have a problem with knetworkmanager in SuSE10.3. Prior to 10.3, wpa wasn't supported very well. You could try rerunning the YaST2 -> network setup. If you use KDE, make sure that kwalletmanager is installed. knetworkmanager uses it to hold the wpa_psk.

In SuSE 10.4 knetworkmanager has problems for me. The YaST configuration starts knetwork manager and then tries to download a package on the internet. I'm guessing that the package it is trying to install is needed for knetworkmanager to work.

The original problem sounds like you need these two lines in /etc/sysconfig/network/ifcfg-<device>:
Code:
BOOTPROTO='dhcp'
STARTMODE='auto'

Last edited by jschiwal; 07-13-2008 at 02:36 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox 1.5 always loads in 'Work offline' mode giffbd Linux - Software 7 12-13-2010 09:13 PM
Updated Network Manager - Now Firefox stuck in OFFLINE MODE! Balarabay1 Suse/Novell 13 10-25-2010 10:38 AM
Yum firefox cannot access internet, Konqueror and kopete can johnsnails77 Linux - Server 16 03-19-2008 09:25 PM
Suse 10.2 - Firefox Offline Mode jeelliso Linux - Software 4 12-23-2006 07:28 PM
Unable to access Konqueror with USB drive plugged in user mode richdux Mandriva 3 03-10-2005 08:27 PM


All times are GMT -5. The time now is 10:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration