LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Failed to connect to the secure network using wpa_supplicant (http://www.linuxquestions.org/questions/suse-novell-60/failed-to-connect-to-the-secure-network-using-wpa_supplicant-630880/)

Kirinor 03-26-2008 07:21 PM

Failed to connect to the secure network using wpa_supplicant
 
I am connected to the secure network that runs on university campus and provides access to internet. The server is Windows 2003 Enterprise Server. Connecting through Network manager does not seem to accomplish anything, but I don't know how to check its logs to see what is wrong exactly.

One of the classmates used Ubuntu and wpa_supplicant with a 802wired.sh and wpa_supplicant.wired.conf files as means to do it.
Here is a guide he used:
http://www.stevens.edu/itwiki/cgi-bi...e=Linux_802.1x

It worked for him, but I got only some error messages while running 802wired.sh:
Quote:

/etc/init.d/802wired.sh
Initializing interface 'eth0' conf '/etc/wpa_supplicant.wired.conf' driver 'wire
d' ctrl_interface 'N/A'
Configuration file '/etc/wpa_supplicant.wired.conf' -> '/etc/wpa_supplicant.wire
d.conf'
Reading configuration file '/etc/wpa_supplicant.wired.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group=0 (from group name 'root')
ap_scan=0
Priority group 0
id=0 ssid=''
Initializing interface (2) 'eth0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_wired_init: Added multicast membership with packet socket
Own MAC address: 00:0f:b0:73:ef:84
Setting scan request: 0 sec 100000 usec
Added interface eth0
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit [

Listening on LPF/eth1/00:90:4b:f3:b3:54
Sending on LPF/eth1/00:90:4b:f3:b3:54
Listening on LPF/eth0/00:0f:b0:73:ef:84
Sending on LPF/eth0/00:0f:b0:73:ef:84
Sending on Socket/fallback
receive_packet failed on eth1: Network is down
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 2
send_packet: Network is down
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
send_packet: Network is down
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 5
send_packet: Network is down
I can only open internet from a computer lab now, so there is much incentive to quickly resolve a problem. If you can at least point me to the right direction, that would be great.
I am a Windows advanced user and Newcomer to Linux openSuse 10.2

Kirinor 03-27-2008 06:58 AM

More information
 
The server uses Protected EAP authentication (IEEE 802.1x).


All times are GMT -5. The time now is 09:15 AM.