LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 03-24-2008, 05:15 AM   #1
1kyle
Member
 
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Rep: Reputation: 32
External USB disk - Only ROOT has Write permission (Suse 10.3)


Hi guys
I've googled for this but can't find a satisfactory answer.

Only Root seems to have Write permission to an external USB disk.

Even if I mount the device manually and allow all permissions

mount -t vfat -o rw /dev/sdb1 /mnt/extusb.

Still get access denied when I try to write as a normal user.

Anyway round this.

Cheers

-K
 
Old 03-24-2008, 05:49 AM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
You can do two things to give yourself write permissions. Either use the fmask and dmask options to give "others" read/write permissions, or use the "uid" option to make yourself the owner.

Code:
mount -t vfat /dev/sdb1 /mnt/extusb -o defaults,uid=<yourusername>,fmask=0177,dmask=0077
or
mount -t vfat /dev/sdb1 /mnt/extusb -o defaults,fmask=0111,dmask=0000
See the "mount" man page for other options such as "noatime" which you want to use for flash drives.
 
Old 03-24-2008, 06:16 AM   #3
1kyle
Member
 
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Original Poster
Rep: Reputation: 32
Hi there -- did that but still system won't allow a USER to WRITE to the device .

I got round the problem by converting the disk to NTFS and mounting it as ntfs-3g -- then it worked PERFECTLY.

Anway as the disk was one of those portable WD 250GB disks I think having NTFS on it is better anyway.

Cheers

-K
 
Old 03-24-2008, 06:56 AM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
NTFS isn't a good filesystem to use on Linux. If you don't have a windows machine you will have no way to repair it if something goes wrong.
 
Old 03-24-2008, 07:38 AM   #5
1kyle
Member
 
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Original Poster
Rep: Reputation: 32
Hi there
I need to use the Disk on both Windows and Linux machines.

Not all the Windows machines are connected (even remotely) to Linux machines so I have to use a Windows file system on the disk.

The current incarnation of ntfs-3g with the latest kernel doesn't seem to break NTFS. I've done some pretty exhaustive testing on SUSE 10.3 x_64. Unlike the initial releases of FUSE / ntfs-3g this seems very stable.

Ideally an ext3 file system would be better but on some Windows machines (Office / Work) I use I don't have admin rights so can't install the ext3 package for Windows.

(I also backup regularly so no disaster even if the whole disk goes AWOL).

Cheers

-K

Last edited by 1kyle; 03-24-2008 at 07:40 AM.
 
Old 03-24-2008, 01:05 PM   #6
pilotgi
Member
 
Registered: Apr 2002
Location: ks
Distribution: openSUSE 12.2 64 bit
Posts: 488

Rep: Reputation: 32
I did this a different way with the gui in KDE. Mount the disk then use File Manager-Super User Mode.

Change the permissions of /disk to your username. Click ok.
 
Old 03-24-2008, 02:44 PM   #7
1kyle
Member
 
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Original Poster
Rep: Reputation: 32
That method is not really a solution as I need to use the disks in applications such as VMWARE Workstation.

The Super User mode is fine for browsing files / copying data but when you need to run specific applications such as Opem Office etc. then you need normal USER access to these disks.

The nt-3g method described above works fine.

With large disks and VISTA vfat will probably be on its way out soon anyway.
Cheers
-K
 
Old 03-24-2008, 04:12 PM   #8
pilotgi
Member
 
Registered: Apr 2002
Location: ks
Distribution: openSUSE 12.2 64 bit
Posts: 488

Rep: Reputation: 32
Quote:
Originally Posted by 1kyle View Post
That method is not really a solution as I need to use the disks in applications such as VMWARE Workstation.

The Super User mode is fine for browsing files / copying data but when you need to run specific applications such as Opem Office etc. then you need normal USER access to these disks.

The nt-3g method described above works fine.

With large disks and VISTA vfat will probably be on its way out soon anyway.
Cheers
-K
I think you misunderstood me. You use Super User Mode to change the permissions. Then the disk is owned by the user instead of root. It worked for me anyway for writing to my external firewire drive as a regular user.
 
Old 03-25-2008, 07:08 AM   #9
1kyle
Member
 
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Original Poster
Rep: Reputation: 32
Hi there
Firewire (IEExxx interface) drives have no problem --it just seems to be the USB Drives for some strange reason.
Memory SD card (VFAT) is also OK

Cheers
-K
 
Old 03-25-2008, 08:36 AM   #10
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
If you want any user to be able to write to a vfat filesystem, use dmask & fmask mount options that allow "others" to write to it. The "uid=" mount option can change the ownership to yourself. Unless there was a problem with the filesystem causing it to be mounted readonly, you must not have used the uid, fmask & dmask options that would give you write access.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Establishing write permission for an external hard drive in SUSE 10.3 Jason21 Linux - Newbie 7 10-26-2007 01:40 AM
Permission issues after installing external USB disk drive Maarten_Holland Linux - Newbie 2 02-01-2006 09:27 AM
External USB hard disk wont allow user to write, vfat FS scm86 Linux - Hardware 3 09-06-2005 01:05 AM
Sharing USB Ext Disk -- can only Write as ROOT ( Hotplug ??) 1kyle Linux - Networking 4 08-12-2004 11:01 AM
External USB drive -- only WRITE as root 1kyle Linux - Hardware 0 08-03-2004 10:00 AM


All times are GMT -5. The time now is 10:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration