LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Error KDE SU permission problem - Su returned with an error. Yaste and SU compromise. (http://www.linuxquestions.org/questions/suse-novell-60/error-kde-su-permission-problem-su-returned-with-an-error-yaste-and-su-compromise-732752/)

mrukjames 06-13-2009 05:55 PM

Error KDE SU permission problem - Su returned with an error. Yaste and SU compromise.
 
Hi,

I am running Suse 10.3 using KDE.

I am unable to access Yast and cannot login as Root/SU.
It returns the following message:

"Permissions on the password database may be too restrictive.
su: incorrect password"

After a Google search and reading forums- all the remedies involve login in as Super User first. But how can I attempt login or change permissions if I can not log in as Super User?

I even tried re-installing but it did not correct the system or allow me to manage users/passwords etc. What can I do? Please help.

I thank you in advance for your wonderful support,

Kind Regards,
James

unSpawn 06-13-2009 06:58 PM

If it's a local machine boot into runlevel 1 to fix perms with 'chmod 0644 /etc/passwd; chmod 0400 /etc/shadow' or else run a Live CD?

mrukjames 06-15-2009 06:22 PM

Hi,

I thank you so much for your advice!

I am a novice to Linux so I was very happy to learn how to go into run level 1.

I logged in as root successfully and did the following actions:

chmod 0644 /etc/passwd
chmod 0400 /etc/shadow

I also went into /opt/kde3/share/config/kdeglobals and added to the end of the file:

[super-user-command]
super-user-command=su

But unfortunately I still have the same problem- nothing has changed.
I appreciate any further suggestions or advice

Once again, thank you for your kind support, as this gives me a great opportunity for learning Linux!

Thanks,
James

unSpawn 06-15-2009 08:01 PM

You may have inadvertedly set permissions through Yast to "paranoid"? If that's the case you might try reverting permissions to a lower setting (try "easy" ;-p) entering runlevel 1 again and then running 'yast'. This commandline version should allow you to "undo" your actions. Else try 'chkstat -set /etc/permissions.easy' but please have a look at Understand SuSEconfig (PDF, SLES 9), the "Objective 2 Understand SuSEconfig" part and on first or look up the equivalent in http://www.novell.com/documentation/opensuse103/ .


All times are GMT -5. The time now is 06:48 AM.