LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 07-18-2009, 04:50 AM   #1
vijay2009
LQ Newbie
 
Registered: Jul 2009
Posts: 6

Rep: Reputation: 0
error 15 :file not found on booting suse linux 10


we used suse linux 10 and ubuntu 8.04 in our computer.

in suse linux,we update online updates.then it asks to reboot.after rebooting into the suse linux it shows error 15:file not found.press any key to continue.
then we go to use ubuntu 8.04 kernel 2.6.24-16, in that also when using add or remove program or synaptic package manager or updating online it shows an error message E:dpkg was interrupted.you must manually run "dpkg--configure -a"to correct the problem. E:_cache-->open()failed,please report.
then we manually corrct the problem and after rebooting it shows the four versions of ubuntu 8.04.1 kernel 2.6.24-22
ubuntu 8.04.1 kernel 2.6.24-21
ubuntu 8.04.1 kernel 2.6.24-19
ubuntu 8.04.1 kernel 2.6.24-16
and suse linux 10 os is not seen.
then in ubuntu, after online updates the ubuntu is ubuntu 8.04.3 LTS kernel 2.6.24-24 (with the help of ubuntu launchpad , we make changes in the menu.lst and we also solved the problem "unable to resolve host". thanks to launchpad.)

now our menu.lst in ubuntu follows

# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,5)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=232d9e4c-48f8-474d-83c5-a559530a9679 ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,6)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash access=v3

## should update-grub lock old automagic boot options
## e.g. lockold=false
## lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

howmany=2
color cyan/blue white/blue

## ## End Default Options ##

title Ubuntu 8.04.3 LTS, kernel 2.6.24-24-generic
root (hd0,6)
kernel /boot/vmlinuz-2.6.24-24-generic root=UUID=232d9e4c-48f8-474d-83c5-a559530a9679 ro quiet splash access=v3
initrd /boot/initrd.img-2.6.24-24-generic
quiet

title Ubuntu 8.04.3 LTS, kernel 2.6.24-24-generic (recovery mode)
root (hd0,6)
kernel /boot/vmlinuz-2.6.24-24-generic root=UUID=232d9e4c-48f8-474d-83c5-a559530a9679 ro single
initrd /boot/initrd.img-2.6.24-24-generic

title Ubuntu 8.04.3 LTS, memtest86+
root (hd0,6)
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

how can i get into suse linux os.?please help. i am new to computer and linux .
 
Old 07-18-2009, 05:48 AM   #2
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
No suse linux is not on you're menu.lst ?
Did you know on which partition suse linux is ?
If not run fdisk -l in terminal (L lower)to find out where she is and post the outcome
If you know on which partition opensuse is
Add ad the bottom of you're menu.lst
the next lines

title opensuse
root (hd0,?) ? being the partition of opensuse remember GRUB start counting by ZERO (hdo,1) is sda partition sda2
configfile /boot/grub/menu.lst
If it do not start opensuse post agian
 
Old 07-18-2009, 09:10 AM   #3
vijay2009
LQ Newbie
 
Registered: Jul 2009
Posts: 6

Original Poster
Rep: Reputation: 0
fdisk -l shows the following:

Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0006fbd2

Device Boot Start End Blocks Id System
/dev/sda1 1 13055 104864256 83 Linux
/dev/sda2 13056 26110 104864287+ 83 Linux
/dev/sda3 * 26111 26241 1052257+ 83 Linux
/dev/sda4 26242 38913 101787840 f W95 Ext'd (LBA)
/dev/sda5 26242 26764 4200966 82 Linux swap / Solaris
/dev/sda6 26765 31985 41937651 c W95 FAT32 (LBA)
/dev/sda7 31986 35632 29294496 83 Linux
/dev/sda8 35633 38913 26354601 83 Linux
elcot@elcot-laptop:~$

Then What we do?
 
Old 07-18-2009, 09:15 AM   #4
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,084

Rep: Reputation: 336Reputation: 336Reputation: 336Reputation: 336
did you find out what partition it's on?
you must edit your /boot/grub/menu.lst or /boot/grub/grub.conf
as root

Quote:
title opensuse
root (hd0,?) ? being the partition of opensuse remember GRUB start counting by ZERO (hdo,1) is sda partition sda2
configfile /boot/grub/menu.lst
using ubuntu's filebrowser as root look into each partition, find suse partition
edit suse menu.lst
to open ubuntu root filebrowser
"sudo nautilus"
and your password
 
Old 07-19-2009, 03:55 AM   #5
vijay2009
LQ Newbie
 
Registered: Jul 2009
Posts: 6

Original Poster
Rep: Reputation: 0
in terminal(on ubuntu ), i type sudo nautilus it asks password .after entering password ,it opens root-file browser(in the places menu ofroot-file browser,there are root,desktop,file system,1.1GB media,42.9GB media,107.4GB media,107.4GB media and trash.
in the 1.1GB media i saw menu.lst(media/disk/boot/boot/grub)-gedit file.it shows the following

# Modified by YaST2. Last modification on Sat Jan 3 08:21:32 IST 2009
default 1
timeout 8
gfxmenu (hd0,2)/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: xen###
title Xen -- SUSE Linux Enterprise Desktop 10 - 2.6.16.60-0.33
root (hd0,2)
kernel /xen.gz
module /vmlinuz-2.6.16.60-0.33-xen root=/dev/disk/by-id/scsi-SATA_WDC_WD3200BEVT-_WD-WXE308JF2860-part1 vga=0x314 resume=/dev/sda5 splash=silent showopts
module /initrd-2.6.16.60-0.33-xen

###Don't change this comment - YaST2 identifier: Original name: linux###
title SUSE Linux Enterprise Desktop 10 - 2.6.16.60-0.33
root (hd0,2)
kernel /vmlinuz-2.6.16.60-0.33-smp root=/dev/disk/by-id/scsi-SATA_WDC_WD3200BEVT-_WD-WXE308JF2860-part1 vga=0x314 resume=/dev/sda5 splash=silent showopts
initrd /initrd-2.6.16.60-0.33-smp

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- SUSE Linux Enterprise Desktop 10 - 2.6.16.60-0.33
root (hd0,2)
kernel /vmlinuz-2.6.16.60-0.33-smp root=/dev/disk/by-id/scsi-SATA_WDC_WD3200BEVT-_WD-WXE308JF2860-part1 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
initrd /initrd-2.6.16.60-0.33-smp

and the terminal shows the following

Initializing nautilus-share extension
seahorse nautilus module initialized
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.


** (nautilus:7728): WARNING **: Unable to add monitor: Operation not supported

is this correct?
then what we do?
 
Old 07-19-2009, 08:04 AM   #6
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
What are you trying to do ?
If I am correct than UBUNTU is up and running.
But opensuse is not
In this case you have to add the lines I describe before in the menu.lst
off UBUNTU
Adding it in UBUNTU as I describe before nano /boot/grub/menu.lst

If opensuse is up and running and not ubuntu you have to add it in the menu.lst of opensuse.
 
Old 07-20-2009, 03:03 AM   #7
vijay2009
LQ Newbie
 
Registered: Jul 2009
Posts: 6

Original Poster
Rep: Reputation: 0
we added the following lines in the menu.lst(gedit boot/grub/menu.lst)i.e, before ###END DEBIAN AUTOMAGIC KERNELS LIST .
title opensuse
root (hd0,2)
configfile /boot/grub/menu.lst

and then save it.
after rebooting it shows opensuse(seen at the end) and ubuntu os .
we select opensuse and goes into it.it shows the following
Xen -- SUSE Linux Enterprise Desktop 10 - 2.6.16.60-0.33
SUSE Linux Enterprise Desktop 10 - 2.6.16.60-0.33
Failsafe -- SUSE Linux Enterprise Desktop 10 - 2.6.16.60-0.33

then it automatically goes into (within few seconds)SUSE Linux Enterprise Desktop 10 - 2.6.16.60-0.33

many lines gone up. finally we saw the following lines(we gave here few lines what we have seen at the end.)
BIOS EDD Fcility r0.16 2004-jun-25, 1 devices found.
Loading reiserfs
Attempting manual resume
waiting for device /dev/disk/by-id/SCSI-SATA_WDC_WD3200BEVT-_WD-WXE308JF2860- Part1 to appear:..................not found--exiting to /bin/sh
$_

(here we do not know how to come out of this so then we typed exit and it shows the following)
umonunt: /dev: device is busy
umonunt: /dev: device is busy
kernel panic - not syncing: attempted to kill init!
(here no key board keys work.so we press and hold down the power button for few seconds until it shutsdown the computer.)
then what we do?
 
Old 07-22-2009, 09:59 AM   #8
vijay2009
LQ Newbie
 
Registered: Jul 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Hai Ronlau9,
What we can do then?
 
Old 07-23-2009, 08:04 AM   #9
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
From what I see now from you're last posting that you have Suse Linux Enterprise Desktop.
That is the Novell version and supported by Novell
Although it is based on opensuse it not the same as opensuse
I am used to opensuse.
 
Old 07-24-2009, 02:16 AM   #10
vijay2009
LQ Newbie
 
Registered: Jul 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Ok we approch novell forum .thanks for your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error 15: File not found ; booting problem pradeep_ad Fedora 1 05-13-2009 10:12 AM
Error like msg found while booting vibinlakshman Linux - Software 3 12-13-2008 01:23 PM
Older Grub will not boot newer Suse: error 15 File not found ronaldv Suse/Novell 3 10-08-2008 04:53 AM
GRUB, SUSE, Error 15 File Not Found fizgigtiznalkie Linux - Distributions 2 08-31-2004 06:38 PM
When booting PCMCIA error...driver not found? claudius753 Linux - Newbie 1 01-30-2004 01:19 AM


All times are GMT -5. The time now is 09:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration