LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Epson EPL-5900L printer not working (http://www.linuxquestions.org/questions/suse-novell-60/epson-epl-5900l-printer-not-working-4175446469/)

Ormu 01-20-2013 10:03 AM

Epson EPL-5900L printer not working
 
I'm trying to get Epson EPL-5900L to work on openSuse 12.2 (64bit, kernel 3.4.11-2.16-desktop). I once got it to work on Mandriva but I don't remember how.

I followed the steps explained here and installed epsonepl driver from Sourceforge and now the printer is recognized in YaST, but I can't get a working PPD file for it.

I tried to manually assign each of the three PPD files provided in the epsonepl package but they all seem to be invalid. YaST complains about too long lines in the file etc.


Ghostscript version information (gs -v):

Quote:

GPL Ghostscript 9.05 (2012-02-08)
Copyright (C) 2010 Artifex Software, Inc. All rights reserved.
CUPS error log:

Quote:

E [20/Jan/2013:09:59:06 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
E [20/Jan/2013:10:14:15 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
E [20/Jan/2013:16:16:01 +0200] Browsing=1
E [20/Jan/2013:16:16:01 +0200] BrowseLocalProtocols=0
E [20/Jan/2013:16:16:01 +0200] BrowseRemoteProtocols=1
E [20/Jan/2013:16:16:01 +0200] BROWSE_CUPS=1
E [20/Jan/2013:16:16:01 +0200] Unable to bind socket for address [v1.::1]:631 - Address already in use.
E [20/Jan/2013:16:39:20 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
W [20/Jan/2013:16:49:56 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/Epson-EPL-5900L-epl5900l.ppd!
E [20/Jan/2013:16:49:56 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
W [20/Jan/2013:16:51:09 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/Epson-EPL-5900L-epl5900l.ppd!
E [20/Jan/2013:16:51:09 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
W [20/Jan/2013:16:53:37 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/Epson-EPL-5900L-epl5900l.ppd!
W [20/Jan/2013:16:53:37 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/epl5900l.ppd!
E [20/Jan/2013:16:53:37 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
W [20/Jan/2013:16:55:27 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/Epson-EPL-5900L-epl5900l.ppd!
W [20/Jan/2013:16:55:27 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/epl5900l.ppd!
E [20/Jan/2013:16:55:27 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!
W [20/Jan/2013:16:58:52 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/Epson-EPL-5900L-epl5900l.ppd!
W [20/Jan/2013:16:58:52 +0200] [CGI] Missing Product in /usr/share/cups/model/downloaded/epl5900l.ppd!
E [20/Jan/2013:16:58:52 +0200] [cups-driverd] Bad driver information file "/usr/share/cups/drv/sample.drv"!

I also installed manufacturer-PPDs package which contains a file for EPL-5900 but as I expected it doesn't work (see below).

Information about the printer on Linux:
http://www.openprinting.org/printer/...pson-EPL-5900L

John VV 02-02-2013 05:34 PM

I take it you have tried the cups web interface ?
http://localhost:631

OS gui's have never been good for me
but the cups localhost page has always done what i need

Ormu 02-08-2013 03:29 PM

Same problem. The printer is recognized but this model is not listed in the model list. Only EPL-5900 is but it does not work. Printing doesn't even start.

When I try to manually assign a PPD file (any of the three) provided with the epsonepl driver package it gives an error:

Code:

Set Printer Options EPSON_EPL-5900L Error

Unable to open PPD file:

    Line longer than the maximum allowed (255 characters)



All times are GMT -5. The time now is 02:54 AM.