LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 09-08-2008, 06:13 PM   #1
aleangelico
LQ Newbie
 
Registered: Feb 2007
Posts: 4

Rep: Reputation: 0
dhcp not working with 2wire 1700hg


Hi!

I'm running an openSuse 11 and I cannot obtain a dhcp address from the 2wire dsl modem we use for internet access. But I can get it from any other dhcp in the network (there are 2 Win 2003 server running dhcp servers)

I connected the linuxbox directly to the 2wire cable and after many retries it gives up, but never receive the ip address. Anyone had a similar issue with a 2wire modem?

regards
Alex
 
Old 09-09-2008, 04:17 PM   #2
asimba
Member
 
Registered: Mar 2005
Location: 127.0.0.0
Distribution: Red Hat / Fedora
Posts: 349

Rep: Reputation: 42
How do you know you are not getting any address ? if you could get few more details on that.

It could be a few reasons:

1.Network Adapter is disabled
2.Do you MAC filters in place for DHCP./Sticky IP addresses ?
3.It could be hardware problem - probably cable/port may have gone bad.
 
Old 09-09-2008, 07:09 PM   #3
aleangelico
LQ Newbie
 
Registered: Feb 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Is a somehow complicated installation. There are 2 DHCP servers running and the linux box get addresses with no problem from them. The thing is I want to put this computer in the DSL Router DMZ and for that the modem generates an ip address for the PC.
If I connect the linux box to the network switch and run the dhclient I always get addresses from the Win DHCP Servers
Then I connected the PC directly to the modem and disconected the modem from the network (but not from the phone line). I run the dhclient and it retries many times until giving up because the modem DHCP server is not giving any address to the Linux Box.

Maybe the modem is damaged, but the modem dhcp server was working a few months ago...
 
Old 09-10-2008, 07:42 AM   #4
asimba
Member
 
Registered: Mar 2005
Location: 127.0.0.0
Distribution: Red Hat / Fedora
Posts: 349

Rep: Reputation: 42
Dunno - I might have suggested moving in for Static IP address considering you plan it for DMZ.
 
  


Reply

Tags
dhcp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DHCP not working swiezy Linux - Networking 10 10-23-2007 03:38 AM
2WIRE Wireless PC card not working ? ! ? andre-w Ubuntu 2 06-15-2007 09:16 PM
2wire wifi card... can't get it working in Debian. Keychain Linux - Wireless Networking 2 09-07-2005 02:24 PM
Fedora 2 2Wire card not fully working anthony1101 Linux - Laptop and Netbook 26 01-19-2005 02:44 PM
Fedora 3 2Wire card not fully working (possible wrong driver?) anthony1101 Linux - Laptop and Netbook 1 11-30-2004 11:44 AM


All times are GMT -5. The time now is 10:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration