LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 12-11-2006, 01:49 AM   #1
litlmary
Member
 
Registered: May 2005
Location: Texas, somewhere near Houston (I think)
Distribution: See my sig
Posts: 307

Rep: Reputation: 30
Dead Samba in 10.2???


The file server on my network has a static IP of 192.168.1.2 with its shares using Samba.

I can access them easily using Konqueror by punching
Code:
smb://192.168.1.2/sharename/
into the address bar.

In previous installs I have had lines like this in my fstab:
Code:
//192.168.1.2/sharename /path smbfs  auto,credentials=/root/.credentials,uid=1000 0 0

(with the associated /root/.credentials file in place, of course)
to access them.

I did a fresh install of 10.2 (and am quite impressed so far) using an identical setup as I have always done and now
Code:
mount -a
as root pukes
Code:
ERROR: smbfs filesystem not supported by the kernel
Please refer to the smbmnt(8) manual page
smbmnt failed: 255
ERROR: smbfs filesystem not supported by the kernel
Please refer to the smbmnt(8) manual page
smbmnt failed: 255
ERROR: smbfs filesystem not supported by the kernel
Please refer to the smbmnt(8) manual page
smbmnt failed: 255
at me.

I checked my installed packages and have
Code:
kdebase3-samba
samba
samba-client
samba-doc
samba-pdb
yast2-samba-client
yast2-samba-server
installed with services
Code:
smb
smbfs
running at runlevels 3 and 5. I even checked to make sure the services are currently running (they are).

my smb.conf looks like this
Code:
# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2006-11-27
[global]
workgroup = PC_SUPREME
printcap name = cups
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
usershare allow guests = Yes
security = share
restrict anonymous = no
domain master = no
preferred master = no
server string = 
max protocol = NT
acl compatibility = winnt
ldap ssl = No
server signing = Auto

[homes]
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes

[profiles]
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700

[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/

[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes

[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775
and doesn't seem out of line to my semi-experienced eye.

I have noticed that, judging only by the seat of my pants, 10.2 seems substantially faster than its predecessors. Since the error I am getting is kernel-related I am suspicious that the default kernel is now more modular and less monolithic (hence the speed) and a module required by samba is not being loaded.
Code:
lsmod | grep smb
gets me zilch and
Code:
modprobe smbfs
flops out on me.

On further reflection, maybe this isn't a module issue... As I said, I can access smb shares using Konqueror just fine!

Am I far off?

TIA,

J

Last edited by litlmary; 12-11-2006 at 03:34 AM.
 
Old 12-11-2006, 04:27 AM   #2
litlmary
Member
 
Registered: May 2005
Location: Texas, somewhere near Houston (I think)
Distribution: See my sig
Posts: 307

Original Poster
Rep: Reputation: 30
Hmm... a little tinkering seems to have me straightened out.

Code:
lsmod | grep cifs
got me a result, so I changed
Code:
//192.168.1.2/sharename /path smbfs  auto,credentials=/root/.credentials,uid=1000 0 0
to
Code:
//192.168.1.2/sharename /path cifs  auto,credentials=/root/.credentials,uid=1000 0 0
and it looks like all is ok.

Feel free to share your thoughts and I will report back if there are problems.

J
 
Old 01-21-2007, 05:08 PM   #3
gbport
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Rep: Reputation: 0
I'm having the same problem. Oddly, when I upgraded from 10.1 the problem didn't manifest. However, for unrelated reasons, I had to re-format the hard drive and do a clean install. Then the problem arose. I tried the solution referenced in the above post. No go.
I went to the shell and got this result:
:~ # lsmod | grep smb [no result returned. Cursor went to next line]
:~ # modprobe smbfs
FATAL: Module smbfs not found.

Yet this command: smb://192.168.0.150/filecabinet works. If samba's not installed, how on earth can I access it? In 9.3 10.0 and 10.1 I was able to attach the share to the tree with a line in the fstab. It doesn't work now, and I now have the paradox of the smbfs module not found while able to navigate via the smb:// in konqueror.
 
Old 01-21-2007, 09:46 PM   #4
litlmary
Member
 
Registered: May 2005
Location: Texas, somewhere near Houston (I think)
Distribution: See my sig
Posts: 307

Original Poster
Rep: Reputation: 30
cifs does have to be loaded... does "lsmod" turn up cifs in the list? If not, try "modprobe cifs" and give it another go.
 
Old 01-22-2007, 10:30 AM   #5
tjewkes67
LQ Newbie
 
Registered: Oct 2003
Location: Utah
Distribution: SuSe10.0
Posts: 8

Rep: Reputation: 0
litlmary your cifs solution worked for me

here is what I did in opensuse10.2.
mkdir /home/me/network_music/

mount -t cifs //192.168.xx.xx/shared_folder /home/me/network_folder

I was also getting the "smbfs not supported in kernel" error.
 
Old 02-01-2007, 01:50 AM   #6
PB0711
Member
 
Registered: Aug 2004
Location: London, UK
Distribution: Ubuntu 10.10, ubuntu 11.04, suse 9.2, OSX
Posts: 259

Rep: Reputation: 30
Umm I have to agree on this one. All is happy but cannot mount smb drives. I have noticed that cifs is needed for mounting drives as said by yast. My server doesn't have the CD in so will wait till tomorrow to check on the issue after installing cifs. fingers crossed.
 
Old 02-02-2007, 08:18 AM   #7
gbport
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Rep: Reputation: 0
Started Services?

I tried to started samba services in YAST. Oddly, it worked on my wife's machine, but not on my daughter's. Both are running 10.2, but my daughter's came from the SuSe website and my wife's came from Linux magazine, http://www.linux-magazine.com/issue/75.
 
Old 02-02-2007, 12:54 PM   #8
PB0711
Member
 
Registered: Aug 2004
Location: London, UK
Distribution: Ubuntu 10.10, ubuntu 11.04, suse 9.2, OSX
Posts: 259

Rep: Reputation: 30
Yea so I installed cifs and still I get the:
Code:
ERROR: smbfs filesystem not supported by the kernel
Please refer to the smbmnt(8) manual page
smbmnt failed: 255
Having a look on the suse website I haven't found anything yet also looking on the usenet alt.OS/suse through google, nothing .

Anyone any ideas?

All of my servers have come from the Suse website. I always do the default software setup, I've had it not boot before when I've added things. Yes you say if you add something not compatiable but this is like adding NIS client or taking games off. Anyway I'll stop my rantings. .

EDIT: UMM, ok so I rebooted (I had installed fortran) and randomly I tried the mount -t cifs and it worked. But it mounted with a mask of '777' well actually it's rwxrwSrwt (?S?t) and root:root . So I don't see why cifs works and smbfs doesn't? Anyway I guess I'm happy.

Last edited by PB0711; 02-02-2007 at 01:02 PM.
 
Old 02-03-2007, 07:58 PM   #9
gbport
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Rep: Reputation: 0
I got the same. So, I tried: mount -t cifs //192.168.0.150/filecabinet /mnt/server. Now, for the first time my NAS is asking for password, something it doesn't do with the other machines. I edited my fstab to add username=username,password=password (//192.168.0.150/filecabinet /mnt/server cifs rw,username=username,password=password, uid=user, gid=users 0 0) and added the the username and password to my users on my NAS. Then I executed mount -a to execute my fstab and suddenly, I have access to my NAS. No clue why it works. I'm going to execute a reboot and see if it takes.
 
Old 02-03-2007, 10:14 PM   #10
shadowdancer
Member
 
Registered: Jan 2007
Location: Indonesia
Distribution: openSUSE, Slackware, Now Debian, and now again: Ubuntu
Posts: 61

Rep: Reputation: 15
As default, SUSE 10.2's kernel do not support samba file system. We need to compile another kernel (the newest is good, i think. I use 2.6.19.2).

Don't forget to enable File System->Network File System->Samba

Everything is okay. I just cannot get AppArmor work. It seems the kernel module is custom by Novell. But i don't care. I think my system will be safe without AppArmor...

Thanks
 
Old 02-05-2007, 11:39 AM   #11
PB0711
Member
 
Registered: Aug 2004
Location: London, UK
Distribution: Ubuntu 10.10, ubuntu 11.04, suse 9.2, OSX
Posts: 259

Rep: Reputation: 30
Umm ok, recompiling kernel.... I remember that in gentoo but in suse I've never done it and have no idea where to start. Any suggestions? Google it I know
 
Old 02-22-2007, 04:30 PM   #12
litlmary
Member
 
Registered: May 2005
Location: Texas, somewhere near Houston (I think)
Distribution: See my sig
Posts: 307

Original Poster
Rep: Reputation: 30
You only need to recompile the kernel if you are bent on using smbfs. The default kernel works fine. Recompiling in Suse is also a chore because of the lack of a .config file ("make oldconfig" wont even get it for me!). As I have said elsewhere, smbfs is depricated and cifs is backward compatible with it. If you use cifs instead of smbfs in your fstab or CLI mount string it should be good, so long as the cifs module is loaded.

In regards to the NAS box demanding a user/pass, fstab is not a secure place to keep that info, since all users can view it. You can specify a credentials file instead and then set its permissions to ensure that everyone but root is forbidden.

viel gluck,

J
 
Old 02-25-2007, 01:38 PM   #13
jhaigh
LQ Newbie
 
Registered: Jun 2005
Distribution: OpenSUSE 10.2
Posts: 2

Rep: Reputation: 0
Wink

Quote:
Originally Posted by litlmary
You only need to recompile the kernel if you are bent on using smbfs. The default kernel works fine. Recompiling in Suse is also a chore because of the lack of a .config file ("make oldconfig" wont even get it for me!). As I have said elsewhere, smbfs is depricated and cifs is backward compatible with it. If you use cifs instead of smbfs in your fstab or CLI mount string it should be good, so long as the cifs module is loaded.

In regards to the NAS box demanding a user/pass, fstab is not a secure place to keep that info, since all users can view it. You can specify a credentials file instead and then set its permissions to ensure that everyone but root is forbidden.

viel gluck,

J
LinuxQuestions.org

serious smbfs problem in 10.2
Hi after upgrading from suse 10.1 to suse 10.2 i can acccess my samba partitions . I receive the folloiwng message
ERROR: smbfs filesystem not supported by the kernel

My /etc/fstab line is
//perasma/mp3 /media/mp3 smbfs password='' 0 0

I am searching to google to find a solution and find out some suggestions to replace smbfs and make it cifs
//perasma/mp3 /media/mp3 cifs password='' 0 0
Still i cant mount it..
I also find to the google many novell guys complaining about that and they suggest to compile the kernel to add smbfs support to kernel. I cant believe (really i can't) that suse has left smbfs support outisde kernel. Do u knw any other solution... except kernel compiling? and if not i would need a suse link of how to compile a suse kernel(cause as far as i know suse has a little different way tocompile kernels)


Registered: Jan 2004
Location: Munich
Posts: 266
Distribution: SuSE 8.1/.2, 9.0/.1/.2



Quote:
Originally Posted by alaios
Do u knw any other solution... except kernel compiling? and if not i would need a suse link of how to compile a suse kernel(cause as far as i know suse has a little different way tocompile kernels)




Quote:
Originally Posted by Marius2
Try to mount with cifs filesystem instead of smbfs (mount
-t cifs instead of -t smbfs). Note: with a quick try, this
didn't work for me, so I recompiled the kernel.
After this, cifs worked as well as smbfs.


1. install kernel source with yast
2. cd /usr/src/linux
3. make cloneconfig
4. make menuconfig (choose filesystem -> network file
systems -> SMBFS)
5. make prepare
6. make all
7. make modules_install

That's it.
Unread Today, 02:32 PM #7
jhaigh
Newbie

Registered: Jun 2005
Posts: 1
Distribution: OpenSUSE 10.2

Wink
Quote:
Originally Posted by alaios
Come on plz help me.. .i cant work on my pc i have to mount that damn windows 98 shared folder...HELP




I came here with the same 10.2/SMBFS issue and followed Marius2's advice. Worked first time, although recompile took longer than I expected - over an hour to compile the new kernel. But results were spectacular! Drop SMBFS right now and go w/CIFS - it's part of the Samba suite anyway. I edited my /etc/fstab with this line:
//computer_name/share /localmachine/mount-point CIFS auto,gid=users,credentials=passwd_filename 0 0

Make sure you chmod 600 the passwd_file so only root can read it. Passwd file format is
username = user w/access privileges on MS box
password = secret

Now my network shares on my W2k domain controller are all visible and mount at boot up. Just what I wanted! BTW You may have to use yast2 to install not only the kernel source packages, but also the gcc compiler and curses as well. Not hard to do at all. Kudos to Marius2

Last edited by jhaigh; 02-25-2007 at 01:51 PM.
 
Old 02-05-2010, 02:38 PM   #14
virtualx
LQ Newbie
 
Registered: Oct 2005
Posts: 22

Rep: Reputation: 15
No Write Access!!

I tried cifs, it only give you read access on a openSUSE box. Hardly what I could consider an adiquate replacement for smb.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Symptoms of a Dead MOBO vs a Dead Processor..... Delano_Lucas General 7 07-26-2006 04:50 PM
Please tell me its not dead franznietzsche Linux - Hardware 10 04-09-2005 12:42 AM
Xinetd dead --xinetd dead but pid file exists hillxy Linux - General 1 04-15-2004 02:10 PM
Dead Display = Dead Machine chris319 Linux - Hardware 1 12-05-2003 06:37 AM
Squid:2nd Browser access Internet SPEED dead becomes dead slow mwj Linux - Software 1 10-04-2003 01:40 PM


All times are GMT -5. The time now is 11:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration