LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 03-09-2007, 01:00 PM   #1
navik_pathak
LQ Newbie
 
Registered: Feb 2007
Location: California,US
Distribution: Suse 10.2
Posts: 20

Rep: Reputation: 0
Configure LAN Card in Suse 10.2


Hi ,

I am new to Suse 10.2.

i can see my LAN card in Yast and see that it is using ipv6.

how can i configure my LAN so that i can use my internet.?

do i have to give exact DCHP server ip address for my COMCAST service?
how to configure that please let me know on this?

If some can put in step i will be greatful..

thanks in advance
 
Old 03-09-2007, 02:45 PM   #2
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Rep: Reputation: 30
Is your LAN card actually configured though? Being recognised in Yast doesn't mean it works!

Open a terminal as root and type 'iwconfig' Does this give a wireless option such as wlan0? Is your radio network listed or found? post your output here.
 
Old 03-09-2007, 02:47 PM   #3
navik_pathak
LQ Newbie
 
Registered: Feb 2007
Location: California,US
Distribution: Suse 10.2
Posts: 20

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Adrian Baker
Is your LAN card actually configured though? Being recognised in Yast doesn't mean it works!

Open a terminal as root and type 'iwconfig' Does this give a wireless option such as wlan0? Is your radio network listed or found? post your output here.
it is not wireless...it is ethernet card.

i used ifconfig and it shows
lo

etho

slo

something like that...
 
Old 03-10-2007, 11:26 AM   #4
navik_pathak
LQ Newbie
 
Registered: Feb 2007
Location: California,US
Distribution: Suse 10.2
Posts: 20

Original Poster
Rep: Reputation: 0
any suggestions???
 
Old 03-10-2007, 10:08 PM   #5
swerdna
Member
 
Registered: Jun 2006
Location: Oz
Distribution: openSUSE 10.x
Posts: 80

Rep: Reputation: 15
Quote:
Originally Posted by navik_pathak
any suggestions???
Hello navik_pathak, that's surely not what it said when you entered "ifconfig". There must have been more than that. Can you do it again, enter two commands: first is su to take you into a root terminal, second is ifconfig. You can use copy/paste to put the results from your terminal session into your forum post.

We think you haven't configured your NIC but need to see the results of ifconfig to be sure.

Swerdna
 
Old 03-11-2007, 09:53 AM   #6
navik_pathak
LQ Newbie
 
Registered: Feb 2007
Location: California,US
Distribution: Suse 10.2
Posts: 20

Original Poster
Rep: Reputation: 0
Hi...thanks for reply...

pporacle:~ # whoami
root
pporacle:~ # ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:14:22:A9:3C:96
inet addr:169.254.232.237 Bcast:169.254.255.255 Mask:255.255.0.0
inet6 addr: fe80::214:22ff:fea9:3c96/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1003 errors:0 dropped:0 overruns:0 frame:0
TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:64756 (63.2 Kb) TX bytes:3098 (3.0 Kb)
Interrupt:177

pporacle:~ #

it is taking broadcast ip.

any help/suggestions!!!!
 
Old 03-11-2007, 05:32 PM   #7
swerdna
Member
 
Registered: Jun 2006
Location: Oz
Distribution: openSUSE 10.x
Posts: 80

Rep: Reputation: 15
Quote:
Originally Posted by navik_pathak
Hi...thanks for reply...

pporacle:~ # whoami
root
pporacle:~ # ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:14:22:A9:3C:96
inet addr:169.254.232.237 Bcast:169.254.255.255 Mask:255.255.0.0
inet6 addr: fe80::214:22ff:fea9:3c96/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1003 errors:0 dropped:0 overruns:0 frame:0
TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:64756 (63.2 Kb) TX bytes:3098 (3.0 Kb)
Interrupt:177

pporacle:~ #

it is taking broadcast ip.

any help/suggestions!!!!
Hello again.
The first thing this shows is that your Network Interface Card (NIC) is recognised by Suse and is working, because it has an IP address.
The second thing this shows is that you are not receiving an IP address from the DHCP server because the address starts with 169.254 - These addresses are known as APIPA addresses.
First turn off ipv6 because it severely slows internet. Here's a link.
Second - you have not got connectivity with the DHCP server.
This is addressed one of two ways. But I cannot advise you further until I know which of the two ways you are connecting to the internet. So now I ask you this: Are you connecting to a router that connects to the modem or are you connecting directly to the modem?
And I ask you this: Is your modem a dial-up modem, a DSL/ADSL modem or a cable modem?

Please answer those two questions. In the meantime here is a picture for you to consider. Make things like Pic 4 and Pic 6.

Swerdna.
 
Old 03-11-2007, 05:58 PM   #8
inspiron_Droid
Member
 
Registered: Dec 2006
Distribution: Debian (Wheeze)
Posts: 391

Rep: Reputation: Disabled
You shouldnt need to obtain the dns informati9on from comcast as their network runs on a dynamic dns strucure which means that every time boot up you will automatically be asigned an Ip address fronm their dns servers. Thus you should be able to simply hook the catogory five cable from you modem directly into your Net work Interface Card (NIC) and surf to your hearts contenet.
 
Old 03-11-2007, 07:27 PM   #9
navik_pathak
LQ Newbie
 
Registered: Feb 2007
Location: California,US
Distribution: Suse 10.2
Posts: 20

Original Poster
Rep: Reputation: 0
Quote:
Second - you have not got connectivity with the DHCP server.
This is addressed one of two ways. But I cannot advise you further until I know which of the two ways you are connecting to the internet. So now I ask you this: Are you connecting to a router that connects to the modem or are you connecting directly to the modem?
And I ask you this: Is your modem a dial-up modem, a DSL/ADSL modem or a cable modem?
hey thanks for reply...

i have a cable connection which is connected to a cable modem and than i am using RJ45 connection from cable modem to Laptop.

2) i have disabled ipv6 from Yast->Network->Network Card...selected the card
and in adavance option i have disable ipv6 so thats how i have disabled ipv6

3) i have installed oracle application 11i on my machine so i dont want to change my host domain....if it is possible....

thanks in advance
 
Old 03-12-2007, 12:43 PM   #10
navik_pathak
LQ Newbie
 
Registered: Feb 2007
Location: California,US
Distribution: Suse 10.2
Posts: 20

Original Poster
Rep: Reputation: 0
any suggestions?
 
Old 03-12-2007, 07:01 PM   #11
swerdna
Member
 
Registered: Jun 2006
Location: Oz
Distribution: openSUSE 10.x
Posts: 80

Rep: Reputation: 15
Quote:
Originally Posted by navik_pathak
any suggestions?
Hello again sorry for delay - busy.
Your network card works because it has an APIPA address.
OK you should be getting a DHCP-provided IP address straight to your network Interface card (NIC) from Comcast according to flanksteak). That's normal. BUT you aren't. So what else? OK there are two questions: Authentication and connectivity. Solve connectivity first:
  • Check in Yast software management that these packages have been installed: dhcp-client, dhcpcd, dhcddb, dhcp - but I don't think that's the problem because that's installed by default.
  • Check that there are lights on the NIC socket indicating traffic to and from the cable modem - mine has a rapidly flashing green light showing network traffic.
  • Try replacing the ethernet cable.
  • Do you have a windows connection from the same machine with the same hardware - the only difference being dual-boot - to check the connectivity.
That's probably enough for the basics

Last edited by swerdna; 03-12-2007 at 07:02 PM.
 
Old 03-12-2007, 07:06 PM   #12
navik_pathak
LQ Newbie
 
Registered: Feb 2007
Location: California,US
Distribution: Suse 10.2
Posts: 20

Original Poster
Rep: Reputation: 0
thanks for reply....

Quote:
[*]Check in Yast software management that these packages have been installed: dhcp-client, dhcpcd, dhcddb, dhcp - but I don't think that's the problem because that's installed by default.
all are present
Quote:
[*]Check that there are lights on the NIC socket indicating traffic to and from the cable modem - mine has a rapidly flashing green light showing network traffic.
Mine too...constantly fleshing light

Quote:
[*]Try replacing the ethernet cable.[*]Do you have a windows connection from the same machine with the same hardware - the only difference being dual-boot - to check the connectivity.[/list]That's probably enough for the basics
i have dual boot Laptop with Windows XP Media Center. I can connect from Windows and writing this reply on the same.....

any thing you think i should do?

thanks in advance
 
Old 03-12-2007, 08:31 PM   #13
swerdna
Member
 
Registered: Jun 2006
Location: Oz
Distribution: openSUSE 10.x
Posts: 80

Rep: Reputation: 15
Hi navik_pathak, so the problem is not the connectivity, unless there's a problem in Linux regarding full recognition of the NIC - unlikely to be a problem there. It seems to narrow to the ISP-specific issues such as mac address, authentication, etc, of which I have no knowledge. You probably need someone understanding Comcast-specific issues to chime in now. It's interesting that flanksteak can simply hook up and surf - perhaps he can tell you what is his authentication client - or is it a question of Comcast "allowing" your specific mac address? Also talk to Comcast (if they will respond to a Linux questioner) regarding authentication and their gateway.

Another thought - since you can connect via windows with exactly the same hardware setup - you can obtain the correct DNS settings and gateway address for inserting into the NIC configuration under DHCP in Linux - from the windows command at start --> programs --> accessories --> command prompt: ipconfig/all

Clearly need more help from others if this doesn't help - plus talk to Comcast.
 
Old 03-12-2007, 10:11 PM   #14
navik_pathak
LQ Newbie
 
Registered: Feb 2007
Location: California,US
Distribution: Suse 10.2
Posts: 20

Original Poster
Rep: Reputation: 0
thanks...i have not checked change hostname via DHCP ...is that may be the cause???
 
Old 03-12-2007, 10:44 PM   #15
swerdna
Member
 
Registered: Jun 2006
Location: Oz
Distribution: openSUSE 10.x
Posts: 80

Rep: Reputation: 15
Quote:
Originally Posted by navik_pathak
thanks...i have not checked change hostname via DHCP ...is that may be the cause???
Yes make it like the three pics in the picture link in post#7

Last edited by swerdna; 03-12-2007 at 10:47 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to configure my Wireless LAN PCMCIA Card - realtek 8180l neowillis Debian 1 12-26-2004 06:13 AM
How to setup and configure linksys wmp11 wireless lan on SuSe 8.2 penguinhack62 Linux - Hardware 0 05-18-2004 04:16 AM
Buffalo wireless lan card and SuSE? skunkcabbage Linux - Wireless Networking 2 03-24-2004 05:29 AM
Can I indetify my LAN card? For a SuSE install. ions Linux - Hardware 3 09-05-2003 12:43 AM
Lan card RTL8319B how to configure farhan Linux - Networking 1 03-06-2003 03:33 AM


All times are GMT -5. The time now is 02:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration