LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Changing screen resolution on laptops with KDE 10 messes up desktop display (http://www.linuxquestions.org/questions/suse-novell-60/changing-screen-resolution-on-laptops-with-kde-10-messes-up-desktop-display-800976/)

garza 04-09-2010 04:35 AM

Changing screen resolution on laptops with KDE 10 messes up desktop display
 
Hello LQ members,

Some users in my office are using laptops with OpenSUSE KDE 10 installed. They are encountering a problem when changing their screen resolutions. Normally they have 1024X768 configured. Sometimes they need to lower it to 800X600 (e.g., to connect their laptop to a projector).

When they switch back to 1024X768, their desktop display gets messed up. Their panel/taskbar gets shifted almost to the middle of the screen and the icons on the desktop get spread out all over. It's as if the whole desktop display zoomed out back to 1024X768 but didn't take the panel and the desktop icons with it. And thus far, the only way for users to fix this problem is to restart their laptops or log out and log back in. That is too slow and cumbersome.

There are some known bugs with KDE related to screen resolution. Or it could be that the video card on some systems can't handle such screen resolution changes. Any help would be greatly appreciated, even if it is just a suggestion for quicker workarounds.

THANKS!
garza

P.S. This is my first post! :hattip:

Mr-Bisquit 04-09-2010 09:07 PM

Do the laptops have an external output?
Have you looked into the display properties?

Have you looked up zooming the display in and out?

garza 04-12-2010 03:35 AM

Quote:

Originally Posted by Mr-Bisquit (Post 3930526)
Do the laptops have an external output?
Have you looked into the display properties?

Have you looked up zooming the display in and out?

Thanks for your quick reply.

Yes, the laptops have an external output. My users encounter this problem because they often connect their laptops to a projector and have to change their screen resolutions. But this problem is not caused by the projector/external output alone, as simply changing the screen resolution messes up the desktop display.

I have experimented with the display properties to no avail. I didn't find any setting that could be the root of the issue.

Zooming in and out from a document or web page, for example, doesn't help. Neither does refreshing the desktop display.

So I'm still at a loss...

garza 04-19-2010 10:34 AM

Any new ideas or ways to work around this problem? Anybody???

ninohead 05-09-2010 12:49 PM

Try to checkout the configuration file for display
# vim /etc/sysconfig/displaymanager
-> DISPLAYMANAGER_RANDR_MODE_auto="1024x768_60 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync"

and even when your users change the screen resolution ask them to execute the below command
# rcxdm restart

hope this works



Bees are very busy souls
They have no time for birth controls
And that is why in times like these
There are so many Sons of Bees.

garza 05-20-2010 04:47 AM

Configuration file for display
 
Hello ninohead,

Thank you for your advice. I tried changing the file

# vim /etc/sysconfig/displaymanager

with various combinations for

DISPLAYMANAGER_RANDR_MODE_VGA=""

and

DISPLAYMANAGER_RANDR_MODE_auto="1024x768_60 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync"

The display continued behaving the same way, nothing I changed in these variables led to an improvement.
Some coworkers have told me this is a bug/defect of KDE and that apparently there is no current fix to it... Still, any other ideas are more than welcome.

Thanks!

wagscat123 05-23-2010 07:18 AM

It's in KDE
 
I have had the same issue to the past. It is within the KDE settings. Try seeing if the taskbar settings have something like % of buttom screen. Also, which SUSE 10 are you using? I'd tell ya what exactly to do, but it has been maybe 1 or 2 years since I had that issue. For your desktop, you can drag them back or rearrange them with the menu. Sorry, I haven't been using SUSE 10 a lot since 2008. Good luck! (You should also upgrade to 11.2 (came out 6 months ago), the last SUSE 10 came out 2 yrs 7 months ago. I see where you're coming from if you like to older versions, anyways)

garza 05-26-2010 03:37 AM

The laptops are using SUSE 10.3, and as you said, the quickest solution would be to upgrade to 11.2 and hope that clears the issue. I like both versions, it's just that this issue is not strong enough to require upgrades to all laptops in the office though users keep complaining about it.
I can't just modify the taskbar or rearrange icons on the desktop as this problem makes KDE use up only a part of the screen. It sort of squeezes the desktop display to one corner and, depending on the resolution set, a part of the whole screen is not being used.
This has to be a bug between SUSE 10.3 and laptop video cards...
Thanks for your input!

garza 08-09-2010 05:20 AM

Hello LQ members,

There is no complete fix for this problem, and I doubt there ever will be as openSUSE 10.3 and KDE 3.5 have been left behind in terms of available tech support. I guess modifying the graphics card of the laptop or replacing the card altogether COULD solve the issue...but who knows!

Anyway, I have found several workarounds for this issue and I would like to share them with you guys. Once you get the problem with the taskbar/panel in the middle of your messed-up screen, do this:


1. Logout of your session and login. You can hit Ctrl-Alt-Del and confirm
your logout on the window that appears. Then log back in as you normally
do with your userId and password.


2.
1) Right-click on the taskbar and select "Configure Panel...". The
Configure - KDE Panel will open.

2) Select the Menus section from the lefthand side.

3) At the top, toggle the "Start menu style:" option from KDE to SUSE or
vice versa, and then click on the Apply button.

4) This should change the appearance of the taskbar AND place it back on
the bottom. To switch it back to how it looked like before, toggle the
option in step 3) back to its original value.

3. This is actually the short version of workaround 2 described above and the fastest way so far.

1) Right-click on your K Menu icon which is on the lefthand side of your
taskbar.

2) Select "Switch to SUSE Menu Style" or "Switch to KDE Menu Style".
Which option appears depends on which style you have originally selected
for your K Menu.

3) This should change the appearance of the taskbar AND place it back on
the bottom. To switch it back to how it looked like before, toggle the
option in step 2) back to its original value.



Hope at least one of these helps other people. Thanks for your help and keep on the good work!

Best regards,
garza


All times are GMT -5. The time now is 01:15 AM.