LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Cant upgrade kde4.0 base system, desktop environment etc (http://www.linuxquestions.org/questions/suse-novell-60/cant-upgrade-kde4-0-base-system-desktop-environment-etc-628984/)

riba43 03-18-2008 02:25 PM

Cant upgrade kde4.0 base system, desktop environment etc
 
Hi ,

I have suse 10.3 and I have kde4 packages too. But I cant upgrade those packages to the newer version. For instance, I have, let us say, a package kdebase4, version 4.0-10.3 and there is a new version 4.0.2-8.8which can not be installed. I get the following message:

### YaST2 conflicts list - generated 2008-03-18 19:20:59 ####

kdebase4 cannot be installed due to missing dependencies
There are no installable providers of kdebase4-runtime >= 4.0.2 for kdebase4-4.0.2-8.8.x86_64[openSUSE_Factory_3]
=== kdebase4-4.0.2-8.8.x86_64[openSUSE_Factory_3] ===
kdebase4-4.0.2-8.8.x86_64[openSUSE_Factory_3] will be installed by the user.
glibc-2.6.1-18.3.x86_64 is needed by kdebase4-4.0.2-8.8.x86_64[openSUSE_Factory_3] (/sbin/ldconfig)
bash-3.2-61.x86_64 is needed by kdebase4-4.0.2-8.8.x86_64[openSUSE_Factory_3] (/bin/sh)
kdebase4-runtime-4.0.2-6.8.x86_64[openSUSE_Factory_3] provides kdebase4-runtime == 4.0.2-6.8, but it is uninstallable. Try installing it on its own for more details.
kdebase4-4.0.2-8.8.x86_64[openSUSE_Factory_3] is needed by pattern:kde4_basis-10.3-159.x86_64 (kdebase4 == 4.0.2-8.8)
(null)
Re?itev spora:
( ) do not install kdebase4
( ) Ignore this requirement just here

#### YaST2 confl


What exactly can be done???

aus9 04-02-2008 06:35 AM

ignoring your distro...try to build it in a diff folder...section 4.10
http://docs.kde.org/development/en/k...html#id2548602

roastedmnm 04-07-2008 04:02 PM

What build service directories are you using? I had a similar problem (unfortunately this was a few weeks back) and the problem was that they had reorganized the kde4 directories into a better structure, but it broke the dependency resolution.

My current repo list regarding kde4
http://download.opensuse.org/reposit...openSUSE_10.3/
http://download.opensuse.org/reposit...openSUSE_10.3/
http://download.opensuse.org/reposit...openSUSE_10.3/

Switching to this list seems to have fixed that problem. There are still a few things that conflict but they conflict with kde3 (i.e. nsplugin)

riba43 04-16-2008 01:58 PM

Quote:

Originally Posted by roastedmnm (Post 3113813)
What build service directories are you using? I had a similar problem (unfortunately this was a few weeks back) and the problem was that they had reorganized the kde4 directories into a better structure, but it broke the dependency resolution.

My current repo list regarding kde4
http://download.opensuse.org/reposit...openSUSE_10.3/
http://download.opensuse.org/reposit...openSUSE_10.3/
http://download.opensuse.org/reposit...openSUSE_10.3/

Switching to this list seems to have fixed that problem. There are still a few things that conflict but they conflict with kde3 (i.e. nsplugin)

Well thanks everybody. Nothing worked. I had to reinstall. Now I am not trying to change to KDE4 until SUSE 11.

roastedmnm 04-16-2008 03:02 PM

Sorry to hear that. Maybe openSUSE 11 will get it right.

pilotgi 04-16-2008 07:19 PM

Here's a link to an openSUSE page that has a one click install for the latest KDE4.0.3 components. It adds the correct repos and downloads all the necessary files.

http://en.opensuse.org/KDE4


All times are GMT -5. The time now is 08:16 PM.