LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   can not connect to my pureftp server from Linux client, but i can from windows client (http://www.linuxquestions.org/questions/suse-novell-60/can-not-connect-to-my-pureftp-server-from-linux-client-but-i-can-from-windows-client-301640/)

bonito 03-14-2005 06:27 PM

can not connect to my pureftp server from Linux client, but i can from windows client
 
Hallo!

i recently configured my suse9 inux box to run pure-ftpd, you know, an ftp server.

Why using pure-ftp? well, because im newbie and only because i got it to work = ]

So, i can now connect to my box across the internet from a windows pc using ws-ftp.
hooray.

But unfortuantely,
i can not connect to the same box across the internet from a Linux machine. i get stuck in some kind of passive mode.

at command line i get:
257 "/" is your current location
PASV
227 Entering Passive Mode (192,168,1,152,253,114)
---
and thats it. it just sits there in the shell. Doing nothing.


Using the graphical gftp program, i get:
230-User bruce has group access to: users video audio
230- dialout uucp
230-This server supports FXP transfers
230 OK. Current restricted directory is /
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
229 Extended Passive mode OK (|||44960|)
200-FXP transfer: from 64.79.xx.xx to 172.16.1.106
200 PORT command successful
---

There's that Dam "Passive" blurb agin!
So what gives?? i can FTP in from a windows box, but not from a Linux box. Im using the same user account (bruce) from both machines, and it does accept the password on both machines.
Has anyone had this problem?

Any help would gretaly be appreciated because i do NOT want to have to use windoze...

Matir 03-15-2005 10:49 AM

Most likely this a firewalling issue. Disabling passive mode would probably resolve this issue.

bonito 03-15-2005 10:23 PM

huh? where?
 
Hello,
Firewall issue?

Well, my server is behind a Linksys router.

But why does it still work from a Windows client?

But i digress.

any idea where i would disable this Passive mode?

^_^

Matir 03-16-2005 10:20 AM

It depends on what client you are using. command-line ftp? I believe just type "active".

bonito 03-16-2005 07:00 PM

active?
 
Thank You for your insight.

i cant connect through the commandline client nor the GUI gftp.

But where would i type "active"?

from the shell, i type:

ftp
open 68.69.70.71 (or whatvere the real ip address is of the server)
then i enter a username,
and then the password,

and then it says im connected. but when i try to do a simple command like "ls -al", i get:

257 "/" is your current location
PASV
227 Entering Passive Mode (192,168,1,152,253,114)


and thats it = [

Any help would Greatly be appreciated.

Matir 03-16-2005 09:45 PM

Actually, after open and authentication, under command line ftp, you should just use "passive" to toggle passive on/off.


All times are GMT -5. The time now is 07:49 PM.