LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Can't "Safely Remove" usb stick: KDE, SUSE 10.0 (http://www.linuxquestions.org/questions/suse-novell-60/can%27t-safely-remove-usb-stick-kde-suse-10-0-a-374623/)

m29389 10-19-2005 07:12 AM

Can't "Safely Remove" usb stick: KDE, SUSE 10.0
 
Hi

I am running SUSE 10.0 OSS.
When I insert my usb stick it is automatically mounted and an icon appears in "My Computer". However when I right click on that icon and select "Safely Remove" I get this error:

umount: /media/usbdisk is not in the fstab (and you are not root)
Please check that the disk is entered correctly.

Obviously I can umount this device from the command line (as root) but I want to do it the easy way and without logging in as root.

I have tried (for the hell of it) to add my user to some groups like disk and hald but this makes no difference. Maybe this problem is something to do with the configuration of hal but I wouldn't know where to start with this.

If I add this line to /etc/fstab (taken from /etc/mtab when the device is mounted):
/dev/sdb1 /media/usbdisk subfs rw,nosuid,nodev,sync,fs=floppyfss,procuid,utf8=true 0 0
The error changes to:

umount: only root can unmount /dev/sdb1 from /media/usbdisk
Please check that the disk is entered correctly.

I don't really want to add anything to fstab or use pmount or anything, I would like it to work as it seems how it should.

Any ideas how I can get the "Safely Remove" feature to work?

Thanks

fragos 10-19-2005 06:31 PM

I get the same message with 10.0 trying safely remove. To be honest I have always just removed it manually when the USB memory stick light wasn't on -- never had trouble. I have however noticed that the stick auto mounts properly and all works well until I close the automatic konqueror window and later try to open a new one from within my computer or tried to unison to sync the stick. Its almost as if the system knows the stick is there but thinks its empty. Extracting the stick and re-inserting auto mounts and works correctly. This never happened with 9.1, 9.2 or 9.3. Any ideas?

BufferOverflow 10-23-2005 02:02 PM

Re: Can't "Safely Remove" usb stick: KDE, SUSE 10.0
 
Quote:

Originally posted by m29389
Hi

If I add this line to /etc/fstab (taken from /etc/mtab when the device is mounted):
/dev/sdb1 /media/usbdisk subfs rw,nosuid,nodev,sync,fs=floppyfss,procuid,utf8=true 0 0
The error changes to:

umount: only root can unmount /dev/sdb1 from /media/usbdisk
Please check that the disk is entered correctly.

I don't really want to add anything to fstab or use pmount or anything, I would like it to work as it seems how it should.

Any ideas how I can get the "Safely Remove" feature to work?

Thanks

Hi there

I had the same problem.

You just have to add the "users" group in your line in /etc/fstab so your entry looks like this:

dev/sdb1 /media/usbdisk subfs users,rw,nosuid,nodev,sync,fs=floppyfss,procuid,utf8=true 0 0
............................................^
............................................|
............................................|

Now the "Safely Remove" should work.

bye

m29389 10-24-2005 11:15 AM

Thank you, that seems to have done the trick!

fragos 10-24-2005 02:23 PM

In my SuSE 10.0 retail install, my usbdisk problem is that although the disk is recognized, a konqueror window comes up and access works, the system will later know the disk is there but recognize the content. I normally close the automatic konqueror window after initial use. At the end of my computer use I always run unision to sync with the usbdisk. Unision also can't see some of the files -- it says permissions is the issue. If I remove the usbdrive and reinsert, unision works fine. I can work with it but its very annoying. It appears that SuSE has made major changes in recognizing usb devices but I don't know if that relates to the problem. My /etc/fstab follows:

/dev/hda3 / reiserfs acl,user_xattr 1 1
/dev/hda1 /boot ext2 acl,user_xattr 1 2
/dev/hda2 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrecorder /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0
/dev/dvd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

Happeren 11-14-2005 05:39 AM

Does anyone know of a way to get the "safely remove" option working using the GUI? I'm not very comfortable with editing stuff manually, unless I have en list of what to do like 1. Do this - 2. Do that! etc.

Anyway, thanks to anyone who helps :-)

mr_demilord 11-14-2005 01:51 PM

Quote:

Originally posted by Happeren
Does anyone know of a way to get the "safely remove" option working using the GUI? I'm not very comfortable with editing stuff manually, unless I have en list of what to do like 1. Do this - 2. Do that! etc.

Anyway, thanks to anyone who helps :-)

As far as I know not, but you can fire up konqueror with root priveledges click the suse button > system > File manager > File manager super user > go to /etc/ and open fstab with a text editor :)

pdeman2 11-15-2005 02:41 PM

My fstab file is just like fragos', it doesn't have /dev/sdb1, or anything like that.

Mrpeepers310 11-15-2005 11:35 PM

Aye and the same goes for my fstab, its very dynamic, there is no specifics in there

/dev/hda2 / reiserfs acl,user_xattr 1 1
/dev/hda1 swap swap defaults 0 0
proc /proc proc users,defaults 0 0
sysfs /sys sysfs users,noauto 0 0
usbfs /proc/bus/usb usbfs users,noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/dvdrecorder /media/ subfs users,noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
none /subdomain subdomainfs noauto 0 0


sry if it looks bad it didnt line up correctly so i had to do it by hand!
but ne wayz u see what i mean, very dynamic, the icons do not work on the desktop but in my storage media and everywhere else they do! im thinking its just a file destination cause whenever i click on the desktop icon it gives me this message
"/media/usbdisk is a folder, but a file was expected."

i would like to see where ithe command to look for a file is comming from cause its not in my hotplug conf. or suseplugger.conf or even my file associations! its nuts!!! again every other device icon besides the ones on my desktop work!


All times are GMT -5. The time now is 03:57 AM.