LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 05-28-2008, 09:04 AM   #1
chiaretta
LQ Newbie
 
Registered: Oct 2006
Posts: 2

Rep: Reputation: 0
Can't load dav_svn:Suse10.3 and Apache2


Hi all,
I'm trying to configure Apache2 on suse Linux 10.3 to allow remote access to my svn repository:

같같같같같같같같같같같같같같같
Packages installed (via Yast):

apache2
apache2-prefork
apache2-utils
subversion-server

같같같같같같같같같같같같같같같

***/etc/apache2/default-server.conf contains

'Include /etc/apache2/conf.d/*.conf'

***/etc/apache2/conf.d/subversion.conf contains

<Location /svn>
DAV svn
SVNParentPath /srv/svn/repos/
AuthType Basic
AuthName "subversion repository"
AuthUserFile /etc/apache2/passwd
<LimitExcept GET PROPFIND OPTIONS REPORT>
Require valid-user
</LimitExcept>
</Location>

If I try the url :
myhost(static)ip/svn/myreponame
I get 404 error....
(BTW the same code in /etc/apache2/httpd.local.conf doesn't work as well)

같같같같같같같같같같
Then I try to add dav_svn in APACHE_MODULES in file

/etc/sysconfig/apache2

and restarting the server I get the error message

...# service apache2 start
Starting httpd2 (prefork) httpd2-prefork: Syntax error on line 134 of /etc/apache2/httpd.conf: Syntax error on line 18 of /etc/apache2/sysconfig.d/loadmodule.conf: Cannot load /usr/lib/apache2/mod_dav_svn.so into server: /usr/lib/apache2/mod_dav_svn.so: undefined symbol: dav_register_provider


같같같같같같같같같같같같같
any guess?
Thanks for your help in advance and sorry for too many details, it's my first post....


Chiara
 
  


Reply

Tags
apache2conf, suse10


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache2 suse10.3 redirect to home directory as / is full master Linux - Server 2 05-28-2008 02:31 AM
Trying to load SuSe10.3 with system commander 10 tperri Linux - Newbie 1 04-14-2008 02:35 PM
Apache2 installation with Yast on Suse10.0 CGI problems DLHOMME Suse/Novell 0 05-20-2006 09:20 AM
Apache2 + php5 won't load mustangfanatic Slackware 9 04-19-2006 12:45 PM
help on suse10 64bit apache2 barrythai Mandriva 1 09-05-2005 02:57 PM


All times are GMT -5. The time now is 10:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration