LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 08-27-2007, 02:49 PM   #1
AlexHeap
LQ Newbie
 
Registered: Aug 2007
Posts: 6

Rep: Reputation: 0
Unhappy Can't get NVIDIA X server to work properly


Hi to everyone,

I'm having problems with SUSE 10.2. I've installed it, done all the online updates, I've even installed the NVIDIA driver for my card but it won't let me open the NVIDIA X Server settings application. It did before but since I updated it won't work. I just get the following message: "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server. "

I've checked my /etc/X11/xorg.conf file and it says "nvidia" for the driver and not nv. I did reinstall my nvidia driver again after I'd upgraded the kernel but I'm still having this problem with this message everytime I try and open NVIDIA X Server settings and also this is causing me a problem as I'm trying to run the game Doom3 that I just installed, it's not allowing me to use the NVIDIA driver for some reason. This is also strange because everytime I restart X the NVIDIA logo screen comes up?

Any help would be most appreciated.

AlexHeap
 
Old 08-27-2007, 02:52 PM   #2
AlexHeap
LQ Newbie
 
Registered: Aug 2007
Posts: 6

Original Poster
Rep: Reputation: 0
Also if this will help, I've posted a copy of my xorg.conf file to try and help diagnose the problem:

Section "ServerLayout"
Identifier "Layout[all]"
Screen "Screen[0]" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "gb"
Option "XkbModel" "pc105"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "9"
Option "Device" "/dev/input/mice"
Option "Name" "ImExPS/2 Generic Explorer Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
EndSection

Section "Monitor"
Identifier "Monitor[0]"
VendorName "DELL"
ModelName "M992"
UseModes "Modes[0]"
DisplaySize 352 264
HorizSync 30.0 - 96.0
VertRefresh 50.0 - 160.0
Option "CalcAlgorithm" "XServerPool"
Option "DPMS"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "nvidia"
VendorName "NVIDIA"
BoardName "GeForce FX 5950 Ultra"
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
EndSection
 
Old 08-27-2007, 04:53 PM   #3
The_JinJ
Member
 
Registered: Apr 2004
Location: Scotland
Distribution: Suse, OpenWRT
Posts: 299

Rep: Reputation: 30
I get the same but the drivers are working 100%
Can you enable Desktop Effects?
 
Old 08-27-2007, 06:06 PM   #4
AlexHeap
LQ Newbie
 
Registered: Aug 2007
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by The_JinJ View Post
I get the same but the drivers are working 100%
Can you enable Desktop Effects?
The desktop effects seem to be working fine, I can make the windows wobble and make the screen's desktop move around like a cube by pressing Ctrl and Alt and moving the mouse with the button, just can't seem to access the NVIDIA X Server settings anymore or get my Doom 3 game working????
 
Old 08-28-2007, 02:44 AM   #5
The_JinJ
Member
 
Registered: Apr 2004
Location: Scotland
Distribution: Suse, OpenWRT
Posts: 299

Rep: Reputation: 30
You don't need those settings afaik
If your using XGL then the nvcontrol extension that nvidia-settings talks to the driver with not supported because it's not Xorg.
Does your game error, just not run etc?
 
Old 08-28-2007, 04:18 AM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Change the XGL settings with /opt/gnome/bin/gnome-xgl-settings. It is supplied in the compiz-gnome package.
 
Old 08-28-2007, 02:30 PM   #7
AlexHeap
LQ Newbie
 
Registered: Aug 2007
Posts: 6

Original Poster
Rep: Reputation: 0
Thumbs up

Quote:
Originally Posted by jschiwal View Post
Change the XGL settings with /opt/gnome/bin/gnome-xgl-settings. It is supplied in the compiz-gnome package.
Thank you, I realised what was going on, something to do with the fact that my graphics card doesn't support the XGL desktop effects even though they do work, I remember when I enabled it before it said that the card I'm using wasn't in the list, I disabled it and now my NVIDIA X Server settings are working again. Yippee! Thanks a bunch to the both of you, I should be ok now, hope that this problem I've had might help somebody else in the future like it did for me!

Take care, once again many many thanks for the help! :-)

AlexHeap
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia chipset not detected properly The_paladin Linux - Hardware 2 02-20-2006 02:24 AM
pci-e support: nvidia 6600gt not properly recognized? nvtv does not work... spad Linux - Hardware 1 09-26-2005 07:11 AM
NVIDIA does not work properly in 10.1 Cornholio Slackware 7 03-28-2005 03:00 PM
mail server dosnt work properly AZIMBD03 Linux - Networking 4 04-11-2004 12:28 PM
need X server and DISPLAY to work properly -- dealing with Kazaa installed with wine sejem Linux - Software 2 03-27-2004 04:30 AM


All times are GMT -5. The time now is 06:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration