LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 10-11-2006, 06:22 PM   #1
kersten78
Member
 
Registered: Nov 2003
Location: Minneapolis, MN
Distribution: Slackware, Debian, Gentoo, openSuSE
Posts: 357

Rep: Reputation: 30
Can't figure out how to change SuSE 10.1's horrid default cursor theme


I've been totally impressed with SuSE 10.1 so far... except for the default cursor theme. The grey/silver poofy looking pointer is horrible--it's hard to see. Not to mention the "hand" cursor... the finger is absurdly long--so long that I often find myself overshooting links in my browser. I can't even begin to speak of the stupid clock cursor...egh. What's wrong with a basic white cursor set??

Here's the problem: I can't figure out how to change it system-wide. Sure, I've switched to the Industrial cursors in Gnome and KDE, but that doesn't do a bit of good when I run one of my favorite lightweight WM's such as fluxbox or fvwm. And the cursors aren't consistent in Gnome and KDE even after changing them. Most apps are fine, but when I'm using Opera, for example, as soon as I mouse over the window it's back to the horrific SuSE defaults. And no matter what I do, the astoundingly stupid cursors are back every time I boot into (or log out and return to) gdm or kdm.

I've been poring over forums looking for an answer, and I tried some suggestions on some Arch Linux forums... alas, in vain. I've added
Code:
Xcursor*theme: Industrial
to my ~/.Xdefaults and to the global Xresources file. No luck. I've tried almost every different incarnation I could think of. I've read that it should be set by "Xcursor.theme:" rather than "Xcursor*theme:", but neither work. I've also tried using "[Industrial]" rather than plain "Industrial" as was suggested on an OpenBox howto. Nothing.

Another thread suggested that the /usr/share/icons/default/index.theme file should contain
Code:
[Icon Theme]
Inherits=desired_theme
but that doesn't seem to help.

Does anyone else share my hatred of the default SuSE cursors? And more importantly, has anyone figured out how to change them?
 
Old 10-12-2006, 02:57 AM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,739

Rep: Reputation: 298Reputation: 298Reputation: 298
Control center - Peripherals - Mouse - Cursor theme.
 
Old 10-12-2006, 07:34 AM   #3
kersten78
Member
 
Registered: Nov 2003
Location: Minneapolis, MN
Distribution: Slackware, Debian, Gentoo, openSuSE
Posts: 357

Original Poster
Rep: Reputation: 30
Like I said, I've changed the cursors in KDE and Gnome. What I can't seem to do is swich the cursors system-wide. Every time I log out to kdm or gdm, the cursors go back to default. The gdm/kdm situation isn't a huge deal--what really bothers me is that I can't switch them when using Fluxbox, WindowMaker, etc. All the lightweight WM's use the default cursors. There must be a way to control this... thanks anyway, bigrigdriver.
 
Old 10-12-2006, 02:00 PM   #4
kersten78
Member
 
Registered: Nov 2003
Location: Minneapolis, MN
Distribution: Slackware, Debian, Gentoo, openSuSE
Posts: 357

Original Poster
Rep: Reputation: 30
Well, I solved the problem, and it was much easier than I had imagined. The default mouse theme is defined in /etc/sysconfig/windowmanager with the variable X_MOUSE_CURSOR. Finally, no more fluffy default cursors!

Last edited by kersten78; 10-12-2006 at 08:36 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Change default position of the X cursor or get rid of it!!! thebover Linux - Software 2 04-30-2009 12:47 AM
kde / gtk cursor-theme / theme issue - gentoo imperfect Linux - Newbie 1 01-08-2006 05:09 PM
Could not open default cursor font 'cursor' at startx with slackware 10.2 bgryderclock Slackware 3 01-02-2006 10:36 PM
how disable anti-aliasing fonts completely and how to change the default system theme user222 Linux - General 2 10-16-2004 02:03 AM
Change default windowmaker theme. irshad Linux - Software 0 10-12-2004 10:00 AM


All times are GMT -5. The time now is 07:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration