LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 12-09-2006, 01:29 PM   #1
iroybk
LQ Newbie
 
Registered: Nov 2006
Location: AZ
Distribution: SuSE 10.1
Posts: 14

Rep: Reputation: 0
Can't enable 3d support with Nvidia mx440 on SUSE 10.1


in my computer it says
Display Info
Vendor: nVidia Corporation
Model: GeForce4 MX 440 with AGP8X
Driver: nv (No 3D Support)

I have added the nvidia driver web site ftp://download.nvidia.com/novell to the installation sources in yast but when I updated the driver this way then suse would not load KDE I just got stuck on a command line of some sort so I did a upgrade install and now I have my desktop back but no 3d support. I would like some help as I am quite new to suse thanks.
 
Old 12-09-2006, 02:01 PM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
When I ran Suse 10.1, the official drivers from nvidia.com worked fine (not the ones from the link you posted). Download the driver from here and follow the instructions on the download page to install them. After that edit /etc/X11/xorg.conf and change the driver from "nv" to "nvidia".
 
Old 12-09-2006, 02:02 PM   #3
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
You need to install the legacy nvidia driver. Follow the directions on their site to install. Once this is installed, you'll need to modify /etc/X11/xorg.conf and change the Driver "nv" to Driver "nvidia".

Then everything should load.
 
Old 12-09-2006, 02:04 PM   #4
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,739

Rep: Reputation: 298Reputation: 298Reputation: 298
It's a bit more complicated that just using YaST to upgrade the driver. Here are instructions from the nvidia website which are specific to SuSE. Scroll down to the section relating to 10.1 to see what packages have to be installed: kernel sources among others.

http://www.suse.de/~sndirsch/nvidia-...r-HOWTO.html#3
 
Old 12-09-2006, 02:14 PM   #5
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Quote:
Originally Posted by GrueMaster
You need to install the legacy nvidia driver. Follow the directions on their site to install. Once this is installed, you'll need to modify /etc/X11/xorg.conf and change the Driver "nv" to Driver "nvidia".

Then everything should load.
For a GeForce MX4xxx card, you do not need the legacy drivers. I have a card based on that chip and the normal drivers work fine.
 
Old 12-09-2006, 02:16 PM   #6
iroybk
LQ Newbie
 
Registered: Nov 2006
Location: AZ
Distribution: SuSE 10.1
Posts: 14

Original Poster
Rep: Reputation: 0
first thanks everyone for the replys
ok I have gone to nvidia's website and followed the instructions. Yast is now downloading x11 and nvidia-gfx-kmp-2.6.16.21-8.1 smp but the question I have is when I ran uname -r to find the kernel flavor or what ever than I got 2.6.16.21-0.25-smp and there was not a .25 in the options to download am I doing the right one??
 
Old 12-09-2006, 02:16 PM   #7
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
Quote:
For a GeForce MX4xxx card, you do not need the legacy drivers. I have a card based on that chip and the normal drivers work fine.
Yes, but the new drivers add nothing for legacy support. So for space and compile time, just use the legacy driver.

Last edited by GrueMaster; 12-09-2006 at 02:17 PM.
 
Old 12-09-2006, 02:48 PM   #8
iroybk
LQ Newbie
 
Registered: Nov 2006
Location: AZ
Distribution: SuSE 10.1
Posts: 14

Original Poster
Rep: Reputation: 0
ok I got everything downloaded and I went to /etc/X11/xorg.cfg and looked where it says driber and it was already "nvidia" but when I go into my computer now it says

Display Info
Vendor: nVidia Corporation
Model: GeForce4 MX 440 with AGP8X
Driver: unknown

is that ok
 
Old 12-09-2006, 02:52 PM   #9
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Quote:
Originally Posted by iroybk
ok I got everything downloaded and I went to /etc/X11/xorg.cfg and looked where it says driber and it was already "nvidia" but when I go into my computer now it says

Display Info
Vendor: nVidia Corporation
Model: GeForce4 MX 440 with AGP8X
Driver: unknown

is that ok
Change "unknown" to "nvidia". Did the change happen when you rebooted?
 
Old 12-09-2006, 02:55 PM   #10
iroybk
LQ Newbie
 
Registered: Nov 2006
Location: AZ
Distribution: SuSE 10.1
Posts: 14

Original Poster
Rep: Reputation: 0
where do I make the change? (change from unknown to nvidia)
no I have not rebooted I am scared to last time I tried this I lost my desktop
 
Old 12-09-2006, 03:00 PM   #11
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Quote:
Originally Posted by iroybk
where do I make the change? (change from unknown to nvidia)
no I have not rebooted I am scared to last time I tried this I lost my desktop
I realise I may have misread your post. If /etc/X11/xorg.conf says the driver is nvidia, then thats fine.
 
Old 12-09-2006, 03:00 PM   #12
iroybk
LQ Newbie
 
Registered: Nov 2006
Location: AZ
Distribution: SuSE 10.1
Posts: 14

Original Poster
Rep: Reputation: 0
here is a copy of my /etc/X11/xorg.cfg file

# /.../
# SaX generated X11 config file
# Created on: 2006-11-18T14:24:49-0700.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "7"
Option "Device" "/dev/input/mice"
Option "Name" "ImExPS/2 Logitech Explorer Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
DisplaySize 320 250
HorizSync 30-88
Identifier "Monitor[0]"
ModelName "PF41700"
Option "DPMS"
VendorName "GTW"
VertRefresh 43-76
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 136.57 1280 1368 1504 1728 1024 1025 1028 1068
Modeline "1280x1024" 134.72 1280 1368 1504 1728 1024 1025 1028 1068
Modeline "1280x1024" 132.75 1280 1368 1504 1728 1024 1025 1028 1067
Modeline "1024x768" 80.71 1024 1080 1192 1360 768 769 772 802
Modeline "1024x768" 79.52 1024 1080 1192 1360 768 769 772 801
Modeline "1024x768" 78.43 1024 1080 1192 1360 768 769 772 801
Modeline "800x600" 48.18 800 840 920 1040 600 601 604 626
Modeline "800x600" 47.53 800 840 920 1040 600 601 604 626
Modeline "800x600" 46.87 800 840 920 1040 600 601 604 626
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "GeForce4 MX 440 with AGP8X"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
VendorName "NVidia"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection


Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection
 
Old 12-09-2006, 03:04 PM   #13
iroybk
LQ Newbie
 
Registered: Nov 2006
Location: AZ
Distribution: SuSE 10.1
Posts: 14

Original Poster
Rep: Reputation: 0
when I go into x-moto it says
Warning No 3D graphics card is available or 3D support is not configured yet. However, the application uses or requires 3D hardware support.

should I reboot and see if it works or is there somethink else I need to do?
 
Old 12-09-2006, 03:13 PM   #14
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Quote:
Originally Posted by iroybk
when I go into x-moto it says
Warning No 3D graphics card is available or 3D support is not configured yet. However, the application uses or requires 3D hardware support.

should I reboot and see if it works or is there somethink else I need to do?
Try running "sax2" and then selecting to enable 3d. Rebooting after installing a kernel module isn't really necessary but sometimes it helps solve some problems related to that module.
 
Old 12-09-2006, 03:17 PM   #15
iroybk
LQ Newbie
 
Registered: Nov 2006
Location: AZ
Distribution: SuSE 10.1
Posts: 14

Original Poster
Rep: Reputation: 0
Thank you reddazz
I went into sax2 and the check box for Activate 3D Acceleration was already has a x in it. but it is not working
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do i enable 3d support on susE Linux 9.0? DJ_6sYx6 Linux - Hardware 8 12-19-2006 02:10 AM
How do I enable 64GB RAM support on Suse 10.1 64bit ajitup Linux - Kernel 5 11-23-2006 10:18 PM
How to enable complex script support in Firefox on Suse 9.3/10 Chaitany Linux - Software 2 11-18-2006 01:04 AM
help editing xf86config for nvidia geforce mx440 after installing nvidia driver linguist Linux - Newbie 11 06-13-2006 06:31 AM
How do I enable Fast Writes and SBA support for my NVIDIA card? Crushing Belial Debian 3 12-28-2005 11:41 PM


All times are GMT -5. The time now is 05:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration