LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 12-05-2006, 06:53 PM   #1
techmom
LQ Newbie
 
Registered: Dec 2006
Posts: 4

Rep: Reputation: 0
Question can't connect to swat


I'm using SUSE 9.3 and trying in vain to use swat. My server is running http services, and my /etc/services file lists swat as port 901 (but mentions there is a conflict). When I go to myIP:901 I get a 404 Object not found error. I tried changing to port 905, but no luck. As far as I can tell, all the support files are in place, but I'm really not sure about that. What else can I check for? What am I missing?
 
Old 12-05-2006, 08:23 PM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,816

Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
Welcome to LinuxQuestions.
/etc/services is nothing more then an ASCII text file that allows programs to convert names to port numbers. swat is a seperate server from http and so it does not matter if it (httpd) is running or not. swat typically runs from xinetd which in simple terms is a service that supervises other network services. Instead of services (daemons in linux speak) starting at boot and remaining idle taking up resources they are started when xinetd detects a request. swat must be enabled in the xinetd swat configuration file and of course xinetd must be running. In addition the default is to only allow access from the server itself i.e. no remote login.

http://samba.org/samba/docs/man/Samb...tion/SWAT.html

Last edited by michaelk; 12-05-2006 at 08:27 PM.
 
Old 12-06-2006, 07:09 AM   #3
techmom
LQ Newbie
 
Registered: Dec 2006
Posts: 4

Original Poster
Rep: Reputation: 0
hmmm...

I had an aha! moment when you said I could only connect from the server. I added my pc's IP to the only_from variable in the xinetd conf file and sent a HUP to xinetd, but to no avail. I also added a disable=no line which wasn't there before. I saw user=root but assumed it would ask me for a login when I connected. Is this the problem, or should I look elsewhere?
 
  


Reply

Tags
swat


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SWAT - Could not connect to port 901 brucerowe Linux - Networking 17 09-11-2008 11:45 AM
SWAT cannot connect verbose Linux - Networking 6 08-09-2004 10:23 PM
Can not connect to SWAT anymore lovswr Linux - Networking 0 11-08-2003 11:16 AM
Problem to connect to SWAT from remote scram Linux - Networking 2 07-18-2003 08:04 AM
samba's SWAT...won't connect Robert0380 Linux - Software 7 07-16-2003 04:00 AM


All times are GMT -5. The time now is 12:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration