LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 07-10-2006, 04:25 AM   #1
signmeuptoo
Member
 
Registered: Jul 2005
Location: Ithaca, NY
Posts: 34

Rep: Reputation: 15
bootloader repair/replace problems


Let me start by saying I have always had this same problem with every version of SuSE I have installed, sinc 9.1:

I had to reinstall WinXP, and now my GRUB bootloader is gone, which is to be expected, however:

When I try to repair it, using either the auto OR the custom repair options off of the install disk, I run into fstab entries problems. Right now I am trying to recover the bootloader for SuSE 10.1 x64, WinXP, & WinVista.

I get these issues:

ignore (or remove, neither works) debugfs /sys/kernal/debug no auto

and

ignore /(or remove, neither works) /dev/sda2 /data2 vfat yadda yadda (it's for my iPod)

When it does:

"Check Package Database"

It tells me that all of the hard drives cannot be mounted.

Can someone tell me how I can repair, or rebuild, or build a new bootloader WITHOUT having to do a fresh install?

Someone told me to "chroot" into into SuSE, but when I do a man chroot command, it doesn't say anything about how to use it really, so I have no idea how to do it.

PLEASE, can someone help me on this? Thanks.
 
Old 07-10-2006, 01:10 PM   #2
killy9999
Member
 
Registered: Feb 2005
Location: Poland
Distribution: openSUSE 11.3/11.4 x64
Posts: 114

Rep: Reputation: 15
Try this:

Boot from suse dvd and choose "rescue system". I assume you know which partition is your root partition. Login as root and do this:

cd /mnt/
mkdir suse
mount /dev/hda2 suse (/dev/hda2 should be your root partition)
mount -t proc /proc suse/proc
chroot suse
grub-install /dev/hda (/dev/hda should be the place where grub should be installed)
exit
reboot
 
Old 07-10-2006, 02:51 PM   #3
signmeuptoo
Member
 
Registered: Jul 2005
Location: Ithaca, NY
Posts: 34

Original Poster
Rep: Reputation: 15
when I type in mkdir suse it says connect create directory suse, read only...
 
Old 07-23-2006, 10:50 PM   #4
John Zimmerman
Newbie
 
Registered: Jul 2006
Posts: 0

Rep: Reputation: 0
Solution

I just had this same problem with SuSE 10.1.

Here is what I did to get it fixed (directions as stated above do not work, but are on the right track).

1) Boot from your SuSE installation disk and choose 'recover system'

2) Login as 'root'

3) Figure out which partitions your linux installation is on (I only had one which was hda6) My configuration is as follows on my laptop hda1=winxp, hda2=extended, hda5=fat32, hda6=/. Note that I only have 1 linux partition.

4) Since by default you cannot create new directories within the recover environment you are going to mount you linux installation to /mnt. Then we will need to bind some critical system directories before we chroot.

5) Commands are as follows....
mount /dev/hda6 /mnt
mount --bind /sys /mnt/sys
mount --bind /proc /mnt/proc
mount --bind /dev /mnt/dev
chroot /mnt

6) Now you should be chroot'd to your linux installation and you are ready to install grub however you need to. My grub-install command went like this....

grub-install --no-floppy --force-lba --recheck /dev/hda6


I installed to my partition instead of the bootsector because my Toshiba BIOS causes GRUB to hang before it loads its splash screen. So my work around is to strip the first 512 bytes off of /dev/hda6 after I install grub to it and save it to a file. That file I put in my C:\ and call it from my Boot.ini

So my boot chain looks like Poweron->ToshibaBIOS->NTLOADER/BOOT.INI on hda ->GRUB

So the NTLOADER actually has to kick over to GRUB.

Here is a link with better instructions for that part http://www.highlandsun.com/hyc/linuxboot.html <--I have not made 3 posts yet so it doesn't like me putting URL's in :-(

And yes, with Ubuntu and RedHat I never had to do more thant boot to recovery system and chroot to /mnt/sysimage because it was already mounted for me. It was a bit of a surpirse that SuSE hadn't already done it.
 
Old 02-15-2007, 08:14 PM   #5
SKelem
Member
 
Registered: Jun 2005
Location: Silicon Valley, California
Distribution: Fedora 13
Posts: 36

Rep: Reputation: 15
Didn't work for me

My root is /dev/hda6, and /boot is /dev/hda8

I tried the above steps, and got:

Code:
Rescue:/ # grub-install /dev/hda
/dev/hda: Not found or not a block device.
Rescue:/ # grub-install --no-floppy --force-lba --recheck /dev/hda8
Probing devices to guess BIOS drives. This may take a long time.
/dev/hda8: Not found or not a block device.

Rescue:/ # cat /proc/partitions
major minor  #blocks  name
   7     0      28920 loop0
   7     1      28920 loop1
   3     0  156290904 hda
   3     1   41985846 hda1
   3     2          1 hda2
   3     3   22073310 hda3
   3     5      24066 hda5
   3     6   87032106 hda6
   3     7     658633 hda7
   3     8    3020188 hda8
   8     0  390711384 sda
...

Any idea of what to try next?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Corrupted bootloader - can't repair it. Adrian Baker Linux - General 8 04-26-2006 02:00 AM
Bootloader Problems pedoublenizzle Linux - General 3 01-02-2005 04:28 PM
bootloader problems suvrat23 Linux - Newbie 1 07-21-2004 07:26 AM
Find and repair disk and file problems for red hat linux 8 Ham Linux - Newbie 1 05-24-2004 02:13 AM
problem in perl replace command with slash (/) in search/replace string ramesh_ps1 Red Hat 4 09-10-2003 02:04 AM


All times are GMT -5. The time now is 12:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration