LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 11-21-2006, 07:58 PM   #1
vin0914
LQ Newbie
 
Registered: Nov 2006
Posts: 3

Rep: Reputation: 0
Boot loader (GNU grub 0.97) problems


Hello,

I have Suse 10.1 and Windows XP which I dual boot using the GNU grub. I have two hard drives with a raid set up. So the first hard drive has a windows partition, a linux parition and a linux swap partition and the other harddrive has the same for the raid.

Anyway the other day I restarted my computer and instead of the usual GUI that comes up for the boot loader I got this message:
"GNU grub version 0.97 (628k lower/523200k upper memory)

[Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions ... etc ]

Anyway, this confused me a lot as it happened for no apparent reason and I eventually booted linux again via the installation disc and after searching the internet a bit decided I'd try uninstalling the grub and then reinstalling it using the the yast install package manager. Having done this I realised it was a foolish mistake and am now in a situation even worse than before.

After restarting my PC instead got, "Grub loading... Error 16" which from what I can gather means it thinks I don't have the grub installed.

Anyway I then realised I could have used the yast repair application on the install disc so I tried this next to see if I could get it to install the grub properly. However for reasons unknown this yast repair application always seems to think I do not have linux installed, even though I evidently do. And when I try yo install the boot loader it syas, "No valid root partition found. Go back and select scan options. Afterwards, restart scanning."

When I go a general scan for problems and it gets to partition /dev/sda2 (the linux partition) it says, "No valid Linux partitions found".

This would worry me more except linux is there because I'm on it, though annoying now because I might be able to get the boot loader working if the yast repair thing worked.

So has anyone got any ideas? I currently can't access windows and have to use the installation disk to get onto linux.

I thought I could make a floppy disc with the grub on, so I can just use the floppy disc to load the boot loader (though hopefully as a temporary measure) but I can't seem to find a comprehensive guide on how to do this.

Anyway, any help with any aspect of my problem would be very helpful. I'm a complete noob, so excuse any misused lingo above and clear and consise, step by step advice would be very much appreciated.

My PC doesn't seem to like me recently and I seem to be spending more time trying to get it to work than using it so I'm quite peeved off at the moment hence I thought I'd post here as I'm hoping this'll provide a more hassle free was of finding a solution than googling all day.

Thanks in advance,

Vinay
 
Old 11-23-2006, 09:08 AM   #2
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
This would worry me more except linux is there because I'm on it, though annoying now because I might be able to get the boot loader working if the yast repair thing worked.

I will probably get jumped on for this but if you can get into linux now, back up everything you want to save and do a new install
 
Old 11-29-2006, 02:58 AM   #3
vin0914
LQ Newbie
 
Registered: Nov 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Looks like I'm heading that way.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless Keyboard not working to select boot options (Grub boot loader) psrini_vasan Fedora 7 12-16-2009 06:45 PM
Grub Boot Loader Problems tylerjroach Linux - Newbie 7 01-03-2006 03:54 AM
deleted linux partition adn the boot loader was deleted also,now i have only gnu grub boris199 Linux - Laptop and Netbook 2 01-29-2005 05:53 PM
Grub boot loader menu shows two linux boot options pramos Linux - Newbie 3 09-13-2004 12:40 AM
How to add a boot record which used to startup windows under my Grub boot loader? yunxiang Linux - Newbie 6 02-01-2003 03:22 AM


All times are GMT -5. The time now is 06:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration