LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 06-15-2005, 05:14 PM   #1
zenith1107
LQ Newbie
 
Registered: Jun 2005
Posts: 3

Rep: Reputation: 0
ACPI problem


I just installed SuSE 9.3 on my laptop and it would freeze during kernel loading.

After one night's playing with kernel I found that once I deactivate ACPI by adding "acpi=off" in the boot loader kernel, I was able to get the GUI logon interface and boot normally. However, the wireless for some reason doesn't work anymore (and it can't be turned on either). And if I enable ACPI, it would freeze again at kde loading but the wireless is working (light is on). If anyone can let me know how to enable wireless with ACPI disabled or resolve the freezing problem it would be great. Any help would be greatly appreciated.

Last edited by zenith1107; 06-16-2005 at 07:06 AM.
 
Old 06-16-2005, 05:34 AM   #2
zenith1107
LQ Newbie
 
Registered: Jun 2005
Posts: 3

Original Poster
Rep: Reputation: 0
I just installed SuSE 9.3 on my laptop and it would freeze during kernel loading.

After one night's playing with kernel I found that once I deactivate ACPI by adding "acpi=off" in the boot loader kernel, I was able to get the GUI logon interface and boot normally. However, the wireless for some reason doesn't work anymore (and it can't be turned on either). And if I enable ACPI, it would freeze again at kde loading but the wireless is working (light is on). If anyone can let me know how to enable wireless with ACPI disabled or resolve the freezing problem it would be great. Any help would be greatly appreciated.

Last edited by zenith1107; 06-16-2005 at 07:07 AM.
 
Old 06-22-2005, 09:27 AM   #3
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Try not booting to command line then typing "startx". If there's a problem, you'll get the error messages there.

You'll need to change your default runlevel to 3. As root, edit your /etc/inittab to show id:3:initdefault: instead of id:4:initdefault:

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 12:52 PM
Black screen on boot Michael Davont Linux - Newbie 10 01-25-2005 04:35 PM
xstartup configured, Vnc still only loads grey screen on boot. DeTHZiT Linux - Software 8 09-05-2004 12:45 PM
Black Screen At Boot Up Ax787 Linux - Newbie 1 10-02-2003 01:23 PM
black and grey confusion blistfix LQ Suggestions & Feedback 1 09-02-2001 08:40 AM


All times are GMT -5. The time now is 07:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration