LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Bluetooth Dialup Connection (http://www.linuxquestions.org/questions/suse-novell-60/bluetooth-dialup-connection-364831/)

Fade-Dude 09-19-2005 07:38 AM

Bluetooth Dialup Connection
 
Ok, quick overview.

Me I am a long time MS user/developer. Linux has allways intreaged me. I played around with a couple of distro's over the years. I recently tried suse 9.3 and fell in love.

A problem that I have however....

I cant seem to get suse to recognize/install my cellphone as 'n modem workn through bluetooth. My nifty little bluetooth manager connects to my phone propperly and I can brows through OBEX.

Using kinternet I can create dialup connections, but I can only specify devices that are installed as modems (in Yast/hardware/Modems).

How do I install a default modem that points to my cellphone?

Thanks in advance for anyone that can help. Cheers!

Be.Gurmeet.Be 09-22-2005 12:20 PM

Hi, Fade - Dude, did you sort out your problem , if yes, then please say yes, if not then say no , so that i tell you in my next post how to make a dial up networking connection in SuSE linux 9.2 & 9.3 also. I am bedi-beparwah.

thanks

Be.Gurmeet.Be 09-22-2005 01:03 PM

Fade-Dude , Follow the Steps written below ONE BY ONE CAREFULLy........


1. Just plugin " Bluetooth Dongle into USB Port "

2. Turn your Cell Phone's Bluetooth on.

3. Open the file ' .etc.wvdial.conf ' in any Text Editor such as 'gedit' or 'kwrite' . and replace all the line with the following lines.

[Modem0]
Modem = /dev/rfcomm0
Baud = 57600
SetVolume = 0
Dial Command = ATDT
Init1 = ATZ
Init3 = ATM0
FlowControl = None
[Dialer GPRS]
Username = user
Password = user
Phone = ATD*99***3#
Stupid Mode = 1
Inherits = Modem0


4. now, open file /etc/ppp/options in text editor in the same way

and put # before all the lines starts with word lcp.

it should be 4 or 5 lines. Remember this


5. now , open terminal and run the following commands as the following order....

a.) [roo@localhost]#hcitool scan

This command will show the name of your call phone and one Six pairs digit address. COPY THIS ADDRESS.

b.) [roo@localhost]# sdptool search DUN

This commmand will show you that on which RFCOMM Channel you dial up networking is available in your cell phone.

c.) rfcomm bind 0 <address of cell phone you copied above> <rfcomm channel of dial up networking which is shown by b.) command>

6. After binding, just run ' kppp ' and make a dial up connection as we do in the case of ordinary modem.

just choose Modem Port as /dev/rfcomm0

and enter the phone no. exactly the same you entered in the /etc/wvdial.conf file.

NOTE : MY INTERNET SERVICE PROVIDER'S NO IS *99***1# and *99***3#. You replace this no with your ISP's on both places.

7. After creating a dial up connection in ' kppp ' just press connect button.

8. As you Press Connect Button, on your cell phone you will be asked to enter a particular digit which is for bonding between your computer system and cell phone.

Enter the same digits here which you have in ' Yast ' - > Hardware - > ' Bluetooth ' configuration. Check it

9. As you enter the digit , ' kppp ' pop up shows the following in exact order...................


a. ) Modem Ready

b.) Initializing Modem

c. ) Dialing *99***1#

d. ) Authenticalting....

e.) Network Established or some thing like that.


10. Last but not least...........PLEASE BACK UP OF /etc/wvdial.conf & /etc/ppp/options


Please if this works for you then please SAY THANKS ATLEASET.

I am waiting for a good news from your side .

Regards.

Fade-Dude 09-22-2005 02:12 PM

Shot Dude!!!!
*applause*

I will test this shortly and let you know!

ardian 09-29-2005 10:48 AM

i have tried all things above and it can't work :(
i mean Almost work.

the modem has detected but it can initialize (it stuck in here)
or stuck in dialing *99***1# if clear the extra string initialization.

where do i put extra initialization string like "AT+CGDCONT=1,"IP","satelindogprs.com" ?
and what must i fill in the Advanced modem configuration
in detail plz, or leave it blank?

i'm using SuSe 9.3
MSI Bluetooth dongle and Nokia Ngage
this stuff work well on Windows.


thanks for help

ardian 10-04-2005 09:22 AM

Doesn't work!
Anybody have alternative technique to run bluetooth gprs on SuSE

Be.Gurmeet.Be 10-04-2005 03:27 PM

No need to put extra string any where. Just make sure that all the value fields are filled with theie respective values in

kppp's > Configure > Modems > Modem > Modem Commands >............


, if not the write me down back.........

please explain your problem in more detail.

I am not AS good in english as you are. so please write simple english. I request you.

LET ME TELL YOU THAT, I HAVE BEEN USING GPRS ON MY SONY ERICSSON P - 800 , SINCE I HAD ' SUSE 9.2 ' . IN SUSE 9.3 IT BECAME SO EASY , YOU MUST BE MAKING A LITTLE MISTAKE SOMEWHERE , I GURANTEE YOU , THAT SOON YOU GET IT.

REGARDS..........


All times are GMT -5. The time now is 04:33 AM.