LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 12-11-2006, 10:51 AM   #1
parsek77
Member
 
Registered: Sep 2004
Location: NY
Distribution: SUSE 10.2
Posts: 35

Rep: Reputation: 15
Question Beryl with 10.2


With 10.2, beryl should work without Xgl because of the new X and the latest Nvidia drivers. I have upgraded to 10.2 and installed latest Nvidia drivers but couldn't get work beryl without Xgl. Is there anyone has success with beryl without Xgl? thanks
 
Old 12-11-2006, 11:05 AM   #2
onjoo
Member
 
Registered: Jan 2005
Location: Finland
Distribution: Suse 10, Suse-factory , RHEL4, SLES9, SLED10
Posts: 380

Rep: Reputation: 30
Have you followed this guide http://en.opensuse.org/Beryl or did you try to do it some other way?
 
Old 12-11-2006, 11:08 AM   #3
parsek77
Member
 
Registered: Sep 2004
Location: NY
Distribution: SUSE 10.2
Posts: 35

Original Poster
Rep: Reputation: 15
Yes, I followed that guide and it didn't work. I also looked at beryl project wiki but couldn't run it without Xgl. It is working but with Xgl.
 
Old 12-11-2006, 03:39 PM   #4
biosol
LQ Newbie
 
Registered: Apr 2006
Distribution: SuSE 10.0
Posts: 17

Rep: Reputation: 0
I have it working after following this thread. Beryl guilde

I didn't install XGL, just the NVIDIA driver and then searched for beryl in Yast and installed all 5 or 6 rpms for that.

Hope that helps.
 
Old 12-11-2006, 11:46 PM   #5
cueman
Member
 
Registered: Oct 2006
Location: Scottsdale, Arizona
Distribution: openSUSE 10.2
Posts: 199

Rep: Reputation: 30
Quote:
Originally Posted by biosol
I have it working after following this thread. Beryl guilde

I didn't install XGL, just the NVIDIA driver and then searched for beryl in Yast and installed all 5 or 6 rpms for that.

Hope that helps.
Well thats odd because the recommended way is to use beryl is WITH xgl, according to:

http://en.opensuse.org/Beryl

This is the way I set it up and it runs smooth as silk. I just had a few questions about it I posted a little while ago

Last edited by cueman; 12-11-2006 at 11:47 PM.
 
Old 12-11-2006, 11:56 PM   #6
onjoo
Member
 
Registered: Jan 2005
Location: Finland
Distribution: Suse 10, Suse-factory , RHEL4, SLES9, SLED10
Posts: 380

Rep: Reputation: 30
I dont want to start another beryl thread so I'll post a bit offtopic question

How can beryl be launched automatically in gnome?

Using SLED+ATI+newest buildservice beryl packages.

Everytime I log in, I have xgl running, but the window borders and minimize,maximize,close- buttons are missing. I have to start beryl-manager from terminal and Reload Window Decorator(emerald) to get things normal.

Can anybody help?

Last edited by onjoo; 12-12-2006 at 12:17 AM.
 
Old 12-12-2006, 12:02 AM   #7
parsek77
Member
 
Registered: Sep 2004
Location: NY
Distribution: SUSE 10.2
Posts: 35

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by biosol
I have it working after following this thread. Beryl guilde

I didn't install XGL, just the NVIDIA driver and then searched for beryl in Yast and installed all 5 or 6 rpms for that.

Hope that helps.
It helped, thanks. My problem was deactivating the KDE's composite manager. But after I upgraded beryl, I got the white screen problem. The solution for that is also given. This time beryl.sh script wasn't working. Because KDE was trying to open up my previous session. I changed KDE session startup (empty session) and it worked. The speed improvement is clearly visible over xgl.


Cueman,

You don't need xgl for beryl with the new X (7.2) and Nvidia drivers.
 
Old 12-12-2006, 11:47 AM   #8
cueman
Member
 
Registered: Oct 2006
Location: Scottsdale, Arizona
Distribution: openSUSE 10.2
Posts: 199

Rep: Reputation: 30
Quote:
Originally Posted by onjoo
I dont want to start another beryl thread so I'll post a bit offtopic question

How can beryl be launched automatically in gnome?

Using SLED+ATI+newest buildservice beryl packages.

Everytime I log in, I have xgl running, but the window borders and minimize,maximize,close- buttons are missing. I have to start beryl-manager from terminal and Reload Window Decorator(emerald) to get things normal.

Can anybody help?
Go down to the near bottom of this page, it has what you are looking for:

http://en.opensuse.org/Beryl
 
Old 12-12-2006, 12:00 PM   #9
cueman
Member
 
Registered: Oct 2006
Location: Scottsdale, Arizona
Distribution: openSUSE 10.2
Posts: 199

Rep: Reputation: 30
Quote:
Originally Posted by parsek77
It helped, thanks. My problem was deactivating the KDE's composite manager. But after I upgraded beryl, I got the white screen problem. The solution for that is also given. This time beryl.sh script wasn't working. Because KDE was trying to open up my previous session. I changed KDE session startup (empty session) and it worked. The speed improvement is clearly visible over xgl.


Cueman,

You don't need xgl for beryl with the new X (7.2) and Nvidia drivers.
You're right sorry, it was even right on the page I was going off of, just didn't read far enough down. I have a 256MB GeForce FX 5700, is that considered > GeForce 4? as the opensuse site says?

I don't keep up on the latest hardware like I used to. Tom's Hardware.com was practically my home page when I started this stuff
 
Old 12-12-2006, 01:32 PM   #10
parsek77
Member
 
Registered: Sep 2004
Location: NY
Distribution: SUSE 10.2
Posts: 35

Original Poster
Rep: Reputation: 15
Cueman,

GeForce FX > GeForce 4 or MX series. You are right. You can check from here if you want:http://www.nvidia.com/page/desktop.html
 
Old 12-12-2006, 02:12 PM   #11
onjoo
Member
 
Registered: Jan 2005
Location: Finland
Distribution: Suse 10, Suse-factory , RHEL4, SLES9, SLED10
Posts: 380

Rep: Reputation: 30
Quote:
Originally Posted by cueman
Go down to the near bottom of this page, it has what you are looking for:

http://en.opensuse.org/Beryl
No it hasn't. Thats for KDE. But I added beryl-manager to gnome session startup.

But it still doesn't draw the window borders without manual reload
 
Old 12-12-2006, 02:23 PM   #12
cueman
Member
 
Registered: Oct 2006
Location: Scottsdale, Arizona
Distribution: openSUSE 10.2
Posts: 199

Rep: Reputation: 30
Well what I did to make it easy was just add a desktop icon 'link to application' put 'beryl-manager' in the command line and just start it up that way. I don't think I want to start it when KDE starts, I'd rather do it manually.

Sometimes I lose my window borders too, and just click the taskbar icon and 'reload window decorator' It does seem a little buggy at times.

Last edited by cueman; 12-12-2006 at 02:29 PM.
 
Old 12-16-2006, 11:33 AM   #13
cueman
Member
 
Registered: Oct 2006
Location: Scottsdale, Arizona
Distribution: openSUSE 10.2
Posts: 199

Rep: Reputation: 30
I was wondering, before I had beryl installed, just using xgl desktop effects, you could change the opacity of a window by holding 'shift' and your mouse wheel. Now, with beryl, instead of changing to opaque it changes to black. I can't find a setting, maybe I'm missing it somewhere, but I like the opaque. It seemed the whole purpose was so you could see what was under your active window.

Is there a setting , maybe a color picker for the opacity setting?

Thanks
 
Old 12-16-2006, 11:44 AM   #14
parsek77
Member
 
Registered: Sep 2004
Location: NY
Distribution: SUSE 10.2
Posts: 35

Original Poster
Rep: Reputation: 15
Do you mean translucency? Alt+mouse wheel
 
Old 12-16-2006, 11:57 AM   #15
cueman
Member
 
Registered: Oct 2006
Location: Scottsdale, Arizona
Distribution: openSUSE 10.2
Posts: 199

Rep: Reputation: 30
AAhh, thanks, it was shift/mouse wheel in the desktop effects by default I believe.

Thanks parsek !

On a side note, why would shift/mouse wheel do the darkness? I wonder the purpose.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard shortcuts in Beryl shame Suse/Novell 1 03-23-2007 07:14 AM
Everything in Beryl is white crazyjimbo Linux - Software 18 03-03-2007 01:15 AM
Beryl for Edgy 64bits How-to?? HellSpawn Ubuntu 1 12-11-2006 08:22 PM
edgy + beryl random guy Linux - Software 2 11-30-2006 09:08 PM
Beryl have arrived to Debian ! megaprog Debian 22 11-30-2006 06:57 AM


All times are GMT -5. The time now is 03:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration