LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 03-18-2005, 06:34 PM   #1
Anoth
LQ Newbie
 
Registered: Mar 2005
Posts: 9

Rep: Reputation: 0
ATI installation error


Hi, I'm new to linux so i still get lost pretty easily.

I've installed SUSE 9.2, and I'm triyng to install the ati drivers, following the guide given in this section of the forum and the one from the SUSE ftp (the where I got the rpms from), I installed the gcc, kernel source and make from the dvd.

(I didn't do any updates with yast, so I assume the kernel I'm using and the source I installed are same, cause I installed the system and the aditional package from the same dvd),

steps I took:

-installed: gcc, kernel-source packages (since make was already installed)
-entered init 3 mode
-logged in as root, wich I assume I did it the right way, typed in the command line where I first logged as my common user: su - then he asks me for the password of the root, and I'm in root I think.
-got into the directory where the rpms are and ran the command:
rpm -Uhv fglr*.rpm

then I got this error:

linux:/windows/C/Driver Linux/Grafica/Drivers_suse # rpm -Uhv fglrx-8.10.19-1.1.i586.rpm
error: fglrx-8.10.19-1.1.i586.rpm: V3 DSA signature: BAD, key ID 0dd8616d
error: fglrx-8.10.19-1.1.i586.rpm cannot be installed
linux:/windows/C/Driver Linux/Grafica/Drivers_suse #

Can anyone help me?

Thanks

Anoth
 
Old 03-19-2005, 07:32 AM   #2
Anoth
LQ Newbie
 
Registered: Mar 2005
Posts: 9

Original Poster
Rep: Reputation: 0
improvements...or not :)

Hi I got past that error, but there was one thing I couldn't run from the guide in the forum, that was the final step:
run fglxconfig

however I did added those options from the suse README on step 5, The NoTV and TVStandrd.

Well I could get into graphical mode, but I couldn't test any display properties or graphic card properties change. Anyway i changed my display size. That didn't work and now I think I have to reinstall suse cause I can't get in the graphical mode.

Anyone knows what did I do wrong and why I couldn't run fglxconfig?

Thanks

Anoth
 
Old 03-21-2005, 08:59 AM   #3
tumbelo
Member
 
Registered: Mar 2005
Distribution: Suse 9.3, Kubuntu Hoary, Slackware 10.1
Posts: 66

Rep: Reputation: 15
I have no idea how to make the crappy drivers work but I managed to save my system when I (yes, me too) messed up my X. Since you can't get to the GUI, edit /etc/X11/XF86Config. I used pico as the editor, it's simple enough and trying to use vim was hopeless for me. To get the graphical mode run again I changed some settings back to the way they were before, at least some of them. You could try these, but don't blame me if it goes worse.

Remove Load "dri" from Modules
Change "Driver" from "glx" to "radeon" in the device section (it's at the end of the config file)
 
Old 03-21-2005, 06:06 PM   #4
Anoth
LQ Newbie
 
Registered: Mar 2005
Posts: 9

Original Poster
Rep: Reputation: 0
If I mess up my X again I'll try that for sure, nothing to lose

thanks for the advice
 
Old 04-01-2005, 07:12 PM   #5
pharmd
Member
 
Registered: Feb 2005
Location: South Carolina
Distribution: Ubuntu 6.06 LTS
Posts: 83

Rep: Reputation: 15
good guide..got my ati 9600 up and runninghttp://www.linuxquestions.org/questi...hreadid=302954
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI driver installation in 2.4.26 deveraux83 Slackware 1 11-05-2004 02:44 AM
ATI Radeon installation help. Termin8tor Linux - Newbie 4 09-26-2004 06:07 PM
Suse 9.1 ATI grfx card installation error! slouis Linux - Distributions 4 05-11-2004 12:16 PM
ati installation, please help window Linux - Newbie 3 04-21-2004 06:02 PM
please help me with ati installation window Linux - Hardware 0 04-19-2004 04:32 PM


All times are GMT -5. The time now is 12:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration