LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   ATi install guide for SuSE 9.2 pro (http://www.linuxquestions.org/questions/suse-novell-60/ati-install-guide-for-suse-9-2-pro-302954/)

Jason711 03-17-2005 07:41 PM

ATi install guide for SuSE 9.2 pro
 
first off... get a card based on an nvidia chipset... ;)

now, the main stuff is ripped from the SUSE readme that came with the drivers.. so im not taking credit at all really. i just want others to see this guide quicker than i did. perhaps it will make somebodies life a little easier. :D

onward...

i started with a clean install of 9.2 pro. during the install i added gcc, kernel-source, and make. you can do that by searching the packages. these are very important.

after the install i immediately downloaded the rpm's available at SuSE's ftp..

ftp://ftp.suse.com/pub/suse/i386/sup.../fglrx/8.10.19

what you want to do is log in as root to KDE.. then hit ctrl+alt+f4, if that doesnt shut down X... run a shell type init 3.

by now you are at the CLI. log in again. (as root)

cd to the location of the driver rpm's and run rpm -Uhv fglrx*.rpm

next we update the kernel module (if you have updated prior to installing this make sure the source is the same as the kernel you are running. if they are different obviously it wont work. simply go back to YaST/YoU and d/l the correct kernel-source.)

cd to /usr/src/linux
rm -f .config
make cloneconfig
make prepare-all
rm -rf /usr/src/kernel-modules/fglrx

go back to your driver rpm directory.

this time run rpm -Uhv km_fglrx*.rpm

now we compile the kernel module sources.

cd to /usr/src/kernel-modules/fglrx
KERNEL_SOURCE=/usr/src/linux make modules
KERNEL_SOURCE=/USR/SRC/linux make install
depmod -a

on to the configuration... (remember you are still in init 3)

run these..
rcxdm stop
sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profile/firegl -i

to enable 3d support...

run vi /etc/X11/XF86Config... scroll down to the section called "Module" and make sure it says Load "dri"

now run fglrxconfig (remember you are configureing this in root... mine did not apply to the regular user, so i had to run fglxconfig again. what i did was log in as the user.. pull up a shell, ran su, then ran init 3. logged in again as the usr at the CLI, su, and ran fglrxconfig.) i really hope that made sense... lol.

the key things with the config is to make sure you do not use the internal agpgart. make sure you are do not set a resolution higher than your monitor can support, check the refresh rates aswell as you will need that info.

and another thing, it will ask about multisampling and AA... do not force on all applications.. this will greatly reduce performance. the drivers simply do not deliever for the card right now so it isnt worth it. for example running glxgears with forced multisampling got me around 1500 fps... without its around 3600 fps.

now you sould be finished....

run init 5 to get back to X.

have a nice day.. :D

t3gah 03-20-2005 08:47 PM

Great going! Maybe you should post a howto in the "Linux Tutorials" section:

http://www.linuxquestions.org/questions/answers.php

of the forum and have the link there too. That way it will be like "sticky" but in the one place....

Anoth 03-21-2005 04:37 AM

Did great with your tutorial and the one from the ftp, just one thing I couldn't do which is the part:

now run fglxconfig (remember you are configureing this in root... (...)

Couldn't run it at all, where am I supose to run it?

Thanks

NOTE - (I had already stated this problem in another thred http://www.linuxquestions.org/questi...hreadid=303341)

tumbelo 03-21-2005 09:05 AM

I'd also like to know how to access the config since I'll eventually want to try to install the drivers again. The last time I tried, I followed the official instructions as much as I understood but still messed up X.

Anoth 03-21-2005 06:04 PM

yup, I messed up my X too, and then reinstalled the OS :), even though I could enter the X, I just couldn't change anymore the options of my monitor, and my graphic card options were the same.

Hoping for some help in here :)

By the way my graphic card is an Asus ATI EAX 800XT, maybe it can help somewhere...

BDHamp 03-22-2005 10:57 PM

Thanks for the Guide
 
Thanks for this guide. As a newbie to Linux itself and thus unfamiliar with most of the individual programs, It was extremely helpful. I'd tried following several others and ended up in the midst of graphics hell.

I note above a few people asked about running fglxconfig. I too had the problem of not being able to get this to work. Then I read that section of the guide more carefully and noted what I believe must be a typo. Try running fglrxconfig (note the addition of the "r"). This worked perfectly for me.

Jason711 03-24-2005 09:47 AM

np for the guide... im a newbie myself. sorry about the typo... i threw it all togther in about five minutes.. didnt bother to proof read it. :o

ill correct it.

if you have doom3 let me know if you can run it!

i couldnt, i have ordered a 6800nu. lol.

BDHamp 03-24-2005 09:15 PM

Doom 3
 
Well, I sorta got it to run, but in an acceptable way. I'm still running a dual boot system until I get all the personal bugs and challenges worked out, and a lot of what I'm doing right now is comparing performance of tasks under Linux to tasks under Windoze. Windoze is losing in all respects except one -- anything that involves heavy use of my graphics card.

I've been an ATI guy for a long time, but I've decided I'm going to switch. So, when I do get Doom 3 to run properly, it will be with the same card you're getting.

Jason711 03-25-2005 10:57 AM

Re: Doom 3
 
Quote:

Originally posted by BDHamp
Well, I sorta got it to run, but in an acceptable way. I'm still running a dual boot system until I get all the personal bugs and challenges worked out, and a lot of what I'm doing right now is comparing performance of tasks under Linux to tasks under Windoze. Windoze is losing in all respects except one -- anything that involves heavy use of my graphics card.

I've been an ATI guy for a long time, but I've decided I'm going to switch. So, when I do get Doom 3 to run properly, it will be with the same card you're getting.

funny how that works, isnt it.

vincewu 03-25-2005 10:59 AM

[help]I can't enable 3d support
 
yeah i've installed ATI driver and there is Load "dri" in XF86config,but i still can't enable 3d,why?:confused:

Stealthy_C 03-25-2005 02:27 PM

Quote:

run these..
rcxdm stop
sax2 -r -m 0=fglrx -b

Nice Job.

But one question, I get to the part I have quoted above, and once I run that last line I get a SaX> command line
type in this
/usr/X11R6/lib/sax/profile/firegl -

and nothing happens, hmm what did i do wrong?

vincewu 03-25-2005 08:45 PM

Quote:

Originally posted by Stealthy_C
Nice Job.

But one question, I get to the part I have quoted above, and once I run that last line I get a SaX> command line
type in this
/usr/X11R6/lib/sax/profile/firegl -

and nothing happens, hmm what did i do wrong?

you should run this:
sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profile/firegl -i

tumbelo 03-26-2005 07:21 AM

Re: Doom 3
 
Quote:

Originally posted by BDHamp
Well, I sorta got it to run, but in an acceptable way. I'm still running a dual boot system until I get all the personal bugs and challenges worked out, and a lot of what I'm doing right now is comparing performance of tasks under Linux to tasks under Windoze. Windoze is losing in all respects except one -- anything that involves heavy use of my graphics card.

I've been an ATI guy for a long time, but I've decided I'm going to switch. So, when I do get Doom 3 to run properly, it will be with the same card you're getting.


Does it actually even run? I tried _Quake 2_ yesterday, and it jerked and lagged even on 800*600. Even the software mode ran better at that res! As a bonus, the game froze completely, forcing me to hard reboot when running on OpenGL.

Stealthy_C 03-26-2005 01:55 PM

Quote:

Originally posted by vincewu
you should run this:
sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profile/firegl -i



:D :cool:

Thanx knew I was typing something wrong :p

Its nice to have 3D enabled, and now my screen savers dont run frame by frame :)

pharmd 04-01-2005 06:29 PM

thanks aolt man this helps a great deal...now that gears program is up to 1765.8 fps


this needs to be made into a sticky...there are so many posts asking for this information


All times are GMT -5. The time now is 02:39 AM.