LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 05-07-2005, 10:20 PM   #1
abefroman
Senior Member
 
Registered: Feb 2004
Location: Chicago
Distribution: CentOS
Posts: 1,277

Rep: Reputation: 53
Are you suppose to be able to run X remotely?


Are you suppose to be able to run X remotely?

I get the following message:
linux:~ # X

This is a pre-release version of XFree86, and is not supported in any
way. Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org. Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository
(http://www.XFree86.Org/cvs).

XFree86 Version 4.3.99.902 (4.4.0 RC 2)
Release Date: 18 December 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: SuSE Linux [ELF] SuSE
Current Operating System: Linux linux 2.6.4-52-smp #1 SMP Wed Apr 7 02:11:20 UTC 2004 i686
Build Date: 23 August 2004
Changelog Date: 29 February 2004
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sun May 8 03:14:51 2005
(==) Using config file: "/etc/X11/XF86Config"
(WW) I810(0): Failed to set up write-combining range (0xf0000000,0x8000000)
Could not init font path element /usr/X11R6/lib/X11/fonts/local, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID, removing from list!
 
Old 05-07-2005, 11:00 PM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
X is run locally. Applications that use X are then run remotely by, for example, tunneling X over ssh.

For example, let's say that you have a Linux machine at home, and want to run an X application remotely from your Windows machine at work.

First, start X on Windows. If you need X for Windows, you can download the free cygwin package, which includes Xorg.

Second, ssh from the Windows machine to the Linux machine, requesting that X be tunneled:

ssh -Y userid@host

After you login, you can run any X application, and it will display on your Windows machine. For example, if you want to run the evolution email program:

evolution &

If you are trying to run an X application on a Linux/*BSD/UNIX machine, X is already there. Just start at the ssh.
 
Old 05-08-2005, 12:51 PM   #3
abefroman
Senior Member
 
Registered: Feb 2004
Location: Chicago
Distribution: CentOS
Posts: 1,277

Original Poster
Rep: Reputation: 53
How do I get ssh to work wtih cygwin?

abe2@abe ~
$ ssh 10.10.10.10
bash: ssh: command not found

Its saying in cant find ssh.
 
Old 05-08-2005, 01:34 PM   #4
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
Then you didn't select it during the installation.

Rerun the Cygwin setup, and in the "Net" section, select openssh. Also make sure that in the X11 section, you've selected the x-startup scripts. The requisites should be automatically selected.
 
Old 05-08-2005, 01:50 PM   #5
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
As a followup, this is the sequence of actions you need to take to run a remote X application:

1.Start Windows
2. Run cygwin. This establishes the environment.
3. At the cygwin bash prompt, enter the command startx. This will bring up the local X. An xterm window will open.
4. In the xterm window, ssh to the destination machine, with the "-Y" option. For example:

ssh -Y someuser@somehost

5. When you are logged into the remote system, you can run any X application, and it will display on your local system.
 
Old 05-08-2005, 02:27 PM   #6
abefroman
Senior Member
 
Registered: Feb 2004
Location: Chicago
Distribution: CentOS
Posts: 1,277

Original Poster
Rep: Reputation: 53
Thanks!

I am getting this error though:
abefro@linux:/root> export DISPLAY=69.211.121.xx:0
abefro@linux:/root> xhost +127.0.0.1
xhost: unable to open display "69.211.121.xx:0"

where 69.211.121.xx is my ip.

Got any tips?
 
Old 05-09-2005, 03:49 AM   #7
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
I think there are some security settings that prohibit the use of the X server from remote locations. In /etc/X11/xdm/Xservers you may have to remove '-nolisten tcp' and in /etc/X11/xdm/xdm-config you may need to comment-out the line 'DisplayManager.requestPort: 0'. Since I have never tried this, I can't tell which one ot those is really required.
 
Old 05-09-2005, 11:04 AM   #8
abefroman
Senior Member
 
Registered: Feb 2004
Location: Chicago
Distribution: CentOS
Posts: 1,277

Original Poster
Rep: Reputation: 53
Thanks! It still wont let me connect though.

Is it
export DISPLAY=10.10.0.252:0
or
export DISPLAY=10.10.0.252:0.0
?

Should that be run as root or an under privledged user?
 
Old 05-09-2005, 11:25 AM   #9
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Quote:
abefro@linux:/root> xhost +127.0.0.1
xhost: unable to open display "69.211.121.xx:0"
I think this is the problem. You cannot run xhost from the remote system. This has to be run locally (I think).
 
Old 05-09-2005, 12:29 PM   #10
abefroman
Senior Member
 
Registered: Feb 2004
Location: Chicago
Distribution: CentOS
Posts: 1,277

Original Poster
Rep: Reputation: 53
I tried running xhost locally and get the same error:

xhost: unable to open display "10.10.0.251:0"
xhost: unable to open display "localhost:0"
xhost: unable to open display "localhost:0.0"
xhost: unable to open display "10.10.0.251:0.0"
 
Old 05-09-2005, 12:45 PM   #11
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
I read a little in my literature and found another method of authentification. Maybe this will work better:

1. Extract the MIT-MAGIC-COOKIE-1 key on your local machine (usually in ~/.Xauthority):
Code:
user@workstation$ xauth extract keyfile workstation:0
2. Transfer keyfile to your remote client (e.g. FTP)
3. Install key on client:
Code:
user@client$ xauth merge keyfile
Now try again to export and access the display. And don't forget to comment-out 'DisplayManager.requestPort: 0' in /etc/X11/xdm/xdm-config.

EDIT: STOP Before you try this, have a look at this link: http://portal.suse.com/sdb/en/2002/04/remotex_80.html

Last edited by abisko00; 05-09-2005 at 12:49 PM.
 
Old 05-09-2005, 12:54 PM   #12
abefroman
Senior Member
 
Registered: Feb 2004
Location: Chicago
Distribution: CentOS
Posts: 1,277

Original Poster
Rep: Reputation: 53
linux:/home/abefro # locate Xauthority
/home/abefro/.Xauthority
linux:/home/abefro # xauth extract .Xauthority localhost:0
No matches found, authority file ".Xauthority" not written
linux:/home/abefro # cat .Xauthority
☺ ♣linux ☺0 ↕MIT-MAGIC-COOKIE-1 ►I[* ¶↔˛`V,ázA:U¬ ♦⌂ ☻ ☺0 ↕MIT-MAGIC-COOKIE-
1 ►I[* ¶↔˛`V,ázA:U¬☺
linux.site ☺0 ↕MIT-MAGIC-COOKIE-1 ►I[* ¶↔˛`V,ázA:U¬linux:/home/abefro #

Its saying no matches found even though the authority file is there, I also tried putting the full path to the Xauthority file.
 
Old 05-09-2005, 12:59 PM   #13
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
No, no, the command xauth knows where to find .Xauthority. The parameter 'keyfile' is just the filename where you would like to extract the key to. Sorry if my post was confusing.
 
Old 05-09-2005, 01:20 PM   #14
abefroman
Senior Member
 
Registered: Feb 2004
Location: Chicago
Distribution: CentOS
Posts: 1,277

Original Poster
Rep: Reputation: 53
Thanks for the clarification.

It stil doesnt seem to be working:
linux:~ # >keyfile
linux:~ # xauth extract keyfile 10.10.0.252:0
No matches found, authority file "keyfile" not written
 
Old 05-09-2005, 01:28 PM   #15
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
As far as I can see, you are logged in as root. This way xauth assumes .Xauthority in /root. Try the command as user. I edited the above post. Have a look at the link first, maybe the xhost method will work after you applied the changes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't run X programs remotely mcshen Linux - General 2 07-28-2005 08:47 PM
Can I run wine remotely via ssh? jon_k Linux - Software 1 06-04-2005 05:57 AM
Is it possible to run ethereal remotely via the commandline? abefroman Linux - Security 5 05-10-2005 12:10 AM
With GTK can you run it remotely? abefroman Linux - Software 2 05-08-2005 05:13 AM
Unable to run X applications remotely pree Linux - Software 0 06-27-2003 02:45 AM


All times are GMT -5. The time now is 11:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration