LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   am/pm verses 24 hour time (http://www.linuxquestions.org/questions/suse-novell-60/am-pm-verses-24-hour-time-320391/)

CouchMaster 05-05-2005 10:32 AM

am/pm verses 24 hour time
 
SuSE 9.1 - KDE
How do you set the clock to show the standard am/pm time instead of the 24 hour military time it shows now? I've looked, searched, traveled to the ends of the Earth and have not found the answer. Someone has to know how to do this, I mean come on ---- I've just installed PCBSD on an old beatup computer and it does it automatically!!!!!!!! GEEEEEEZZZZZEEE Guys......

69_rs_ss 05-05-2005 11:50 AM

Are you using KDE or gnome? In KDE it should be under Control Center -> Regional. Just set it to your region and it should fix this.

abisko00 05-05-2005 11:55 AM

Try this:

Right-click the clock -> Date & Time Format -> Select Register 'Time & Dates' -> Change 'Time Format' to 'pH:MM:SS AMPM'.

Just a comment: Most of Europe uses what you call 'military time', not sure about the rest of the world that doesn't have english as native language. ;)

CouchMaster 05-05-2005 12:39 PM

Will give it a try - thanks ..........

geeman2.0 05-05-2005 12:44 PM

How changing it for fluxbox?
I've been wanting to change the clock setting in flux myself, but have been unable to figure out how.

CouchMaster 05-05-2005 01:02 PM

Quote:

Originally posted by abisko00
Try this:

Right-click the clock -> Date & Time Format -> Select Register 'Time & Dates' -> Change 'Time Format' to 'pH:MM:SS AMPM'.

Just a comment: Most of Europe uses what you call 'military time', not sure about the rest of the world that doesn't have english as native language. ;)

I had to wait until 1pm to see if it worked - and it does! Abisko00 you da man!!!!!!!!!! Thanks

smyunus 05-19-2015 01:09 AM

Quote:

Originally Posted by abisko00 (Post 1627089)
Try this:

Right-click the clock -> Date & Time Format -> Select Register 'Time & Dates' -> Change 'Time Format' to 'pH:MM:SS AMPM'.

Just a comment: Most of Europe uses what you call 'military time', not sure about the rest of the world that doesn't have english as native language. ;)

How do we achieve this by commands?

John VV 05-19-2015 02:51 AM

this thread is 10 years old and for a version of suse (9.1) that is long dead
9.1 went End Of Life back on June 30th 2006


the instructions for that os ( suse 9.1) will be VERY different than those for
OpenSUSE 13.2 or tumbleweed

abisko00 05-20-2015 10:13 AM

And even after ten years, you'll get an answer to your question. :)

The display format of the clock is dependent on the locale settings. In /etc/sysconfig/language you can change to whatever locale you like (and is installed).

If you however refer to the format of the "date" command in bash, changing the locale setting will not switch to the am/pm setting (at least not on my system). Here, I solved the problem by setting an alias in .bashrc like

Code:

alias date="date +%r"
There are many other formatting options available. Have a look at the manpage.


All times are GMT -5. The time now is 08:45 PM.