LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 06-20-2008, 07:27 PM   #1
xbennyboy
Member
 
Registered: Jul 2004
Distribution: openSUSE 10.2
Posts: 141

Rep: Reputation: 15
After a dual-boot install, Vista no longer boots


I installed opensuse 11 from a burned DVD. I have two hard drives: one 40GB drive with two ntfs partitions /dev/sda1 (with Vista install) and /dev/sda2, and another 8GB drive with the Suse installation and swap partition.
For some reason, when I choose to boot Vista from the GRUB menu, it just gets stuck at a black console screen with
Code:
rootnoverify (hd1,0)
chainloader (hd0,0)+1
How do I fix this?
 
Old 06-20-2008, 09:50 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,485

Rep: Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077
Try changing it to "rootnoverify (hd0,0)"
 
Old 06-20-2008, 11:52 PM   #3
xbennyboy
Member
 
Registered: Jul 2004
Distribution: openSUSE 10.2
Posts: 141

Original Poster
Rep: Reputation: 15
Thank you! It works perfectly. Although I have to wonder why openSUSE 11 automatically configures the Vista boot entry with hd1 for rootnoverify.
 
Old 06-21-2008, 12:25 AM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,485

Rep: Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077
Most distros have trouble with multiple disks - just bad (installer) design.
 
Old 06-21-2008, 01:56 PM   #5
xbennyboy
Member
 
Registered: Jul 2004
Distribution: openSUSE 10.2
Posts: 141

Original Poster
Rep: Reputation: 15
So apparently, this is an issue with the new Vista bootloader. The generated line from Yast "rootnoverify (hd1,0)" works only for Windows versions below Vista. For vista you have to change it to hd0. I think this should be made a sticky, since I think many people will be running into these issues.

http://forums.opensuse.org/install-b...-opensuse.html
 
Old 06-21-2008, 06:47 PM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,485

Rep: Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077
Nope - that wouldn't have worked with any version of windoze.
Don't try and generalize from one specific case. There are plenty of nuances in how the loaders (including Vista) work.
 
Old 06-27-2008, 08:39 PM   #7
stasik
Member
 
Registered: Dec 2005
Location: dublin
Distribution: suse 11.3, 64 bit
Posts: 126

Rep: Reputation: 15
i have the same problem with my Windows xp. i can not boot it. i did the same thing as with previous distros of suse.. this is my menu.lst:

# Modified by YaST2. Last modification on Sat Jun 28 01:18:36 BST 2008
default 0
timeout 5
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title linux
root (hd0,1)
kernel /boot/vmlinuz-2.6.25.5-1.1-default root=/dev/disk/by-id/scsi-SATA_SAMSUNG_HD321KJ_S0ZEJ1MP802507-part2 resume=/dev/sda3 splash=silent showopts vga=0x31a
initrd /boot/initrd-2.6.25.5-1.1-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title windows
rootnoverify (hd0,1)
kernel /boot/vmlinuz-2.6.25.5-1.1-default root=/dev/disk/by-id/scsi-SATA_SAMSUNG_HD321KJ_S0ZEJ1MP802507-part1 showopts ide=nodma apm=off acpi=off noresume edd=off x11failsafe vga=0x31a
initrd /boot/initrd-2.6.25.5-1.1-default

title aaaa


but at boot loader for my windows entry i have:

optional kernel command line parameter: showopts ide=nodma apm=off acpi=off noresume edd=off x11failsafe
kernel image: /boot/vmlinuz-2.6.25.5-1.1-default
initial ram disk: /boot/initrd-2.6.25.5-1.1-default
root device: /dev/sda1
vga mode: 0x31a


any ideas how to fix it???
thanks in advance

Last edited by stasik; 06-27-2008 at 08:40 PM.
 
Old 06-27-2008, 09:14 PM   #8
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,485

Rep: Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077
Report a bug to the developers.

Did you alter menu.lst ???
Let's see the output from "fdisk -l" (as root/sudo, whatever).
 
Old 06-29-2008, 07:57 AM   #9
stasik
Member
 
Registered: Dec 2005
Location: dublin
Distribution: suse 11.3, 64 bit
Posts: 126

Rep: Reputation: 15
i didnt alter the menu.lst.

linux-5cru:~ # fdisk -l

Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xe294e294

Device Boot Start End Blocks Id System
/dev/sda1 1 19122 153597433+ 7 HPFS/NTFS
/dev/sda2 * 19123 38301 154055317+ 83 Linux
/dev/sda3 38302 38913 4915890 82 Linux swap / Solaris

Disk /dev/sdb: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xd7a757b2

Device Boot Start End Blocks Id System
/dev/sdb1 1 38914 312568832 7 HPFS/NTFS



i have 2 hard drives:
1- have windows + linux + swap
2 - ntfs.
 
Old 06-29-2008, 10:13 AM   #10
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
That is what is confusing your boot loader is having the second hard drive in the ntfs format. Your boot loader has to guess which partition is windows. stasik change your windows entry to rootnoverify (hd0,0)
 
Old 06-29-2008, 05:32 PM   #11
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,485

Rep: Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077
That appears to be a screwed up recovery option (despite it being titled windows) - ignore it for now. Create a new stanza like this
Code:
title fix-it
rootnoverify (hd0,0)
chainloader +1
 
Old 06-30-2008, 05:29 PM   #12
stasik
Member
 
Registered: Dec 2005
Location: dublin
Distribution: suse 11.3, 64 bit
Posts: 126

Rep: Reputation: 15
Larry Webb & syg00, thank you very much. that did the trick. thanks again!!!
 
Old 06-30-2008, 05:33 PM   #13
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,485

Rep: Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077
Happy to help - you might as well go back and fix the titles. Make the other one "failsafe", and the fix-it one "Windoze" (or somesuch ).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New install on vista system, want dual boot for vista and fedora. lhelden Linux - Newbie 9 08-21-2008 11:22 AM
fedora/vista dual boot - partimage: restored vista - vista won't let me log on redmoon zero Linux - General 1 12-31-2007 08:21 PM
Mandriva Spring 2007 dual boots with Windows Vista TigerLinux Mandriva 10 09-06-2007 12:44 AM
Ubuntu install/dual-boot Vista SuperSenshi100 Linux - Newbie 2 08-25-2007 09:56 PM


All times are GMT -5. The time now is 11:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration