LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Accessing WiFi in university, SuSE 11.0 Kde 3.5 (http://www.linuxquestions.org/questions/suse-novell-60/accessing-wifi-in-university-suse-11-0-kde-3-5-a-772915/)

raju.mopidevi 12-02-2009 04:48 AM

Accessing WiFi in university, SuSE 11.0 Kde 3.5
 
2 Attachment(s)
In my university we have a Wifi. All the people are connecting to it through windows. I am a regular linux user. I don't want to go windows.
How can i connect to it ?

The details of my university wifi can be seen in attached image.

repo 12-02-2009 04:53 AM

Does the wireless works, like at home ?
Is the wireless card recognized and working?
Do you use kwifimanager?

raju.mopidevi 12-02-2009 04:58 AM

I am using Knetwork manager. It has a option to create eth0,wlan0.
In windows automatic recognition of wifi option is available. But this is not with my openSUSE. I don't know to see available wifi connections. So i had made snapshot of KLUniversity wifi properties. May be that can be helpful to create wifi connection.

repo 12-02-2009 05:00 AM

Does it work on another location?
What is the output from
Code:

ifconfig
iwconfig


raju.mopidevi 12-02-2009 05:00 AM

Knetwork manager allows me to enable/disable radio options. But it is not showing any wifi connections even after enabling. Normally I expect automatic recognition of wifi connection after I enable Wifi.

raju.mopidevi 12-02-2009 05:04 AM

Presently I am at my home, and i was using wired connection to connect to internet. If i know how to scan all the available wifi connections, then tomorrow i'll try them at my university.

repo 12-02-2009 05:13 AM

Quote:

Originally Posted by raju.mopidevi (Post 3776867)
Presently I am at my home, and i was using wired connection to connect to internet. If i know how to scan all the available wifi connections, then tomorrow i'll try them at my university.

You first need to know if the wireless card is recognized and if the driver is loaded.
Therefore you need to issue
iwconfig and ifconfig

raju.mopidevi 12-02-2009 05:17 AM

these are my present output for the two commands

IFCONFIG:
Code:

linux-snzv:/home/raju # ifconfig
eth0      Link encap:Ethernet  HWaddr 00:15:C5:C2:9C:9F
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::215:c5ff:fec2:9c9f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9991 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11503 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4537138 (4.3 Mb)  TX bytes:3519758 (3.3 Mb)
          Interrupt:17

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1231 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1231 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:72509 (70.8 Kb)  TX bytes:72509 (70.8 Kb)

IWCONFIG:
Code:

linux-snzv:/home/raju # iwconfig
lo        no wireless extensions.

wmaster0  no wireless extensions.

wlan0    IEEE 802.11g  ESSID:""
          Mode:Managed  Channel:0  Access Point: Not-Associated
          Tx-Power=0 dBm
          Retry min limit:7  RTS thr:off  Fragment thr=2352 B
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

eth0      no wireless extensions.


repo 12-02-2009 05:22 AM

You should enable wlan0 in knetworkmanager.
Then, if the card works correct, it should see the accesspoints.

raju.mopidevi 12-02-2009 05:27 AM

Wifi is already enabled. Since I am at my home, it is showing no wireless extensions.

I will try those commands in my university. I'll post those outputs tomorrow.

raju.mopidevi 12-04-2009 07:47 AM

hi, thanks to all,
I had created the wireless connection, just by giving the SSID name only. Now i was able to connect to the Wifi in my university.


All times are GMT -5. The time now is 03:28 AM.