LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 12-07-2005, 12:36 PM   #1
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: SUSE 10.3, Microware OS-9, Caldera 2.4
Posts: 223

Rep: Reputation: 30
9.3 alsamixer resetting on reboot


Does anyone know what could be resetting my alsamixer settings on reboot? Is there a simple way to recall the last setting? Like a config file somewhere?

Thanks
 
Old 12-08-2005, 05:10 AM   #2
Sargek
Member
 
Registered: Jan 2003
Location: San Antonio, Texas
Distribution: Debian testing
Posts: 416

Rep: Reputation: 32
Quote:
Originally Posted by ionmich
Does anyone know what could be resetting my alsamixer settings on reboot? Is there a simple way to recall the last setting? Like a config file somewhere?

Thanks
Not sure how Suse does things, but in several distros I've used over the past few years (including currently), you would run
Code:
alsactl store
as root to store your alsamixer settings, and they should remain at reboot. Not sure if Suse requires you to run some type of service at boot to initiate alsa sound or not.
 
Old 12-08-2005, 09:28 AM   #3
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
Sargek said:
Quote:
Not sure if Suse requires you to run some type of service at boot to initiate alsa sound or not.
It is required. The shell-script /etc/init.d/alsasound is used for that.
This script requires /usr/sbin/alsactl program from alsa-utils package.

It runs '/usr/sbin/alsactl restore' at system startup
using the 'S<number>alsasound -> ../alsasound
K<number>alsasound -> ../alsasound links
in the /etc/init.d/rc<number>.d directories

Last edited by berbae; 12-08-2005 at 09:29 AM.
 
Old 12-08-2005, 01:16 PM   #4
meh1
LQ Newbie
 
Registered: Sep 2004
Location: U.S.
Distribution: SuSE 9.2 Pro
Posts: 14

Rep: Reputation: 0
Alsamixer Keeps Resetting On Reboot

I had this exact same problem earlier this year. I use Suse 9.2. The problem started after I updated alsa to a newer version. I corrected the problem by accident. I had to delete my soundcard driver, using YAST and reinstall and configure it. After doing this the alsamixer saves my settings and on reboot I don't have to adjust the volume setting. I'm not sure why this worked, but it did. I tried all the suggestions posted here and none of them worked.

Hope this helps,

meh1
 
Old 12-08-2005, 07:51 PM   #5
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: SUSE 10.3, Microware OS-9, Caldera 2.4
Posts: 223

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by meh1
I had this exact same problem earlier this year. I use Suse 9.2. The problem started after I updated alsa to a newer version. I corrected the problem by accident. I had to delete my soundcard driver, using YAST and reinstall and configure it. After doing this the alsamixer saves my settings and on reboot I don't have to adjust the volume setting. I'm not sure why this worked, but it did. I tried all the suggestions posted here and none of them worked.

Hope this helps,

meh1
It certainly worked for me. Thanks.

In the meantime I learned how to set the mixer using "amixer", which can be invoked from a script executed when KDE starts your player. Different settings for different software.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No keyboard/mouse after reboot. Requires second reboot to work. rottie Linux - Hardware 6 01-16-2006 05:04 AM
/dev/nvdia* permissions keep resetting on reboot Lagg Slackware 7 05-13-2005 04:04 PM
Losing my alsamixer settings after a reboot moger Slackware 4 07-05-2004 10:17 PM
hostname resetting to localhost on unclean reboot brian_h1 Linux - Networking 0 05-11-2004 08:18 PM
Resetting the MTU Cichlid Linux - Networking 1 03-28-2002 12:50 PM


All times are GMT -5. The time now is 05:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration