LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   12.2 Install Failure: Grub2 Insisting on Using Swap for Boot (http://www.linuxquestions.org/questions/suse-novell-60/12-2-install-failure-grub2-insisting-on-using-swap-for-boot-4175426712/)

joncr 09-11-2012 10:45 AM

12.2 Install Failure: Grub2 Insisting on Using Swap for Boot
 
Trying to do a clean install of OpenSUSE 12.2. It's failing on a multi-disk machine.

Grub2 keeps trying to install on the swap partition. It should be on /dev/sda. When I correct this during the installation routine, it does not "take". As a result, I first get error about failure to create inited, followed by grub2 failure messages.

The install also sets the boot flag on swap. If I reset it manually with parted, reboot, and start the install over, the flag is set to boot. (THe boot flag is correctly set on the actual boot drive.)

kakaka 09-11-2012 05:42 PM

The device /dev/sda represents the whole disk drive, but the device /dev/sda1 represents a partion on /dev/sda. You seem to be using the term "swap partition" and contrasting that with /dev/sda which is an entire disk, not a partition. That makes sound as if something is trying to treat a disk as a partition, rather than creating partitions within the disk. If that it is actually what is happening, then that is the problem.

Normally with openSUSE there is a way to successfully override any suggestions it might make about setting up the system.

Are you running Grub2 manually, or allowing some install procedure to run it for you?

In general, please provide some additional details so we can understand the exact nature of the problem.

joncr 09-11-2012 05:57 PM

Swap's the first partition on /dev/sdf. /Boot is the first partition on /dev/sda. The second partition on /dev/sda is /. So, sda1 and sda2, respectively.

I'm using the standard installer, in non-Automatic Configuration mode because I have multiple drives that need to be partitioned.

The installer lets me change where Grub is installed. It initially shows /dev/sdf. I have no idea why it is opting for that partition instead of the boot partition, other than that the install routine keeps tagging the swap partition on /dev/sdf as the boot partition. (sdf is gpt, and sda is msdos, and is flagged as boot. So, at that point, two partitions are flagged boot.) Changing that to /dev/sda does not change the actual grub script entry as revealed in the grub options menu. That still shows /dev/sdf.

Booting to "rescue" and manually removing the boot flag on swap has no effect.


If I continue with the install after that, the first reboot fails, dumping me back to the installation DVD.

yancek 09-11-2012 06:37 PM

Before the installation of Opensuse begins, you will see a screen labelled "Live Installation Settings" with several headings in green to include: System, Partitioning, Booting. Click on Booting and you get a new screen with two tabs at the top including Section Management and Bootloader Installation. Check the various options and make any changes you want.

If you want Grub installed to a separate /boot partition on sdf, you will obviously need to manually configure your other bootloader on whichever drive/partition you are booting from to include that entry.

There is no need to set a boot flag or mark a partition as active, this isn't windows.

Quote:

If I continue with the install after that, the first reboot fails, dumping me back to the installation DVD
The last time (as well as previous installs) I installed Opensuse (12.1), I was informed the installation had completed and told to reboot and "Remove the Installation Medium" prior to reboot!

joncr 09-11-2012 09:04 PM

I'm installing from DVD and don't recall seeing "Live Installation Settings". I'll check next time I try. During the installation, I'm selecting the manual, or "expert" partitioning approach.

I don't want /boot on /dev/sdf. I explicitly set it on /dev/sda1 in the partitioner. It is the installation routine that selects /dev/sdf as the location for grub.

I've had 15 year's of experience with Linux and it is often necessary to use fdisk or parted to manually set the boot flag on the boot partition. Installation routines often do not do this. As a result, the install appears to complete successfully, and the user finds the system won't boot. A number of distributions will explicitly warn you during partitioning if the selected boot drive has not been flagged correctly. Of course, they offer no no way to do that; you have to boot to a shell to get that done. (FYI: I never use automatic installation or partitioning. I always do it manually because I always have multiple drives. Automatic Linux partitioners can't handle multiple drives. So, maybe the auto stuff sets up boot correctly on its single drive.)

To repeat, I partition sda1 as boot and sda2 as /. I ensure that the boot flag is set on sda. The install routine selects sdf, not sda, as grub's location, although I have partitioned sdf as swap and a data drive. When I change the location for grub via the install routine to sda, it is still installed to sdf, the swap partition is still flagged for boot, and the system, of course, does not boot, producing error messages about initrd and grub that would be totally useless to a mainstream users, but clearly indicating grub is trying to boot off the swap partition on sdf.

If I then boot into rescue mode and manually remove the boot flag from sdf, and rerun the install, the cycle repeats itself. I.e., sdf is set as the boot drive (even though sda is, as well) grub is installed incorrectly to sdf, and the reboot fails.

(No "Remove Installation Media..." message here. I was expecting it. I thought, perhaps, 12.2 is like Fedora, which runs the second stage of its install from the install media after the first reboot.)

yancek 09-12-2012 06:33 PM

My last experience with Opensuse was 12.1. I click to begin the installation and see the Welcome screen with the license agreement. The next step is the time zone and after that, a suggested partitioning screen which has never been what I wanted whenever I have tried to install Opensuse so I click the Edit Partition tab near the bottom of the screen. After editing to my liking, I again come back to the Suggested Partitioning screen and check to see if it is now what I want. If it is, I then click the Next tab and come to the Live Installation Settings page which has numerous options which can be edited, including the bootloader. When you have made your selections for the bootloader and click OK, you should see a screen "Confirm Installation". If you click on Install here, you should see progress and eventually a pop-up indicating the computer needs to be rebooted without the Install CD in the drive to finish.

If you are not seeing this, then Opensuse has made some major changes to their Live Installer since 12.1?? Don't know what else to suggest.


All times are GMT -5. The time now is 05:48 PM.