LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 02-03-2008, 10:19 AM   #1
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: SUSE 10.3, Microware OS-9, Caldera 2.4
Posts: 223

Rep: Reputation: 30
10.3 online update causes boot failure


After a successful installation and testing of 10.3 I was encouraged to do an online update. Now 10.3 will not boot, returning the error...

root (/dev/disk/by-id/scsi-SATA_ST3160215A_9RA0445H-part2,1)
error 23: Error while parsing number
Press any key to continue

"No problem", you say? Just look at /boot/grub/menu.lst.old and make appropriate changes. Sorry! menu.lst.old has been over-written by the update. Brilliant programming!

My menu.lst is as follows:-

# Modified by YaST2. Last modification on Sun Feb 3 08:34:57 CST 2008
default 0
timeout 8
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3 - 2.6.22.16-0.1
root (/dev/disk/by-id/scsi-SATA_ST3160215A_9RA0445H-part2,1)
kernel /boot/vmlinuz-2.6.22.16-0.1-default root=/dev/disk/by-id/scsi-SATA_ST3160215A_9RA0445H-part2 vga=0x314 resume=/dev/sda1 splash=silent showopts
initrd /boot/initrd-2.6.22.16-0.1-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.3 - 2.6.22.16-0.1
root (/dev/disk/by-id/scsi-SATA_ST3160215A_9RA0445H-part2,1)
kernel /boot/vmlinuz-2.6.22.16-0.1-default root=/dev/disk/by-id/scsi-SATA_ST3160215A_9RA0445H-part2 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
initrd /boot/initrd-2.6.22.16-0.1-default

###Don't change this comment - YaST2 identifier: Original name: linux-2.6.22.5-31-default###
title openSUSE 10.3
root (hd0,1)
kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_ST3160215A_9RA0445H-part2 vga=0x314 resume=/dev/sda1 splash=silent showopts
initrd /boot/initrd-2.6.22.5-31-default

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
rootnoverify (hd0,1)
chainloader (/dev/fd0)+1

###Don't change this comment - YaST2 identifier: Original name: failsafe-2.6.22.5-31-default###
title Failsafe -- openSUSE 10.3
root (hd0,1)
kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_ST3160215A_9RA0445H-part2 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
initrd /boot/initrd-2.6.22.5-31-default

I have two drives active, hdc and hdd. 10.3 is on hdd. I tried disconnecting hdc. Nothing changed. I think it must have some connection to the 10.3 change to sda devices. Does anyone know why SUSE changed from /dev/hd? to /dev/sd?. Seems to me like a move backwards.

Thanks for any help.
 
Old 02-03-2008, 10:48 AM   #2
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Smile 10.3 online update causes boot failure

Yes suse 10.3 is moved to sda

But it works fine fore me although the online update using dsl
take rather a long time


all the best
 
Old 02-03-2008, 12:44 PM   #3
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Forget the disc-id reference in GRUB and fstab. Too confusing, and not sure why some distros do this now. Either stick with the typical /dev/hdx or /dev/sdx, or use e2label to give your drives an easy to remember name.
 
Old 02-03-2008, 04:16 PM   #4
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: SUSE 10.3, Microware OS-9, Caldera 2.4
Posts: 223

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Micro420 View Post
Forget the disc-id reference in GRUB and fstab. Too confusing, and not sure why some distros do this now. Either stick with the typical /dev/hdx or /dev/sdx, or use e2label to give your drives an easy to remember name.
Thanks for the good advice, it got me started in the right direction. /dev/hdx did not work, but /dev/sdx did. My problem is that I have a removable IDE bay that is uppermost in the descriptor chain. Here's what works now, with one or two drives and with the boot drive in hdc position.

# Modified by YaST2. Last modification on Sun Feb 3 08:34:57 CST 2008
default 0
timeout 8
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title ONLY HDC
root (hd0,1)
kernel /boot/vmlinuz-2.6.22.16-0.1-default root=/dev/sda2 vga=0x314 resume=/dev/sda2 splash=silent showopts
initrd /boot/initrd-2.6.22.16-0.1-default

###Don't change this comment - YaST2 identifier: Original name: linux###
title HDC and HDA
root (hd0,1)
kernel /boot/vmlinuz-2.6.22.16-0.1-default root=/dev/sdb2 vga=0x314 resume=/dev/sdb2 splash=silent showopts
initrd /boot/initrd-2.6.22.16-0.1-default
 
Old 02-03-2008, 05:53 PM   #5
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
I don't understand your new question, if it is a question. So you have a removable IDE drive? Just boot up your SuSE, and then mount it to some directory. You don't need GRUB to do that. Look in your /etc/fstab, or manually do it yourself. What is your question exactly?
 
Old 02-04-2008, 10:14 AM   #6
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: SUSE 10.3, Microware OS-9, Caldera 2.4
Posts: 223

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Micro420 View Post
I don't understand your new question, if it is a question. So you have a removable IDE drive? Just boot up your SuSE, and then mount it to some directory. You don't need GRUB to do that. Look in your /etc/fstab, or manually do it yourself. What is your question exactly?
There was no question.

I was merely pointing out that when there is an HDA drive in place the boot drive (HDC) is addressed as /dev/sdb and when there is no HDA the boot drive (HDC) is addressed as /dev/sda. This requires two boot options in the menu. With SUSE 10.2 the same option would apply to both conditions, as the reference to the boot drive was physical (i.e. /dev/hdc) and did not change when an HDA drive was present.
 
  


Reply

Tags
online, update


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
online update failure jmgleason Suse/Novell 3 11-02-2006 12:44 AM
Suse 9.1 Online Update Problem - System wont boot bmaher292 Linux - Software 2 04-12-2006 04:30 AM
Online Kernel update - now can't boot! damm Suse/Novell 6 02-15-2006 09:16 AM
Online Update Failure of 3 programs cousinlucky Linux - Newbie 4 12-20-2005 03:26 PM
9.2 Pro won't boot into GUI after YOU (online update) Steerpike Suse/Novell 3 11-27-2004 06:53 PM


All times are GMT -5. The time now is 11:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration