LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 04-09-2007, 10:37 AM   #1
zzzbk2002
LQ Newbie
 
Registered: Apr 2007
Posts: 2

Rep: Reputation: 0
10.2 OpenSUSE on a Dell Latitude 620- Cant get 1440x900 resolution


Hi,

Hope you can help.

Graphics Card: Intel 945 GM

Just installed 10.2 OpenSUSE on a Dell Latitude 620.

I am using the i810 driver. I can not get 1440x900 resolution. In fact I can not get anything better than 1024x768.
Every time I run YASt and attempt to change the resolution my laptop crashes after I select Save or Cancel on the xfine utility.


xorg.conf follows:
# /.../
# SaX generated X11 config file
# Created on: 2007-04-09T23:56:09+1000.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
FontPath "unix/:7100"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
Load "dri"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "9"
Option "Device" "/dev/input/mice"
Option "Name" "Dell Premium USB Optical Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[3]"
Option "AccelFactor" "0.1"
Option "BottomEdge" "650"
Option "Buttons" "5"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
Option "CircularScrolling" "1"
Option "Device" "/dev/input/mice"
Option "EdgeMotionMaxSpeed" "15"
Option "EdgeMotionMinSpeed" "15"
Option "Emulate3Buttons" "on"
Option "EmulateMidButtonTime" "75"
Option "FingerHigh" "15"
Option "FingerLow" "14"
Option "HorizScrollDelta" "20"
Option "InputFashion" "Mouse"
Option "LeftEdge" "120"
Option "MaxSpeed" "3"
Option "MaxTapMove" "110"
Option "MaxTapTime" "180"
Option "MinSpeed" "0.2"
Option "Name" "ALPS;Touchpad"
Option "Protocol" "auto-dev"
Option "RightEdge" "830"
Option "SHMConfig" "on"
Option "TopEdge" "120"
Option "UpDownScrolling" "1"
Option "Vendor" "Sysp"
Option "VertScrollDelta" "20"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
DisplaySize 304 190
HorizSync 29-62
Identifier "Monitor[0]"
ModelName "YY265 141WX1 LCD MONITOR"
Option "DPMS"
VendorName "LPL"
VertRefresh 43-60
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1280x800" 83.46 1280 1344 1480 1680 800 801 804 828
Modeline "1280x800" 69.75 1280 1328 1360 1440 800 803 809 823 +HSync -Vsync
Modeline "1280x768" 80.14 1280 1344 1480 1680 768 769 772 795
Modeline "1280x768" 67.00 1280 1328 1360 1440 768 771 778 790 +HSync -Vsync
Modeline "1024x768" 64.11 1024 1080 1184 1344 768 769 772 795
Modeline "1024x768" 55.00 1024 1072 1104 1184 768 771 775 790 +HSync -Vsync
Modeline "1280x600" 61.50 1280 1336 1464 1648 600 601 604 622
Modeline "1280x600" 52.50 1280 1328 1360 1440 600 603 613 619 +HSync -Vsync
Modeline "1024x600" 48.96 1024 1064 1168 1312 600 601 604 622
Modeline "1024x600" 43.00 1024 1072 1104 1184 600 603 613 619 +HSync -Vsync
Modeline "800x600" 38.22 800 832 912 1024 600 601 604 622
Modeline "800x600" 34.75 800 848 880 960 600 603 607 617 +HSync -Vsync
Modeline "768x576" 34.96 768 792 872 976 576 577 580 597
Modeline "768x576" 32.25 768 816 848 928 576 579 583 593 +HSync -Vsync
Modeline "640x480" 23.86 640 656 720 800 480 481 484 497
Modeline "640x480" 23.25 640 688 720 800 480 483 487 494 +HSync -Vsync
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "945 GM"
BusID "0:2:0"
Driver "i810"
Identifier "Device[0]"
Option "NoDDC"
VendorName "Intel"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
InputDevice "Mouse[3]" "SendCoreEvents"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection


Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection
 
Old 04-10-2007, 03:32 AM   #2
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Unfortunately I can't help too much, but I know for a fact that SuSE will work with a Latitude D620 because I had one at work and I got my display to go 1440x900.

Try booting with no X-server and run yast as root at the terminal and see if you can configure it from there.
 
Old 04-12-2007, 03:25 AM   #3
zzzbk2002
LQ Newbie
 
Registered: Apr 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks for your reply Micro420.

2 questions if possible.
1. Do you have the WXGA+ model of the Dell Latitude 620 ? On further investigation it seems I have only the WXGA model which is only capable of 1280 x 800 resolution.
2. Have you encountered the crashing/freezing I discussed above ?

thanks
bill
 
Old 08-15-2007, 08:24 AM   #4
lyaskov
LQ Newbie
 
Registered: Aug 2007
Posts: 3

Rep: Reputation: 0
Hey guys,

I have the same problem with my Acer 5610Z with integrated Intel graphics - the maximum resolution I can set in openSUSE 10.2 is 1024x768 and it should be atleast 1280x800... can you help me?

Thanks in advance!

Viktor
 
Old 08-15-2007, 04:49 PM   #5
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Rep: Reputation: 30
Quote:
Originally Posted by zzzbk2002 View Post
Thanks for your reply Micro420.

2 questions if possible.
1. Do you have the WXGA+ model of the Dell Latitude 620 ? On further investigation it seems I have only the WXGA model which is only capable of 1280 x 800 resolution.
2. Have you encountered the crashing/freezing I discussed above ?

thanks
bill
This seems to be the right answer here..

After looking at your Xorg.conf, SAX configured everything correctly, the only issue is your hardware is limited by the resolution it supports.. Being WXGA and not WXGA+ .. There are different models
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dell latitude D620 red hat 4 - screen resolution olivomartino Linux - Hardware 4 01-30-2007 11:56 AM
Dell Latitude C810 Resolution Problems alan surry Linux - Laptop and Netbook 0 10-02-2006 08:53 AM
Video resolution problems with Fedora on Dell Latitude C800 Indref Linux - Newbie 1 09-11-2006 09:20 AM
Slackware on Dell Latitude CPi D300XT has Wrong Resolution, No Touchpad arew264 Slackware 4 01-21-2006 12:49 AM
Display Resolution Dell Latitude 610 with Suse 9.2 edualfaia Linux - Laptop and Netbook 1 09-27-2005 11:04 AM


All times are GMT -5. The time now is 06:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration