LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 12-17-2006, 11:41 AM   #1
NDR008
Member
 
Registered: Nov 2006
Location: (Bristol or Coventry) (UK) or Malta
Distribution: openSUSE 11.0
Posts: 170

Rep: Reputation: 30
10.2 no more auto wifi?


When I boot my laptop on 10.1, as soon as I used to turn my wifi switch on (on my laptop) KNetworkManager used to notify me of the change and what networks are avaialable.

Now on 10.2, unless I boot my PC with the switch on, I am never allowed to connect to a WiFi source at a later stage.

10.2 was dissapointing to me, I think i prefer 10.1...

Oh and KWiFi detects the networks, but doesn't let me switch to them either.

Last edited by NDR008; 12-17-2006 at 11:45 AM.
 
Old 12-18-2006, 08:45 AM   #2
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
So your saying that you laptop doesnt let you connect to wireless, when you boot the computer, with wireless turned off?

What exactly is the problem here? Just leave it on! It's not like your carrying world altering super secret spy information around on your laptop that you need it off, is it?

Have you tried booting with wireless on, then turning it off again after it's fully booted?
 
Old 12-18-2006, 01:47 PM   #3
NDR008
Member
 
Registered: Nov 2006
Location: (Bristol or Coventry) (UK) or Malta
Distribution: openSUSE 11.0
Posts: 170

Original Poster
Rep: Reputation: 30
it works if i boot with the wireless on, but not if i boot with it off. Before I could switch the wireless on after it boots.

Leaving it on is not the solution - but a temporary fix. I like things to work as intended :P
 
Old 12-18-2006, 02:50 PM   #4
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
And what about turning it off after you boot? And yes, it is a solution. It was intended to work, with windows They didn't have linux in mind when they made the wireless switch, wether it's worked in the past or not.
 
Old 12-19-2006, 04:00 AM   #5
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Rep: Reputation: 30
Quote:
Originally Posted by NDR008
it works if i boot with the wireless on, but not if i boot with it off. Before I could switch the wireless on after it boots.

Leaving it on is not the solution - but a temporary fix. I like things to work as intended :P
I have to agree with this.. as my problem is even worse than yours.

In 10.0 I could connect to any wireless network I wanted, and turn the wireless on and off with the button on my laptop easily. However, I installed Suse 10.2 and now my wireless connection won't work at all! The button on my laptop is not working, the LED light doesn't come on and I can't connect no matter what I do!
Sounds like a bug to me....
 
Old 12-19-2006, 04:31 AM   #6
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Rep: Reputation: 30
I just fiddled with ndiswrapper some more and it connected!! I'll post more details later when I've played with it some more.
 
Old 12-21-2006, 10:33 AM   #7
upsangel
LQ Newbie
 
Registered: Sep 2005
Posts: 9

Rep: Reputation: 0
Good news!!!!!!!!
I have the same problem with my HP v3172, the led for wifi is flashing which frighten me!!!
I just come across other article that talk about ndiswrapper, i hope you can present your approach to your wifi with this software.
In fact my Suse 10.2 just failed booting, and i am using XP now. Hope i can return to Suse soon!
 
Old 12-21-2006, 05:20 PM   #8
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Rep: Reputation: 30
Seems my laptop needed ndiswrapper to run the Wifi properly. It was fine in 10.0 and after updating it stopped working.

I logged on as root in a terminal and typed ndiswrapper -l :
Quote:
AHBlaptop:/home/adrian # ndiswrapper -l
installed drivers:
bcmwl5 driver installed, hardware (14E4:4320) present (alternate driver: bcm43xx)
I then typed ndiswrapper -ma to write module alias configuration for all devices (don't ask me to explain, I read the manual and did what it said!!)

My computer then connected immediately on rebooting it. No problem since.

Hope this helps!

(PS If ndiswrapper -l DOESN'T show driver and hardware present, you need to install the driver)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
auto logon wifi SUSE10.1 beerten Linux - Laptop and Netbook 1 11-06-2006 06:11 AM
Best WiFi PCI (or else) card in general for Linux and WiFi network experimentation? ICEMANII Linux - Wireless Networking 2 09-21-2006 05:50 PM
Ralink WIFI with Asus@Home WIFI wavemachine Linux - Hardware 0 10-20-2004 04:10 PM
auto-completion - how does it work & can my script args auto-complete? BrianK Programming 1 06-11-2004 05:51 PM
autofs enabled in kernel but auto.mount and auto.master are NOT in /etc! Alybyzrp Linux - General 0 11-11-2003 01:26 PM


All times are GMT -5. The time now is 11:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration