LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 10-16-2004, 12:07 PM   #1
Dannyarr
Member
 
Registered: Sep 2004
Distribution: Arch Linux
Posts: 40

Rep: Reputation: 15
Unhappy [9.1 pro] Apache, MySQL & PHP ... not working!


Well as the topic name says i cant get this to work. I have SuSE installed on my second pc that isnt connected to the internet atm. It has 2 network cards though. The system specs are:

ASUS A7N8X-DELUXE
AMD Athlon XP 2200+
512MB DDR333
ASUS ATI Radeon 9600XT/TD
160GB WDD SATA HDD
LG DVD-RW

Anyway i installed SuSE and everything is working and such except for apache. I installed all things related to apache and mysql i could find in the install/remove software section. When i try to activate Apache over YAST it doesnt gimme any errors (or i dont see em?!) and then when i open a browser and type in localhost or 127.0.0.1 it isnt showing up anything, gives me a error that the connection failed or so.

Not to mention mysql, i dont have a clue where to even start with that. Im pretty new to linux and everything runs fine except that, which is one of the most important things for me since i want that machine to be for some local testing of my new webpage and such.

Is there any tutorial or something which would in detail explain me how to set it all up and running. I really dont have a clue why apache isnt working, is there some error log or so that i can look at? I dont know where those are located otherwise i would post em here.

Is the problem with the apache maybe caused by my network cards? My MB has 2 network cards onboard and i didnt configure either of them since i dont use them atm. Or is there maybe some update i need to download from the suse webby to get apache working? Dont tell me to use YOU cuz i cant since the computer has no access to internet atm. I also thought about the version of apache and mysql in SuSE. Where can i check those? And is it maybe wiser to download them from their websites and install them from there instead the suse dvd?



I would apriciate any help,

Thx in advance


LD
 
Old 10-16-2004, 07:14 PM   #2
RJDavis
LQ Newbie
 
Registered: Oct 2004
Location: Fairbanks AK
Distribution: Slackware 9.1
Posts: 2

Rep: Reputation: 0
I've got the same problem, but after a bit of searching, I found out how to activate Apache... it's easy:

Log in as root.

At the command prompt, type "httpd"

In your browser, pages are served from http://127.0.0.1/

I'm using Slackware 9.1, so this might be different for you, but my pages are served from "/var/www/htdocs".

If you figure anything out on the PHP and MySQL aspect, lemme know, because I'm currently clueless.

Catch ya later,
 
Old 10-17-2004, 01:30 AM   #3
tishamp
LQ Newbie
 
Registered: Mar 2004
Posts: 5

Rep: Reputation: 0
The apache and PHP

Hi I can activate Apache using the the Apache2ctl command but I can't get my PHP pages which just print stuff to display, any help here? Also any extensions available with apache for JSP?
Regards,
Tisham.
 
Old 10-17-2004, 03:27 AM   #4
Dannyarr
Member
 
Registered: Sep 2004
Distribution: Arch Linux
Posts: 40

Original Poster
Rep: Reputation: 15
I found a great guide that solved all my probs:

http://www.coolsolutions.com/forums/...pic.php?t=1997

 
Old 10-17-2004, 01:54 PM   #5
RJDavis
LQ Newbie
 
Registered: Oct 2004
Location: Fairbanks AK
Distribution: Slackware 9.1
Posts: 2

Rep: Reputation: 0
Out-Standing! Thanks a million, LD!
 
Old 10-17-2004, 02:42 PM   #6
Dannyarr
Member
 
Registered: Sep 2004
Distribution: Arch Linux
Posts: 40

Original Poster
Rep: Reputation: 15
Dont thank me, thank google And the guy who wrote it ofcourse I think they should make a link to this somewhere on these forums, in some sticky or so. I have yet to see any easier and better tutorial to set apache, php and mysql running on suse. And i bothered with it quite a while
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware guide for AMP Apache MySQL & PHP xushi Slackware 35 05-11-2006 11:18 AM
Apache not working after installing mysql and php alaateb Linux - Networking 6 04-22-2005 09:24 AM
php, mysql, apache not working together like expected atheist Debian 2 09-06-2004 11:48 AM
From RedHat9 to FreeBSD (Apache 2 & Mysql & PHP 4) guardian653 *BSD 5 12-11-2003 05:31 PM
PHP not working with Apache, nor mysql wldkos Linux - Software 18 05-16-2003 12:23 PM


All times are GMT -5. The time now is 09:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration