LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Solaris / OpenSolaris (http://www.linuxquestions.org/questions/solaris-opensolaris-20/)
-   -   Update Manager gives Unable to locate JRE meeting specification "1.5+" (http://www.linuxquestions.org/questions/solaris-opensolaris-20/update-manager-gives-unable-to-locate-jre-meeting-specification-1-5-a-4175458606/)

Mark_667 04-18-2013 05:16 AM

Update Manager gives Unable to locate JRE meeting specification "1.5+"
 
I'm trying to update a Solaris 10 x86 test system to get it to a specific patch level but running the updatemanager command gives
Quote:

Unable to locate JRE meeting specification "1.5+"
Running /usr/sbin/smpatch analyze gives the same error.

I had been getting:
# updatemanager
/usr/bin/updatemanager: /usr/jdk/latest/bin/java: not found
but looking in /usr/jdk/ latest was a symlink to a 1.5 JRE install no longer present. I deleted the symlink, created a latest dir and a bin dir under that. In the bin dir I created a symlink to the java executible of a 1.6 install but for some reason it doesn't think it's 1.5 or later although running a java -version on it says it's 1.6. What's going on here?


All times are GMT -5. The time now is 09:05 AM.