LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices



Reply
 
Search this Thread
Old 05-11-2005, 05:36 AM   #1
zillah
Member
 
Registered: Oct 2004
Posts: 532

Rep: Reputation: 30
Unable to access home directory


As admin, I created user account called "forum", with password "forum", I tried to access user account, by logging out from admin account and relogin as user "forum", I received this error message:

"Unable to access home directoy. Click OK to start a Failsafe session, or Cancel to restart login"

Last edited by zillah; 05-11-2005 at 05:46 AM.
 
Old 05-11-2005, 06:07 AM   #2
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 50
Re: Unable to access home directory

Quote:
Originally posted by zillah
As admin, I created user account called "forum", with password "forum", I tried to access user account, by logging out from admin account and relogin as user "forum", I received this error message:

"Unable to access home directoy. Click OK to start a Failsafe session, or Cancel to restart login"
maybe as admin you can create a home directory for your user.
 
Old 05-11-2005, 06:22 AM   #3
zillah
Member
 
Registered: Oct 2004
Posts: 532

Original Poster
Rep: Reputation: 30
Quote:
maybe as admin you can create a home directory for your user.
I created home directory for the user in /export/home, but still the same problem

Last edited by zillah; 05-11-2005 at 06:24 AM.
 
Old 05-11-2005, 10:23 AM   #4
zillah
Member
 
Registered: Oct 2004
Posts: 532

Original Poster
Rep: Reputation: 30
This guy has got same my problem:

http://supportforum.sun.com/sunos/in...e47ab1d8d7712e
 
Old 05-11-2005, 01:55 PM   #5
zillah
Member
 
Registered: Oct 2004
Posts: 532

Original Poster
Rep: Reputation: 30
I edit the /etc/passwd file, and I changed the "/home/forum" to "/export/forum" (replace home to export).

Note:
forum is the home directory for the user forum.

I was able to get rid of this message:

"Unable to access home directoy. Click OK to start a Failsafe session, or Cancel to restart login".

But then I received another message, I have not recorded that message (because I am far away from my unix box right now)

Last edited by zillah; 05-11-2005 at 01:59 PM.
 
Old 05-11-2005, 04:58 PM   #6
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,523

Rep: Reputation: 365Reputation: 365Reputation: 365Reputation: 365
This is not the best way to solve the issue.

First home directories should be in /export/home/<username>, not directly under /export, this is not mandatory, but is a convention with Solaris.

Second, home directories should be accessed through /home/<username>, this has been the common usage since the beginning of unix development.

To achieve that, you just have to add a line like this in the /etc/auto_home file:
<username> <hostname>:/export/home/<username>
e.g.:
forum mypc:/export/home/forum

or if you have a bunch of users:

* mypc:/export/home/&

The goal is to prepare the feature of sharing user's home directories between several hosts through NFS.

Last edited by jlliagre; 05-12-2005 at 02:54 AM.
 
Old 05-12-2005, 12:40 AM   #7
zillah
Member
 
Registered: Oct 2004
Posts: 532

Original Poster
Rep: Reputation: 30
Quote:
First home directories should be in /export/home/<username>, not directly under /export, this is not mandatory, but is a convention with Solaris.
Yes you are right, this was mistyping from me.
Quote:
I created home directory for the user in /export/home, but still the same problem
 
Old 05-12-2005, 02:53 AM   #8
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,523

Rep: Reputation: 365Reputation: 365Reputation: 365Reputation: 365
What same problem ?
Is forum owning the /export/home/forum directory ?
Did you modify the auto_home file as I suggested ?
 
Old 05-14-2005, 03:10 AM   #9
zillah
Member
 
Registered: Oct 2004
Posts: 532

Original Poster
Rep: Reputation: 30
# cat /etc/passwd###########Just I diplayed the /etc/passwd to see the users
root:x:0:0:Super-User:/:/sbin/sh
daemon:x:1:1::/:
bin:x:2:2::/usr/bin:
sys:x:3:3::/:
adm:x:4:4:Admin:/var/adm:
lp:x:71:8:Line Printer Admin:/usr/spool/lp:
uucp:x:5:5:uucp Admin:/usr/lib/uucp:
nuucp:x:9:9:uucp Admin:/var/spool/uucppublic:/usr/lib/uucp/uucico
smmsp:x:25:25:SendMail Message Submission Program:/:
listen:x:37:4:Network Admin:/usr/net/nls:
gdm:x:50:50:GDM Reserved UID:/:
webservd:x:80:80:WebServer Reserved UID:/:
nobody:x:60001:60001:NFS Anonymous Access User:/:
noaccess:x:60002:60002:No Access User:/:
nobody4:x:65534:65534:SunOS 4.x NFS Anonymous Access User:/:
forum:x:100:1::/home/forum:/bin/sh
forum1:x:101:1::/home/forum1:/bin/sh
forum2:x:102:1::/home/forum2:/bin/sh



gedit /etc/auto_home
# Copyright 2003 Sun Microsystems, Inc. All rights reserved.
# Use is subject to license terms.
#
# ident "@(#)auto_home 1.6 03/04/28 SMI"
#
# Home directory map for automounter
#
+auto_home
forum 193.225.160.177:/export/home/forum ######I added this line
forum1 193.225.160.177:/export/home/forum1 ######I added this line
forum2 193.225.160.177:/export/home/forum2 ######I added this line


I created manually these users in the /export/home

mkdir /export/home/forum
mkdir /export/home/forum1
mkdir /export/home/forum2

# ls /export/home
forum forum1 forum2

Still I can not access as normal user ?
Do I need to create symbolic link between /export/home and /home?

Is there any thing else I have to do

Last edited by zillah; 05-26-2005 at 01:49 AM.
 
Old 05-19-2005, 01:27 AM   #10
zillah
Member
 
Registered: Oct 2004
Posts: 532

Original Poster
Rep: Reputation: 30
Any other advice I have to be aware or try?
 
Old 05-19-2005, 04:41 AM   #11
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,523

Rep: Reputation: 365Reputation: 365Reputation: 365Reputation: 365
You need to NFS share the user's home directories.

file /etc/dfs/dfstab :

share -F nfs -o rw -d "home directories" /export/home

run this command as is too or reboot to enable the NFS service.

Last edited by jlliagre; 05-19-2005 at 04:42 AM.
 
Old 05-19-2005, 06:26 AM   #12
zillah
Member
 
Registered: Oct 2004
Posts: 532

Original Poster
Rep: Reputation: 30
Quote:
You need to NFS share the user's home directories.
I am going to try what you have suggested, but could you please tell me why do we have to share the user's home directories?
 
Old 05-19-2005, 09:19 AM   #13
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,523

Rep: Reputation: 365Reputation: 365Reputation: 365Reputation: 365
I think the way you specified the home directory location (by its IP address) implies NFS will be used to access it.

It would probably had worked without the need to launch the NFS service should you use the hostname instead of the IP address, but this is just a guess.

Anyway, the automounter is showing its full interest when the user's home directories is unique, whatever the server the user is connected to, and this implies NFS is enabled.
 
Old 05-26-2005, 02:10 AM   #14
zillah
Member
 
Registered: Oct 2004
Posts: 532

Original Poster
Rep: Reputation: 30
Quote:
You need to NFS share the user's home directories.

file /etc/dfs/dfstab :

share -F nfs -o rw -d "home directories" /export/home
I tried this:
# share -F nfs -o rw -d 193.225.160.177/export/home
Output was:
Usage: share [-o options] [-d description] pathname [resource]

Am I doing the right thing ? Is there some thing wrong the command ?

Last edited by zillah; 05-29-2005 at 12:24 AM.
 
Old 05-26-2005, 02:42 AM   #15
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,523

Rep: Reputation: 365Reputation: 365Reputation: 365Reputation: 365
This is what I suggested:
Quote:
share -F nfs -o rw -d "home directories" /export/home
This is what you tried:
Quote:
share -F nfs -o rw -d 193.225.160.177/export/home
Hmm, look closer to find if some difference exists ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
programs have no access to home directory. SnowSurfAir Linux - Software 4 07-14-2005 01:05 AM
unable to Mount server home directory to clients abhishek124 Linux - Networking 1 06-24-2005 03:44 AM
Others should not access my home directory. u4u Linux - General 3 01-16-2005 10:28 AM
apache unable to access /home/*/public_html directory cavemanf16 Linux - Software 6 07-08-2004 06:43 AM
Access denied to 'Home' directory aviceda Linux - Newbie 2 11-07-2003 02:48 PM


All times are GMT -5. The time now is 12:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration