LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices

Reply
 
Search this Thread
Old 03-02-2010, 12:11 PM   #1
mjolnir
Member
 
Registered: Apr 2003
Posts: 680

Rep: Reputation: 68
Terminal Bug/Fix


I updated from build 131 to build 133 this morning. Everything seemed fine until I tried to use the terminal. Key presses weren't echoed, garbage output.
The second procedure below seems to have fixed it.






carl@opensolaris:~$ SunOS opensolaris 5.11 snv_133 i86pc i386 i86pc Solaris

WARNING! My build 133 became unstable soon after I applied this fix. http://www.linuxquestions.org/questi...ld-133-792922/ I am not sure why just now.
readline: warning: turning off output flushing
carl@opensolaris:~$ \N\A\M\E \U\S\E\D \A\V\A\I\L \R\E\F\E\R \M\O\U\N\T\P\O\I\N\T
rpool 18.7\G 49.7\G 85\K /rpool
rpool/\R\O\O\T 16.5\G 49.7\G 21\K legacy
rpool/\R\O\O\T/opensolaris 184\M 49.7\G 4.57\G /
rpool/\R\O\O\T/opensolaris-1 27.6\M 49.7\G 5.53\G /
rpool/\R\O\O\T/opensolaris-2 19.4\M 49.7\G 5.97\G /
rpool/\R\O\O\T/opensolaris-3 42.4\M 49.7\G 6.81\G /
rpool/\R\O\O\T/opensolaris-4 16.3\G 49.7\G 6.81\G /
rpool/dump 1019\M 49.7\G 1019\M -
rpool/export 144\M 49.7\G 23\K /export
rpool/export/home 144\M 49.7\G 23\K /export/home
rpool/export/home/carl 144\M 49.7\G 144\M /export/home/carl
rpool/swap 1019\M 50.6\G 106\M -
readline: warning: turning off output flushing
carl@opensolaris:~$ carl@opensolaris:~$ bash: adm: command not found
carl@opensolaris:~$ BE Active Mountpoint Space Policy Created
-- ------ ---------- ----- ------ -------
opensolaris - - 184.30M static 2009-02-09 10:23
opensolaris-1 - - 27.57M static 2009-03-21 12:43
opensolaris-2 - - 19.40M static 2009-03-28 12:20
opensolaris-3 - - 42.44M static 2009-05-02 09:15
opensolaris-4 NR / 19.91G static 2010-03-02 05:06
CARL@OPENSOLARIS:~$


carl@opensolaris:~$ crw------- 1 root sys 11, 9 2010-03-02 05:41 /dev/ptmx
readline: warning: turning off output flushing
carl@opensolaris:~$
http://sunfunlogs.blogspot.com/
My shell doesn't get inputs.
"It could happen that, after system upgrade or "hacking", your terminal emulator like gnome-terminal maybe presents a message like this:

readline: warning turning off output flushing

The solution may be the following: it is necessary to check the rights on pseudo terminal pseudo-device:

marco@IbmSolaris:~$ ls -lL /dev/ptmx

If the output you get is not the same like this

crw-rw-rw- 1 root sys 11, 8 2010-01-26 15:31 /dev/ptmx

you should be able to use xterm to change them. See man pty for more."


http://opensolaris.org/jive/thread.j...61835&tstart=0
Re: [osol-discuss] Gnome-terminal broken after update from build 111b to build 133
Posted: Feb 26, 2010 5:20 AM in response to: cjpeliss


Click to reply to this thread Reply

On 26/02/2010 13:15, Christian Pélissier wrote:

> On a DELL LATITUDE D630 and after upgrading from 111b to 133 gnome terminal is broken. When booting build 133 GDM is OK. After login it's impossible to work with gnome-terminal.

"Hit that myself, it's in the release notes:

2380 image-update loses /dev/ptmx from /etc/minor_perm
http://defect.opensolaris.org/bz/show_bug.cgi?id=12380

When using image-update or the Package Manager to update to
build 125 or greater, remote access to the system via ssh(1) or
rlogin(1) may become unavailable. Alternatively, using
terminal programs such as gnome-terminal(1) or xterm(1) may
result in characters not being echoed or commands unable to be
typed.

Work-around: Boot the original boot environment (BE) instead
and correct the /etc/minor_perm file contained within as
follows

<reboot into the earlier BE>
user@host$ pfexec beadm mount <name of new BE> /mnt
user@host$ pfexec sh -c \
"grep ^clone: /etc/minor_perm >> /mnt/etc/minor_perm"
user@host$ pfexec touch /mnt/reconfigure
user@host$ pfexec bootadm update-archive -R /mnt
user@host$ pfexec beadm unmount <name of new BE>

At this point, the new BE can be booted into."

--
Alan Burlison
--
_______________________________________________
opensolaris-discuss mailing list
opensolaris-discuss at opensolaris dot org


http://theintersect.org/2009/opensolaris-workarounds/

readline warning turning off output flushing
This is a bug triggered by an upgrade from the 2009.06 stable to certain dev versions. Add clonetmx 0666 root sys to /etc/minor_perm

I ended up trying the mount/unmount procedure from Mr. Burlison and the terminal seems to be working now.
carl@opensolaris:~$ uname -a
SunOS opensolaris 5.11 snv_133 i86pc i386 i86pc Solaris
carl@opensolaris:~$ beadm list
BE Active Mountpoint Space Policy Created
-- ------ ---------- ----- ------ -------
opensolaris - - 184.30M static 2009-02-09 10:23
opensolaris-1 - - 27.57M static 2009-03-21 12:43
opensolaris-2 - - 19.40M static 2009-03-28 12:20
opensolaris-3 - - 53.38M static 2009-05-02 09:15
opensolaris-4 NR / 19.92G static 2010-03-02 05:06
carl@opensolaris:~$ zfs list
NAME USED AVAIL REFER MOUNTPOINT
rpool 18.7G 49.7G 85K /rpool
rpool/ROOT 16.6G 49.7G 21K legacy
rpool/ROOT/opensolaris 184M 49.7G 4.57G /
rpool/ROOT/opensolaris-1 27.6M 49.7G 5.53G /
rpool/ROOT/opensolaris-2 19.4M 49.7G 5.97G /
rpool/ROOT/opensolaris-3 53.4M 49.7G 6.81G /
rpool/ROOT/opensolaris-4 16.3G 49.7G 6.81G /
rpool/dump 1019M 49.7G 1019M -
rpool/export 144M 49.7G 23K /export
rpool/export/home 144M 49.7G 23K /export/home
rpool/export/home/carl 144M 49.7G 144M /export/home/carl
rpool/swap 1019M 50.6G 106M -
carl@opensolaris:~$

Last edited by mjolnir; 03-05-2010 at 11:02 AM. Reason: Possible problems with fix.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New src2pkg bug-fix version gnashley Slackware 29 01-08-2010 03:56 PM
how to do the Patch update and bug fix in AS 3.0? sathyguy Linux - Enterprise 3 08-31-2006 07:44 AM
Bug Fix Ctp. Obvious Linux - Newbie 5 08-02-2004 07:58 AM
Bug fix update for 10.0 akihandyman Mandriva 3 07-14-2004 05:13 PM
bug in RPM, but how to fix? bearcatsandor Linux - Software 2 12-06-2001 07:34 PM


All times are GMT -5. The time now is 09:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration