LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices

Reply
 
Search this Thread
Old 05-24-2009, 12:38 PM   #1
crisostomo_enrico
Member
 
Registered: Dec 2005
Location: Madrid
Distribution: Solaris 10, Solaris Express Community Edition
Posts: 547

Rep: Reputation: 35
SXCE b114: cannot boot into failsafe mode


Hi!

After live upgrading Nevada from 113 to 114 I started VirtualBox and hit this bug: http://www.virtualbox.org/ticket/3981 and as a consequence the system paniced. As a workaround I substituted the VBox kernel module. I didn't reboot and the system paniced another time. During the subsequent startup the system told me to boot into failsafe mode to fix the boot archive and when I did that I got the following message:
Code:
krtld: bind_primary(): no relocation information found for module /plaftorm/i86pc/kernel/amd64/unix
krtld: error during initial load/link phase

krtld could neither locate nor resolve symbols for:
    /plaftorm/i86pc/kernel/amd64/unix
in the boot archive. Please verify that this file
matches what is found in the boot archive.
You may need to boot using the Solaris failsafe to fix this.
Unable to boot
Press any key to reboot.
I don't know if those system panics could affect the miniroot but I don't feel comfortable working without an available failsafe image. Is there any way to restore it?

Thanks,
Enrico
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can only boot in failsafe mode... st4rz Suse/Novell 4 07-25-2007 10:23 AM
SUSE 10.1 boot gives Black Screen in Failsafe mode salukidawgs Linux - Desktop 1 09-05-2006 12:24 PM
No Video in X, Unless ..... Sax2 is ran in failsafe mode on each boot pfx Linux - Newbie 2 06-26-2005 08:09 PM
after booting screen goes blank and will not boot in failsafe mode suse 9.1 personal hairy5050 Linux - Software 2 02-19-2005 10:36 PM
how can I boot windows in "failsafe" mode with LILO? julian_s Linux - Newbie 5 01-19-2004 10:13 AM


All times are GMT -5. The time now is 06:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration