LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices



Reply
 
Search this Thread
Old 09-16-2005, 09:28 AM   #1
tets
LQ Newbie
 
Registered: Aug 2005
Location: Prague, Czech Rep.
Distribution: Debian
Posts: 22

Rep: Reputation: 15
SSH login timeout - too short


Hi,

I've got following problem:

When I try to login remotely via SSH to my Solaris 10 server (with sshd installed on it), connection is closed before I can type the password. If I type my pass within 5 or 10 seconds, it connects OK.

There is no timeout set in "/etc/default/login" (#TIMEOUT=300), so I assume default value (300 sec.) is used.
Also nothing is set in "/etc/ssh/sshd_config", so I hope default value (600 sec.) is used. In "sshd_config" is rule "KeepAlive yes".

I'm using IPfilter as a firewall. There is a rule
"pass in quick on bge0 proto tcp from any to any port = 22 keep state"
to allow SSH connection from everywhere.

Where to change this login timeout? Do you have any ideas?

Thanks for any help.

Tets
tets(at)seznam.cz
 
Old 09-16-2005, 09:55 AM   #2
reddy_pradeep
LQ Newbie
 
Registered: Feb 2004
Posts: 4

Rep: Reputation: 0
please remove comment before #TIMEOUT=300 in /etc/default/login

i hope this will work now for 300sec
 
Old 09-16-2005, 10:01 AM   #3
reddy_pradeep
LQ Newbie
 
Registered: Feb 2004
Posts: 4

Rep: Reputation: 0
hi
i have doubt on ipv6 filtering using ipfilter in solaris 10.
could you please answer my question on ipv6 filtering?

thnx in advance
 
Old 09-18-2005, 07:20 AM   #4
tets
LQ Newbie
 
Registered: Aug 2005
Location: Prague, Czech Rep.
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 15
Hi reddy_pradeep,

thanks for fast response, but it did't help :-(

About IPv6: I use only IPv4, so i can't help you. I'm quite a neewbie to these things. Sorry for that...

Tets
 
Old 09-19-2005, 04:34 AM   #5
tets
LQ Newbie
 
Registered: Aug 2005
Location: Prague, Czech Rep.
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 15
Problem solved!

I was blind. There is another option in "sshd_config" file - "LoginGraceTime". It was set to 10. After changing this value to 300, it works OK.
Sorry for bothering...

Tets :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 10 login fails after short time Daniel Sampsel Suse/Novell 2 12-04-2005 10:31 AM
why ssh timeout? sherifff Linux - Networking 1 05-06-2004 10:30 PM
ssh timeout RedHat 9 clinton Linux - Newbie 2 12-13-2003 07:07 AM
SSH timeout goldenmag Linux - Security 2 12-10-2003 05:06 PM
ssh timeout blackmercury Linux - General 1 06-02-2003 06:32 PM


All times are GMT -5. The time now is 10:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration